Author [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: UIA -- HowTo?  (Read 267 times)

Offline Thom

UIA -- HowTo?
« on: January 28, 2015, 02:21:18 AM »

I'm using the 0.53 linux version of the wallet and found the UIA creation interface in the GUI, but after filling in all of the fields and clicking the Create button nothing happens.

Also, it's really difficult to read the amount of the fee, is it 207.985 or 207,985 bts? I presume it's 207.

I tried the console, but had no luck with that either. Is there a way to designate which account the bts fee comes from or are they presumed to come out of the account that creating the asset?

So do I need to use the console instead of the GUI, or can a UIA be created using the GUI? I could use a little guidance from a dev or someone that's created a UIA.

« Last Edit: January 28, 2015, 02:53:47 AM by Thom »

Offline abit

Re: UIA -- HowTo?
« Reply #1 on: January 28, 2015, 03:26:50 AM »
Code: [Select]
>>> help wallet_asset_create
wallet_asset_create <symbol> <asset_name> <issuer_name> <description> <maximum_share_supply> <precision> [public_data] [is_market_issued]   Creates a new user issued asset
Creates a new user issued asset

  symbol (asset_symbol, required): the ticker symbol for the new asset
  asset_name (string, required): the name of the asset
  issuer_name (string, required): the name of the issuer of the asset
  description (string, required): a description of the asset
  maximum_share_supply (real_amount, required): the maximum number of shares of the asset
  precision (uint64_t, required): defines where the decimal should be displayed, must be a power of 10
  public_data (json_variant, optional, defaults to null): arbitrary data attached to the asset
  is_market_issued (bool, optional, defaults to false): creation of a new BitAsset that is created by shorting

Example of creating an asset with max supply of 10000000000.00 (the zeros after dot refer to precision):
Code: [Select]
wallet_asset_create MYASSET "My Asset" "my_account_name" "my asset description" 1000000000000 100
BTS account: abit
BTS committee member: abit
BTS witness: in.abit

Offline Thom

Re: UIA -- HowTo?
« Reply #2 on: January 28, 2015, 04:57:13 AM »
Still quite baffled.

First, thanks for the info abit. What you provided was that quotes are necessary around the string args when using the console. It would be nice if the max  string length were known too.

I think there's a problem with the accounts I created and are being used to create the asset.

I created 3 new accounts in this order:

1) tfreedman
2) pub.tfreedman
3) tcbr.tfreedman

After each was created it was registered and the .5 bts fee paid from a different account. If you look at the "My Accounts" page all are listed, all show the .5 bts fee and all are shown to be registered.

When I try to use
           wallet_asset_create "SYMBOL" "tcbr.tfreedman" "My UIA description" 10000 100   
I see messages (under the bell icon in upper right corner) that say tbcr.tfreedman account does not exist, similar to when I try to transfer bts from one wallet account to another like this:

Code: [Select]
[email protected]:27
 ○ [email protected]:32
 ○ [email protected]:33
 ○ [email protected]:29
 ○ [email protected]:28
 ○ app.js:7
 ○ app.js:7
 ○ [email protected]:6
 ○ [email protected]:6
 ○ app.js:7
 ○ [email protected]:3
 ○ [email protected]:3
20006 unknown_account: unknown account
Unknown account name!
    bitshares  wallet.cpp:1319 get_account

    bitshares  wallet.cpp:1338 get_account

    bitshares  common_api_client.cpp:4008 wallet_transfer

I restarted the client but I still get the same results. Can someone else verify they can see those 3 accounts? If not why does my wallet show them as valid and registered?

tfreedman            public key: BTS77VcuFcKUwaAEfU9wyPUzhqdqx1HWyPHdCAXh6MZ4p3rFP6B7R
Transaction #10dd70b3      Block #1637879 , Transaction #0 , Next #1       TimeStamp: 01/27/2015 7:52 PM

pub.tfreedman    public key: BTS6KDyopKQayZtg9dmX5ob5DUQqiyYcSMzZ4zz86GkmZ71LXUE2E
Transaction #f476e7a8        Block #1637891 , Transaction #0 , Next #0       TimeStamp: 01/27/2015 7:54 PM

tcbr.tfreedman    public key: BTS7XoThtixGSUrJ6rKnMZQ9dJZMbNAba4PJxNDpmVDBT5QSNApV8
Transaction #76ae0391       Block #1637885 , Transaction #0 , Next #1       TimeStamp: 01/27/2015 7:53 PM

Offline Thom

Re: UIA -- HowTo?
« Reply #3 on: January 28, 2015, 07:14:10 AM »
I gotta say is the linux qt_wallet has some serious UIX issues to iron out before it is ready for the public.

I finally got the UIA created, but it was far from easy. I had problems getting the wallet to *fully* recognize the subaccount registration, trouble in the UI name filters (they don't work consistently), and it was a real pain to get the UI to accept tcbr.tfreedman as a valid address for fund transfer. I had to rescan the blockchain several times before the accounts were recognized.

I had success with the console, but there too it seemed to screw up the maximum shares. I requested 10000 and it used the default 1000000. Initially the fee for the UIA was 207.9xx BTS, but when I finally got it to work the fee was 500 BTS.

Reviewing the UIA on has me questioning if the asset was created properly.
« Last Edit: January 28, 2015, 07:15:56 AM by Thom »

Offline infovortice2013

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 511
    • View Profile
    • BitShares en español
  • BTS: traderx
Re: UIA -- HowTo?
« Reply #4 on: February 14, 2015, 06:21:29 PM »
this feature of UIA is working actually ???
New Keyoteeid: 5rUhuLCDWUA2FStkKVRTWYEqY1mZhwpfVdRmYEvMRFRD1bqYAL
new08/21 id 5Sjf3LMuYPSeNnjLYXmAoHj5Z6TPCmwmfXD6XwDmg27dwfQ