Author [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Unable to sync blockchain ....  (Read 300 times)

Offline karnal

Unable to sync blockchain ....
« on: March 14, 2015, 10:59:13 AM »

It's been three days and I am very frustrated.. ::)

This is 0.6.1 on Linux. Due to incorrect balance report, I reset the database which translated to "sync the whole blockchain", which, the program informed, would only "take a few minutes".

Fast forward to now, and it is still not done. It is segfaulting now and then (every day about 5 times) and does not appear ot make any actual progress. It has been stuck on a certain block for hours now. Again.

I have 7 accounts configured. Seem to recall having read somewhere that this might be a problem.

By now I have considerable funds in bitshares and can't just drop the accts and start over.

Any hints?

Offline valzav

  • Sr. Member
  • ****
  • Posts: 294
    • View Profile
Re: Unable to sync blockchain ....
« Reply #1 on: March 14, 2015, 12:35:54 PM »
Did you try 0.6.2?
Also could you run it under gdb and make it to display a stack trace after the segfault?

Offline karnal

Re: Unable to sync blockchain ....
« Reply #2 on: March 17, 2015, 05:44:57 PM »
I have not yet tried 0.6.2, a quick look over the changelog yielded no relevant bugfixes. Did I miss anything?

Running under gdb is feasible, but I do believe that the segfault is not the issue here. I got them before as well, especially after receiving transfers.. almost 100% of the time, when both accounts are in the same wallet.

Still have not succeeded fixing this. I have thought about maybe eliminating the accounts from the wallet, letting it sync, and then rescan transactions, once the accounts are re-imported.

Is this possible?

Offline vikram

Re: Unable to sync blockchain ....
« Reply #3 on: March 17, 2015, 05:52:03 PM »
We've been getting various reports of this problem, and usually if you go into your data directory and delete everything EXCEPT the "wallets" folder, most people are able to sync after that.