BitShares Forum

Main => Technical Support => Topic started by: Akado on November 07, 2015, 05:39:55 pm

Title: Claiming Balances - Can't Broadcast Transaction
Post by: Akado on November 07, 2015, 05:39:55 pm
So after importing my keys, I went to wallat management console, selected the assets listed to go to my account and when it appears to confirm a transaction which seems like the previous list of my transactions and tires to broadcast it, it fails.

(http://s22.postimg.org/uucfbsvip/Sem_T_tulo.png)
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: 38PTSWarrior on November 07, 2015, 06:02:02 pm
Same here.
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: Akado on November 07, 2015, 08:02:01 pm
[member=120]xeroc[/member]
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: xeroc on November 07, 2015, 08:16:47 pm
Issue is known. Try another browser and/or a faster computer if available right now. I suppose, the issue can be fixed by adding the expiration time after having added all claim operations @svk @jcalfee
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: Akado on November 07, 2015, 08:44:02 pm
Issue is known. Try another browser and/or a faster computer if available right now. I suppose, the issue can be fixed by adding the expiration time after having added all claim operations [member=11456]svk[/member] @jcalfee

I'm using the light client so I guess I'll have to wait
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: Akado on November 08, 2015, 06:52:43 pm
[member=120]xeroc[/member] when it's fixed could you give us an update here please? Many thanks.
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: 38PTSWarrior on November 08, 2015, 08:12:14 pm
[member=120]xeroc[/member] when it's fixed could you give us an update here please? Many thanks.
Hi Akado, I wanted to try with the light thing. It starts and then the dots never stop. When going to console it says something about backup, it passed the chain init stage. I have no idea how to import the wallet, hahaha!
But when you say that you also have trouble with this client then I shall wait maybe.
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: 38PTSWarrior on November 08, 2015, 08:13:10 pm
i Akado, I wanted to try with the light thing. It starts and then the dots never stop. When going to console it says something about backup, it passed the chain init stage. I have no idea how to import the wallet, hahaha!
But when you say that you also have trouble with this client then I shall wait maybe.
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: Akado on November 08, 2015, 09:01:01 pm
i Akado, I wanted to try with the light thing. It starts and then the dots never stop. When going to console it says something about backup, it passed the chain init stage. I have no idea how to import the wallet, hahaha!
But when you say that you also have trouble with this client then I shall wait maybe.

Could you provide prints so I know  the exact situation you're in? At the beggining I got it loading for a bit with the dots too but it eventually stopped.
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: xeroc on November 09, 2015, 12:23:32 pm
If the light client is not working for you, please try bitshares.org/wallet or openledger .. create a new account and import/claim your balance there.
It may be required to use Chrome as it is more efficient than firefox sometimes.

Worst case scenario is to use the CLI wallet to claim your balances as described in the migration guide at docs.bitshares.eu/migration
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: fav on November 09, 2015, 12:51:51 pm
no problems here with the light wallet. if it's glitched, hit ctrl+r to reload. usually helps
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: Akado on November 09, 2015, 12:59:44 pm
If the light client is not working for you, please try bitshares.org/wallet or openledger .. create a new account and import/claim your balance there.
It may be required to use Chrome as it is more efficient than firefox sometimes.

Worst case scenario is to use the CLI wallet to claim your balances as described in the migration guide at docs.bitshares.eu/migration

Thing is I already imported my keys in. I made a back up though so they should be safe. Do you know when this could be fixed? I mean, if this could be an easy fix or something that would only be done on the next big iteration you guys do like a hardfork?

[member=31]fav[/member], done that, didn't help. I will see the CLI wallet and give it a try with the commands. If I don't find the time to do so I will upload the backup into an OpenLedger account.

Am I the first guy mentioning this? Could this have an impact on other members trying to do the same?
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: xeroc on November 09, 2015, 02:03:25 pm
You are not the only one. Issue is that your bts are split across many balance ids and the wallet takes to long to construct the whole tx .. thats all (afaik)
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: Akado on November 10, 2015, 12:08:58 am
You are not the only one. Issue is that your bts are split across many balance ids and the wallet takes to long to construct the whole tx .. thats all (afaik)

Now tried on OpenLedger using Firefox and I have the same problem as other people mentioned, getting stuck on loading balance claims. Any eta you could share on a fix for this? I'm usually patient, it's just that after all this time and finally being able to access my funds and use them got me a little anxious.
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: xeroc on November 11, 2015, 08:25:04 pm
Try the cli wallet to claim into your account .. after claiming you can use the web/light wallet again
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: Akado on November 11, 2015, 10:08:25 pm
Try the cli wallet to claim into your account .. after claiming you can use the web/light wallet again

https://bitshares.org/download/

Windoes, Linux and Mac links show a 404
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: Akado on November 16, 2015, 12:08:32 am
Yeah I don't really seem to know how to do it with the cli wallet. I downloaded the cli tools stuff on github, there's a cli.exe that as soon as I try to execute (after installation) opens a windows console that immediately crashes.

I might be annoying as hell and don't really want to take your time with this, I would just like to know an ETA on a fix for this.
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: clayop on November 16, 2015, 12:15:42 am
Is your system clock correct? Try to resync it.
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: Akado on November 16, 2015, 12:17:53 am
Is your system clock correct? Try to resync it.

Yes, apparently, it's synced with time.windows.com
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: 38PTSWarrior on November 16, 2015, 04:55:32 am
I am trying with graphene-ui. It says:

ownload the React DevTools for a better development experience: https://fb.me/react-devtools
app.js:7 connecting to wss://bitshares.openledger.info/ws
app.js:8 Configured for BitShares Object
3app.js:4 db init done
app.js:50 ChainStore Init
app.js:50 synced and subscribed, chainstore ready
app.js:4 [App.jsx] ----- ERROR -----> TypeError: Cannot read property 'backup_date' of null(…) TypeError: Cannot read property 'backup_date' of null
    at u.default.createElement.inject.backup_recommended (file:///usr/share/graphene-ui/app.js:79:7770)
    at o (file:///usr/share/graphene-ui/app.js:52:25341)
    at file:///usr/share/graphene-ui/app.js:52:26686
    at Array.reduce (native)
    at getInjected (file:///usr/share/graphene-ui/app.js:52:26653)
    at reduceState (file:///usr/share/graphene-ui/app.js:52:26810)
    at getInitialState (file:///usr/share/graphene-ui/app.js:52:25714)
    at new n (file:///usr/share/graphene-ui/vendors.js:2:18386)
    at E.mountComponent (file:///usr/share/graphene-ui/vendors.js:17:4483)
    at i [as mountComponent] (file:///usr/share/graphene-ui/vendors.js:2:2142)
app.js:4 Uncaught TypeError: Cannot read property 'backup_date' of null


What to do?
Title: Re: Claiming Balances - Can't Broadcast Transaction
Post by: Akado on November 19, 2015, 09:14:05 pm
I updated the light client with the last release and was able to do it. I imported each asset at a time. Didn't try to import all so I dont know if that makes any difference. Update and try.