BitShares Forum

Other => Graveyard => MemoryCoin => Topic started by: bgaer on February 09, 2014, 08:59:12 pm

Title: Mining Issues
Post by: bgaer on February 09, 2014, 08:59:12 pm
Hi There,

I had MMC Client running fine on my laptop for a few days, but then one day it would no longer start - it starts up and shows in the taskbar, but when I click on it from the task bar it says:

Cannot obtain a lock on data directory c:\users\bgaer\appdata\roaming\memorycoin   Memory Coin is probably already running  - when i check task manager only 1 instance is running.

I have rebooted, repaired, uninstalled(after backing up wallet) and reinstalled - but always the same error.

I then tried installing it on an older desktop - which has a 32 bit processor - but apparently there is not a 32 bit miner?   

Any help would be appreciated with the laptop issue and is there a 32 bit miner out there?

Lastly - for older folks like me - the post verification on this forum for the captcha - is absolutly horrible.  It is VERY hard to read even when i put my glasses on.


Title: Re: Mining Issues
Post by: seraphim on February 09, 2014, 09:10:18 pm
Hello brian,

there's probably a file in %appdata%\MemoryCoin which didn't get deleted. Navigate there and delete everything except your wallet.dat (hope you got a backup of it - issues like that may corrupt the file). After that, try starting the program again.

Did you have the miner running when you closed the MemoryCoin client?

For 32bit systems you can try with an older wallet version, maybe the miner included there works. But it will be very slow and probably not cost-effective.
I wanted to include a link here anyways, but it seems it's lately been removed by our web admins.
Title: Re: Mining Issues
Post by: bgaer on February 09, 2014, 09:49:51 pm
So I uninstalled, went to c:\users\bgaer\appdata\roaming\memorycoin and delted everything there.   

Reinstalled the latest version.

And still having the same issue.    It starts up - I see the splash screen, then it minimizes to the task bar.   I double click on it to get it to acutally open the wallet window and it gives the same error as I mentioned above.    It ran fine until about 2 days ago.

I went thru and deleted everything i have on my machine related to MMC except the wallet.dat and the backup of the wallet.dat.   Which I zipped up and put on my external hard drive -so now even that is not on my computer.   

I guess i will try doing the entire process again and this time rebooting after install and maybe check the registry?  I cannot understand what could possibly be wrong.


Title: Re: Mining Issues
Post by: FreeTrade on February 09, 2014, 09:53:47 pm
Try deleting the memorycoin folder so that it gets recreated. Backup your wallet of course.
Title: Re: Mining Issues
Post by: seraphim on February 09, 2014, 09:56:28 pm
Uh. Sorry, no windows knowledge is extremely limited.
Your idea of reinstalling and checking the registry sounds good, if it doesn't work after that maybe someone else can step in helping here?

//edit: yes, maybe freetrade :D
Title: Re: Mining Issues
Post by: bgaer on February 09, 2014, 10:09:47 pm
OK I got it working - here is what I had to do in case anyone else runs into this.

As mentioned - step number 1 is to make a copy of your wallet.dat so you dont lose your coins.

After that

#1 - Uninstall from Control Panel/Programs/ Uninstall

#2 - Delete everything from c:\users\[username\app data\roaming\memory coin

#3 - delte everyhthing from the install directory where you had memory coin

#4 - reboot.

#5 reinstall

#6 once it starts up with no issues, close it - replace your backup wallet.dat file with the new one that was created so you get your coins back

#7 restart memory coin.

Thanks for the help everyone.

Title: Re: Mining Issues
Post by: seraphim on February 09, 2014, 10:23:21 pm
Glad to hear you got it solved, and thank you very much for sharing the steps to resolve the issue!
I will use your posting as a reference for others, please send me your MMC address for a small tip.
Title: Re: Mining Issues
Post by: bgaer on February 10, 2014, 05:40:18 am
No problem - hope it can be of help to others if they experience the same issue.

I have to say so far I have mined about 7 coins and by far MMC is my favorite.  The community, the lack of need for specialized hardware, the documentation and community support is outstanding.   


Brian Gaer
MMC: M9GyYYC7Vsu6YkW7wKbE2y5snLVnPSh4qK