BitShares Forum

Other => Graveyard => MemoryCoin => Topic started by: vanitylol on March 11, 2014, 10:19:46 pm

Title: yam will not launch - pls help
Post by: vanitylol on March 11, 2014, 10:19:46 pm
I've spent numerous days now blown away that I can't seem to find a noob guide to just basic setup to the yam. I've got yam unzipped. I put the config in the win64-haswell along with the exe. The config runs as follows:

threads = 4
mining-params = mmc:av=0&aesni=on&m=1024
mine = getwork://[email protected]:80:8880:8881:8882:8883/mmc
mine = getwork://[email protected]:8080:8081:8082:8083/mmc
mine = getwork://[email protected]:8080:8081:8082:8083/mmc
mine = getwork://[email protected]:8080:8081:8082:8083/mmc
mine = getwork://yvg1900.mmc_1:[email protected]:8080/mmc
#proxy = socks4a://127.0.0.1:9150
compact-stats = 1
print-timestamps = 0

I have i5-4670k. when i double click exe. it just shuts down. It's prolly such a noob thing that I'm missing but ive searched threads post google youtube for days and havn't found anything. Please help I've been wanting to mine for a while now. Thanks

edit- or at least where i could find this information
Title: Re: yam will not launch - pls help
Post by: seraphim on March 12, 2014, 10:50:13 am
you can remove the gpools line from the config.

instead of clicking the exe, open cmd, cd to the directory containing the yam.exe and start it from there - hopefully you'll get some output this way which helps to solve the issue...
Title: Re: yam will not launch - pls help
Post by: beardedpants on March 13, 2014, 01:26:59 pm
Open notepad, create a file with this:

yam.exe --config <your-config-file>.cfg
(your config file would be yam-mmc.cfg if you didn't rename it)

Save as a .bat file (Drop down Save as type All Files). You can name it whatever you'd like as long as it ends in .bat.

Make sure this bat file is in the same directory as yam.exe. Double click the bat and (hopefully) success.

That's what I do anyways, and it's always worked for me.