Author Topic: Not Connected - OSX 10.10 - v0.4.24  (Read 2492 times)

0 Members and 1 Guest are viewing this topic.

Offline hyzap

  • Newbie
  • *
  • Posts: 8
    • View Profile
If you have a recent wallet export / backup (or two),

I find the best thing to do is to ensure you are using the newest version of the client (do not click that old superseded BitsharesX dock item). Then, trash (or preferably move) the entirety of user/Library/Application Support/Bitshares . Restart Bitshares, and import your wallet back up.

It works...
Don't trash the "wallets" folder in the BitShares folder .. it contains your private keys! .. unless you have a proper backup!

Well I'll be darned... after a few hiccups, that worked well.
Of course, along with the reinstall was a 'patch' for 0.4.24, so that may have contributed.
And, I guess I had the proper backups.  I do a regular wallet export, and have my private key itself stowed away.  :)
Thanks fellas.  I'm back in business.
Cheers!

>> get_info

{
  "blockchain_head_block_num": 1108721,
  "blockchain_head_block_age": "9 seconds old",
  "blockchain_head_block_timestamp": "2014-11-26T07:43:30",
  "blockchain_average_delegate_participation": "99.02 %",
  "blockchain_confirmation_requirement": 1,
  "blockchain_share_supply": "2,497,914,982.51227 BTS",
  "blockchain_blocks_left_in_round": 57,
  "blockchain_next_round_time": "at least 9 minutes in the future",
  "blockchain_next_round_timestamp": "2014-11-26T07:53:00",
  "blockchain_random_seed": "17ddbcd01e38097533e4b6f6749abc14de2ab558",
  "client_data_dir": "/Users/yourstruly/Library/Application Support/BitShares",
  "client_version": "v0.4.24",
  "network_num_connections": 8,
  "network_num_connections_max": 200,
  "network_chain_downloader_running": false,
  "network_chain_downloader_blocks_remaining": null,
  "ntp_time": "2014-11-26T07:43:39",
  "ntp_time_error": 0.0020769999999999999,
  "wallet_open": true,
  "wallet_unlocked": true,
  "wallet_unlocked_until": "11 days in the future",
  "wallet_unlocked_until_timestamp": "2014-12-07T17:35:09",
  "wallet_last_scanned_block_timestamp": "2014-11-26T07:43:30",
  "wallet_scan_progress": "100.00 %",
  "wallet_block_production_enabled": false,
  "wallet_next_block_production_time": null,
  "wallet_next_block_production_timestamp": null
}

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 12920
  • ChainSquad GmbH
    • View Profile
    • ChainSquad GmbH
  • BitShares: xeroc
  • GitHub: xeroc
If you have a recent wallet export / backup (or two),

I find the best thing to do is to ensure you are using the newest version of the client (do not click that old superseded BitsharesX dock item). Then, trash (or preferably move) the entirety of user/Library/Application Support/Bitshares . Restart Bitshares, and import your wallet back up.

It works...
Don't trash the "wallets" folder in the BitShares folder .. it contains your private keys! .. unless you have a proper backup!

Offline Methodise

If you have a recent wallet export / backup (or two),

I find the best thing to do is to ensure you are using the newest version of the client (do not click that old superseded BitsharesX dock item). Then, trash (or preferably move) the entirety of user/Library/Application Support/Bitshares . Restart Bitshares, and import your wallet back up.

It works...
BTS: methodise

Offline hyzap

  • Newbie
  • *
  • Posts: 8
    • View Profile
The next release has a couple network fixes which should hopefully help with this kind of thing.

Great to hear!  At the moment i'm dead in the water, but optimistically waiting for v0.4.25 and all that it promises.. :)

Offline vikram

The next release has a couple network fixes which should hopefully help with this kind of thing.

Offline hyzap

  • Newbie
  • *
  • Posts: 8
    • View Profile
Nope, no firewall.
It should be noted that I was able to connect with the wallet on my old windows machine no problem through this same router.

I used the network_add_node list as you suggested.  I'll report back later if there's any change.

Thanks for the help!


Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 12920
  • ChainSquad GmbH
    • View Profile
    • ChainSquad GmbH
  • BitShares: xeroc
  • GitHub: xeroc
These commands should force the client to start connecting to the seed nodes:

Code: [Select]
network_add_node "178.62.50.61:1776", onetry
network_add_node "178.62.50.61:1777", onetry
network_add_node "178.62.50.61:1778", onetry
network_add_node "80.240.133.79:1776", onetry
network_add_node "80.240.133.79:1777", onetry
network_add_node "5.101.106.138:1777", onetry
network_add_node "5.101.106.138:1778", onetry
network_add_node "128.199.137.122:1776", onetry
network_add_node "128.199.137.122:1777", onetry
network_add_node "95.85.33.16:8764", onetry
network_add_node "180.153.142.120:1777", onetry
network_add_node "84.238.140.192:42577", onetry
network_add_node "5.101.106.138:1776", onetry
network_add_node "61.129.33.213:1776", onetry
network_add_node "80.240.133.79:1778", onetry
network_add_node "89.187.144.203:8764", onetry
network_add_node "104.131.35.149:1776", onetry
network_add_node "178.62.50.61:1779", onetry
network_add_node "178.62.157.161:1776", onetry
network_add_node "188.226.195.137:60696", onetry
network_add_node "auseednode.minebitshares.com:1776", onetry
network_add_node "euseednode.minebitshares.com:1776", onetry
network_add_node "46.226.109.66:1776", onetry
network_add_node "54.77.51.177:1776", onetry
network_add_node "54.79.27.224:1776", onetry
network_add_node "85.214.53.224:1776", onetry
network_add_node "106.185.26.162:1776", onetry
network_add_node "185.25.22.21:1776" onetry

Are you running a firewall of some kind?

Offline hyzap

  • Newbie
  • *
  • Posts: 8
    • View Profile
  "network_num_connections": 1,
hmm .. seems you ARE connected ..
can you remove/rename the "config.json" file too and restart? Some settings are non-default (to me)

Within 5 hours the client should be synced :(

Ok, I deleted the config.json file while the client was closed, and restarted.  Still nothing moving for me.

>> get_info

{
  "blockchain_head_block_num": 568952,
  "blockchain_head_block_age": "62 days old",
  "blockchain_head_block_timestamp": "2014-09-24T12:52:00",
  "blockchain_average_delegate_participation": "0.02 %",
  "blockchain_confirmation_requirement": 1,
  "blockchain_share_supply": "2,498,983,914.38561 BTS",
  "blockchain_blocks_left_in_round": 82,
  "blockchain_next_round_time": "at least 14 minutes in the future",
  "blockchain_next_round_timestamp": "2014-11-25T01:13:50",
  "blockchain_random_seed": "dd5ccc1fe3a51f07480346399375d890499b8062",
  "client_data_dir": "/Users/redacted/Library/Application Support/BitShares",
  "client_version": "v0.4.24",
  "network_num_connections": 0,
  "network_num_connections_max": 200,
  "network_chain_downloader_running": false,
  "network_chain_downloader_blocks_remaining": null,
  "ntp_time": "2014-11-25T01:00:13",
  "ntp_time_error": 0.045740000000000003,
  "wallet_open": true,
  "wallet_unlocked": true,
  "wallet_unlocked_until": "12 days in the future",
  "wallet_unlocked_until_timestamp": "2014-12-06T14:33:32",
  "wallet_last_scanned_block_timestamp": null,
  "wallet_scan_progress": "0.00 %",
  "wallet_block_production_enabled": false,
  "wallet_next_block_production_time": null,
  "wallet_next_block_production_timestamp": null
}
« Last Edit: November 25, 2014, 01:06:08 am by hyzap »

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 12920
  • ChainSquad GmbH
    • View Profile
    • ChainSquad GmbH
  • BitShares: xeroc
  • GitHub: xeroc
  "network_num_connections": 1,
hmm .. seems you ARE connected ..
can you remove/rename the "config.json" file too and restart? Some settings are non-default (to me)

Within 5 hours the client should be synced :(

Offline hyzap

  • Newbie
  • *
  • Posts: 8
    • View Profile
The "not connected" in the lower right corner often is "wrong" (buggy)
If you have those kind of issues always check with "getinfo" in the console.
Also, let the client run for some minutes to connect to the network ..

It's been up and 'running' for the past 5 hours and this is the output of get_info

>> get_info

{
  "blockchain_head_block_num": 568952,
  "blockchain_head_block_age": "61 days old",
  "blockchain_head_block_timestamp": "2014-09-24T12:52:00",
  "blockchain_average_delegate_participation": "0.02 %",
  "blockchain_confirmation_requirement": 1,
  "blockchain_share_supply": "2,498,983,914.38561 BTS",
  "blockchain_blocks_left_in_round": 82,
  "blockchain_next_round_time": "at least 14 minutes in the future",
  "blockchain_next_round_timestamp": "2014-11-24T07:57:50",
  "blockchain_random_seed": "dd5ccc1fe3a51f07480346399375d890499b8062",
  "client_data_dir": "/Users/redacted/Library/Application Support/BitShares",
  "client_version": "v0.4.24",
  "network_num_connections": 1,
  "network_num_connections_max": 200,
  "network_chain_downloader_running": false,
  "network_chain_downloader_blocks_remaining": null,
  "ntp_time": "2014-11-24T07:44:10",
  "ntp_time_error": 0.049356999999999998,
  "wallet_open": true,
  "wallet_unlocked": true,
  "wallet_unlocked_until": "12 days in the future",
  "wallet_unlocked_until_timestamp": "2014-12-05T21:30:24",
  "wallet_last_scanned_block_timestamp": null,
  "wallet_scan_progress": "0.00 %",
  "wallet_block_production_enabled": false,
  "wallet_next_block_production_time": null,
  "wallet_next_block_production_timestamp": null
}

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 12920
  • ChainSquad GmbH
    • View Profile
    • ChainSquad GmbH
  • BitShares: xeroc
  • GitHub: xeroc
The "not connected" in the lower right corner often is "wrong" (buggy)
If you have those kind of issues always check with "getinfo" in the console.
Also, let the client run for some minutes to connect to the network ..

Offline hyzap

  • Newbie
  • *
  • Posts: 8
    • View Profile
Do you also see JSON Parse errors in notification area?
Many people have "Not connected" on linux as well.
Both official source code and unofficial ubuntu builds.

The thread is here:
https://bitsharestalk.org/index.php?topic=10847.msg150399;topicseen#msg150399

Nope, no JSON Parse errors.

I had to can the Powerbook for a couple weeks to use my wallet on an old Windows box, hence the delay in reply.

And so... I just re-installed the wallet on this Powerbook, and still "Not connected"

I tried deleting the "peers_leveldb" folder again, but still no joy.  I'll wait overnight and see if it connects, as if by magic.

Any other suggestions for a sad Ubuntu user stuck on a Mac...?

Offline hammurabi

  • Full Member
  • ***
  • Posts: 63
    • View Profile
Do you also see JSON Parse errors in notification area?
Many people have "Not connected" on linux as well.
Both official source code and unofficial ubuntu builds.

The thread is here:
https://bitsharestalk.org/index.php?topic=10847.msg150399;topicseen#msg150399

Offline hyzap

  • Newbie
  • *
  • Posts: 8
    • View Profile

Thanks for the reply Xeroc.

I've tried deleting the "peers_leveldb" folder and waiting hours for it to connect, even overnight, but nothing is working yet.

Any other tricks or suggestions?

I need to move some BitUSD so I'm hoping there's a solution of some kind.  I'm waiting on a new linux machine and in the meanwhile I'm stuck with this Mac and no way to make transactions.

Thanks again.

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 12920
  • ChainSquad GmbH
    • View Profile
    • ChainSquad GmbH
  • BitShares: xeroc
  • GitHub: xeroc
Sometimes the wallet needs some minutes to connect to a node successfully ... depends on how many nodes you already have in your local database ..
you can force to connect to a seed node by deleting the "peers_leveldb" folder in "%APPDATA%/Roaming/Bitshares/"