Author Topic: Failed to sync with the API server  (Read 5043 times)

0 Members and 1 Guest are viewing this topic.

Offline Mateusz

  • Newbie
  • *
  • Posts: 16
    • View Profile
Failed to sync with the API server
« on: September 05, 2016, 09:04:55 pm »
I recently downloaded the new BitShares 2.0.160813 light software and set up my account. All seamed to be working flawlessly until yesterday when I tried to start the client and got the following screen:

Quote
Failed to sync with the API server
Please verify that your computer clock is correct.
Once you've synchronized your clock, please refresh this page.

I live in the UTC+1 time zone and use Windows 7 x64 with clock automatically synchronized with 'time.windows.com'. I've synced the computer clock and restarted the client multiple times but the problem persists. How do I change API server or otherwise resolve this error?

Offline nmywn

  • Sr. Member
  • ****
  • Posts: 266
    • View Profile
Re: Failed to sync with the API server
« Reply #1 on: September 05, 2016, 09:44:22 pm »


Chose this one.
I had the same problem today, but this has nothing to do with my clock. Now it's ok, but still far from perfect. New servers are ready to go, but we must wait for official release, which should happen very soon.
BTW new client is 160829.

Offline Mateusz

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: Failed to sync with the API server
« Reply #2 on: September 05, 2016, 10:12:34 pm »
After updating the API connection menu showed up. Many thanks!

Offline ebit

  • Committee member
  • Hero Member
  • *
  • Posts: 1730
    • View Profile
    • 推荐链接
  • BitShares: ebit
Re: Failed to sync with the API server
« Reply #3 on: September 06, 2016, 07:16:11 am »
Quote
国内近日已新增以下 API 服务器节点,使用网页钱包和轻钱包的可以自行添加:
● wss://bit.btsabc.org/ws (比特股中文网 @吴序强 提供)
● wss://bts.transwiser.com/ws (易转网 @巨蟹 提供)
● wss://freedom.bts123.cc:15138 (著名的黑粉 @惨 提供)
● wss://okbtc.org:8089/ws (bebtc.com 的 @郑浩 提供)
● wss://ratebts.com:8089([member=21209]AJ[/member] 提供)
● wss://openledger.hk/ws (OpenLedger 香港提供)

Have a try

Offline MrJeans

  • Hero Member
  • *****
  • Posts: 599
    • View Profile
  • BitShares: mrjeans
Re: Failed to sync with the API server
« Reply #4 on: September 24, 2016, 04:45:39 pm »
When cloning the github and running the client on a local host:
The client is very slow in general
The exchange is non functional (just shows as loading continuously).

Tried connecting to different servers.
Is there any way to fix this so that testing can be done locally.

Offline svk

Re: Failed to sync with the API server
« Reply #5 on: September 25, 2016, 08:05:29 pm »
When cloning the github and running the client on a local host:
The client is very slow in general
The exchange is non functional (just shows as loading continuously).

Tried connecting to different servers.
Is there any way to fix this so that testing can be done locally.
Running on local host works fine for me, can't really help you without more info here.

It will be slower than a production build though that's inevitable due to debugging etc.
Worker: dev.bitsharesblocks

Offline MrJeans

  • Hero Member
  • *****
  • Posts: 599
    • View Profile
  • BitShares: mrjeans
Re: Failed to sync with the API server
« Reply #6 on: September 26, 2016, 03:05:34 pm »
When cloning the github and running the client on a local host:
The client is very slow in general
The exchange is non functional (just shows as loading continuously).

Tried connecting to different servers.
Is there any way to fix this so that testing can be done locally.
Running on local host works fine for me, can't really help you without more info here.

It will be slower than a production build though that's inevitable due to debugging etc.
It did work at one point and then just stopped. Tried different computers, internet connections etc.
Will keep trying.

Offline nmywn

  • Sr. Member
  • ****
  • Posts: 266
    • View Profile
Re: Failed to sync with the API server
« Reply #7 on: September 26, 2016, 04:57:42 pm »
[member=11456]svk[/member],
Same here.
http://localhost:8080/#/ works fine until i choose Exchange tab - then
Code: [Select]
TypeError: c is null
C/e()
 /:9
C/e()
 /:9
C()
 /:9
B.stockChart/e.xAxis<()
 /:438
va()
 /:27
B.stockChart()
 /:438
t.exports/a<.renderChart()
 /:1
bound ()
 self-hosted:752
t.exports/a<.componentDidMount()
 /:1
ReactCompositeComponentMixin.mountComponent/</<()
 /:264
measureLifeCyclePerf()
 /:74
ReactCompositeComponentMixin.mountComponent/<()
 /:263
.notifyAll()
 /:67
ON_DOM_READY_QUEUEING.close()
 /:81
Mixin.closeAll()
 /:204
Mixin.perform()
 /:151
Mixin.perform()
 /:138
.perform()
 /:90
flushBatchedUpdates()
 /:173
bound ()
 self-hosted:752
Mixin.closeAll()
 /:204
Mixin.perform()
 /:151
ReactDefaultBatchingStrategy.batchedUpdates()
 /:63
batchedUpdates()
 /:98
ReactEventListener.dispatchEvent()
 /:150
bound ()
 self-hosted:792

Same happen when I go to http://localhost:8080/#/explorer/blocks:
Code: [Select]
Error in BlockchainActions.getLatest:  TypeError: c is null
Stack trace:
C/[email protected]:///./~/highcharts/highstock.js?:9:17
C/[email protected]:///./~/highcharts/highstock.js?:9:46
[email protected]:///./~/highcharts/highstock.js?:9:159
B.stockChart/e.xAxis<@webpack:///./~/highcharts/highstock.js?:438:450
[email protected]:///./~/highcharts/highstock.js?:27:12
[email protected]:///./~/highcharts/highstock.js?:438:412
t.exports/a<[email protected]:///./~/react-highcharts/dist/ReactHighstock.js?:1:1387
t.exports/a<[email protected]:///./~/react-highcharts/dist/ReactHighstock.js?:1:1701
ReactCompositeComponentMixin.updateComponent/shouldUpdate<@webpack:///./~/react/lib/ReactCompositeComponent.js?:622:20
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:74:12
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:621:26
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:544:5
[email protected]:///./~/react/lib/ReactReconciler.js?:126:5
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:751:7
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:721:5
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:642:7
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:544:5
[email protected]:///./~/react/lib/ReactReconciler.js?:126:5
[email protected]:///./~/react/lib/ReactChildReconciler.js?:110:9
[email protected]:///./~/react/lib/ReactMultiChild.js?:210:11
[email protected]:///./~/react/lib/ReactMultiChild.js?:314:26
[email protected]:///./~/react/lib/ReactMultiChild.js?:301:7
[email protected]:///./~/react/lib/ReactDOMComponent.js?:942:7
[email protected]:///./~/react/lib/ReactDOMComponent.js?:760:5
[email protected]:///./~/react/lib/ReactDOMComponent.js?:718:5
[email protected]:///./~/react/lib/ReactReconciler.js?:126:5
[email protected]:///./~/react/lib/ReactChildReconciler.js?:110:9
[email protected]:///./~/react/lib/ReactMultiChild.js?:210:11
[email protected]:///./~/react/lib/ReactMultiChild.js?:314:26
[email protected]:///./~/react/lib/ReactMultiChild.js?:301:7
[email protected]:///./~/react/lib/ReactDOMComponent.js?:942:7
[email protected]:///./~/react/lib/ReactDOMComponent.js?:760:5
[email protected]:///./~/react/lib/ReactDOMComponent.js?:718:5
[email protected]:///./~/react/lib/ReactReconciler.js?:126:5
[email protected]:///./~/react/lib/ReactChildReconciler.js?:110:9
[email protected]:///./~/react/lib/ReactMultiChild.js?:210:11
[email protected]:///./~/react/lib/ReactMultiChild.js?:314:26
[email protected]:///./~/react/lib/ReactMultiChild.js?:301:7
[email protected]:///./~/react/lib/ReactDOMComponent.js?:942:7
[email protected]:///./~/react/lib/ReactDOMComponent.js?:760:5
[email protected]:///./~/react/lib/ReactDOMComponent.js?:718:5
[email protected]:///./~/react/lib/ReactReconciler.js?:126:5
[email protected]:///./~/react/lib/ReactChildReconciler.js?:110:9
[email protected]:///./~/react/lib/ReactMultiChild.js?:210:11
[email protected]:///./~/react/lib/ReactMultiChild.js?:314:26
[email protected]:///./~/react/lib/ReactMultiChild.js?:301:7
[email protected]:///./~/react/lib/ReactDOMComponent.js?:942:7
[email protected]:///./~/react/lib/ReactDOMComponent.js?:760:5
[email protected]:///./~/react/lib/ReactDOMComponent.js?:718:5
[email protected]:///./~/react/lib/ReactReconciler.js?:126:5
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:751:7
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:721:5
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:642:7
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:544:5
[email protected]:///./~/react/lib/ReactReconciler.js?:126:5
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:751:7
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:721:5
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:642:7
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:544:5
[email protected]:///./~/react/lib/ReactReconciler.js?:126:5
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:751:7
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:721:5
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:642:7
[email protected]:///./~/react/lib/ReactCompositeComponent.js?:558:7
[email protected]:///./~/react/lib/ReactReconciler.js?:158:5
[email protected]:///./~/react/lib/ReactUpdates.js?:151:5
[email protected]:///./~/react/lib/Transaction.js?:138:13
[email protected]:///./~/react/lib/Transaction.js?:138:13
[email protected]:///./~/react/lib/ReactUpdates.js?:90:12
[email protected]:///./~/react/lib/ReactUpdates.js?:173:7
[email protected]:///./~/react/lib/Transaction.js?:204:11
[email protected]:///./~/react/lib/Transaction.js?:151:11
[email protected]:///./~/react/lib/ReactDefaultBatchingStrategy.js?:63:7
[email protected]:///./~/react/lib/ReactUpdates.js?:201:5
[email protected]:///./~/react/lib/ReactUpdateQueue.js?:25:3
[email protected]:///./~/react/lib/ReactUpdateQueue.js?:210:5
[email protected]:///template_of_302_referencing_?:64:3
AltContainer/[email protected]:///./~/alt-container/lib/AltContainer.js?:167:7
push/<@webpack:///../dl/~/transmitter/dist/transmitter.js?:21:14
[email protected]:///../dl/~/transmitter/dist/transmitter.js?:20:5
AltStore/[email protected]:///../dl/~/alt/lib/store/AltStore.js?:50:14
AltStore/this.dispatchToken<@webpack:///../dl/~/alt/lib/store/AltStore.js?:98:56
[email protected]:///../dl/~/flux/lib/Dispatcher.js?:220:5
[email protected]:///../dl/~/flux/lib/Dispatcher.js?:195:9
dispatch/<@webpack:///../dl/~/alt/lib/index.js?:89:16
Alt/this.batchingFunction<@webpack:///../dl/~/alt/lib/index.js?:56:14
[email protected]:///../dl/~/alt/lib/index.js?:72:7
[email protected]:///../dl/~/alt/lib/actions/index.js?:38:7
getLatest/<@webpack:///../dl/src/actions/BlockchainActions.js?:40:21

Tested with Firefox 47.0 (i know) and Chrome 52.0.2743.82 (64-bit)
No issues with web hosted clients.

Offline svk

Re: Failed to sync with the API server
« Reply #8 on: September 26, 2016, 07:17:45 pm »
Looks related to Highcharts, could be that npm installed a newer version of react-highcharts for you with breaking changes. v8 should be ok I think, you could try installing that manually, npm install [email protected]
Worker: dev.bitsharesblocks

Offline nmywn

  • Sr. Member
  • ****
  • Posts: 266
    • View Profile
Re: Failed to sync with the API server
« Reply #9 on: September 26, 2016, 07:33:31 pm »
Still not working.  I did (not sure if right):
Code: [Select]
cd dl; npm install [email protected]; cd ../web;  npm install [email protected]
Maybe this is wrong?
Code: [Select]
$ nvm use 5
Now using node v5.9.1 (npm v3.7.3)
« Last Edit: September 26, 2016, 07:35:13 pm by nmywn »

Offline svk

Re: Failed to sync with the API server
« Reply #10 on: September 27, 2016, 07:39:47 am »
Still not working.  I did (not sure if right):
Code: [Select]
cd dl; npm install [email protected]; cd ../web;  npm install [email protected]
Maybe this is wrong?
Code: [Select]
$ nvm use 5
Now using node v5.9.1 (npm v3.7.3)

I had some time this morning and took a look, there were two issues: one with the minified highstock file and another related to the indicators not being defined properly, I've pushed a fix so it should work properly now.

Edit: Looks like the indicators functionality was removed somewhere in highcharts, so they don't work at the moment.
Worker: dev.bitsharesblocks

Offline svk

Re: Failed to sync with the API server
« Reply #11 on: September 27, 2016, 08:13:29 am »
Upon further investigation I narrowed it down to a problem with the minified highstock v4.2.7 file, I've reverted to 4.2.6 which seems to work fine.
Worker: dev.bitsharesblocks

Offline nmywn

  • Sr. Member
  • ****
  • Posts: 266
    • View Profile
Re: Failed to sync with the API server
« Reply #12 on: September 27, 2016, 02:53:04 pm »
Works great, thank you.

Offline MrJeans

  • Hero Member
  • *****
  • Posts: 599
    • View Profile
  • BitShares: mrjeans
Re: Failed to sync with the API server
« Reply #13 on: September 28, 2016, 07:24:38 pm »
Works now, thanks a lot

Offline santaclause102

  • Hero Member
  • *****
  • Posts: 2486
    • View Profile
Re: Failed to sync with the API server
« Reply #14 on: February 01, 2017, 04:23:08 pm »
For LInux: Had the same problem until I installed ntp