Author Topic: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected  (Read 22327 times)

0 Members and 1 Guest are viewing this topic.

Offline feelgood2

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #64 on: April 17, 2014, 05:55:39 am »
On my 290x I got the following error:

C:\Users\Mile\Desktop\jhProtominer>jhProtominer.exe -o ypool.net -u XXXXXX.PTS -p x -d 0 -a gpuv4 -m2048
╔══════════════════════════════════════════════════╗
║  jhProtominer (v0.2a) + OpenCL GPU Support       ║
║  author: girino, based on code by jh             ║
║                                                  ║
║  If you like it, please donate:                  ║
║  PTS: PkyeQNn1yGV5psGeZ4sDu6nz2vWHTujf4h         ║
║  BTC: 1GiRiNoKznfGbt8bkU1Ley85TgVV7ZTXce         ║
║                                                  ║
║  Please note  that on  pools that support  it    ║
║  (currently only ypool.net), there is an 2.5║
║  mining fee to support further development of    ║
║  this software.                                  ║
╚══════════════════════════════════════════════════╝
Launching miner...
Using 2560 megabytes of memory per thread
Using 1 threads
Available devices:
Platform 00: AMD Accelerated Parallel Processing
  Device 00: Hawaii
  Device 01: AMD Phenom(tm) II X4 925 Processor
Adjusting num threads to match device list: 2
Initializing GPU...
Initing device 0.
Starting OpenCLMomentum V4
Device 00: Hawaii
Max work group size: 256
ERROR: -61, CL_INVALID_BUFFER_SIZE, if size is 0.Implementations may return CL_I
NVALID_BUFFER_SIZE if size is greater than the CL_DEVICE_MAX_MEM_ALLOC_SIZE valu
e specified in the table of allowed values for param_name for clGetDeviceInfo fo
r all devices in context.
Assertion failed!

Program: C:\Users\Mile\Desktop\jhProtominer\jhProtominer.exe
File: OpenCLObjects.cpp, Line 373

Expression: _MY_ERR_X == CL_SUCCESS

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.


Offline megadeth92

Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #63 on: March 02, 2014, 12:52:25 pm »
Runs at 550 coll/min for with an Asus 7850
Integrated GPU of 4770K makes crash the miner :S
Account: jdroa92

Offline girino

  • Full Member
  • ***
  • Posts: 73
    • View Profile
Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #62 on: February 27, 2014, 04:51:59 pm »
I got this error on 6870 1GB. There are some settings in which it uses 1024 MB of memory:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Mile>cd C:\Users\Mile\Desktop\jhProtominer

C:\Users\Mile\Desktop\jhProtominer>proba2

C:\Users\Mile\Desktop\jhProtominer>jhProtominer.exe -o ypool.net -u x.x
 -p x -a gpuv9 -m1024
╔══════════════════════════════════════════════════╗
║  jhProtominer (v0.2a) + OpenCL GPU Support       ║
║  author: girino, based on code by jh             ║
║                                                  ║
║  If you like it, please donate:                  ║
║  PTS: PkyeQNn1yGV5psGeZ4sDu6nz2vWHTujf4h         ║
║  BTC: 1GiRiNoKznfGbt8bkU1Ley85TgVV7ZTXce         ║
║                                                  ║
║  Please note  that on  pools that support  it    ║
║  (currently only ypool.net), there is an 2.5║
║  mining fee to support further development of    ║
║  this software.                                  ║
╚══════════════════════════════════════════════════╝
Launching miner...
Using 1024 megabytes of memory per thread
Using 1 threads
Available devices:
Platform 00: AMD Accelerated Parallel Processing
  Device 00: Barts
  Device 01: AMD Phenom(tm) II X4 925 Processor
Adjusting num threads to match device list: 1
Initializing GPU...
Initing device 0.
Starting OpenCLMomentum V9
Device 00: Barts
Max work group size: 256
ERROR: -61, CL_INVALID_BUFFER_SIZE, if size is 0.Implementations may return CL_I
NVALID_BUFFER_SIZE if size is greater than the CL_DEVICE_MAX_MEM_ALLOC_SIZE valu
e specified in the table of allowed values for param_name for clGetDeviceInfo fo
r all devices in context.
Assertion failed!

Program: C:\Users\Mile\Desktop\jhProtominer\jhProtominer.exe
File: OpenCLObjects.cpp, Line 373

Expression: _MY_ERR_X == CL_SUCCESS

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

C:\Users\Mile\Desktop\jhProtominer>

You wont be able to use the full 1Gb for the miner since some parts of the memory is used for other purposes by the card. You should check the amount of free memory, not the total memory to see what you can run.

Offline feelgood2

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #61 on: February 27, 2014, 08:15:33 am »
I got this error on 6870 1GB. There are some settings in which it uses 1024 MB of memory:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Mile>cd C:\Users\Mile\Desktop\jhProtominer

C:\Users\Mile\Desktop\jhProtominer>proba2

C:\Users\Mile\Desktop\jhProtominer>jhProtominer.exe -o ypool.net -u x.x
 -p x -a gpuv9 -m1024
╔══════════════════════════════════════════════════╗
║  jhProtominer (v0.2a) + OpenCL GPU Support       ║
║  author: girino, based on code by jh             ║
║                                                  ║
║  If you like it, please donate:                  ║
║  PTS: PkyeQNn1yGV5psGeZ4sDu6nz2vWHTujf4h         ║
║  BTC: 1GiRiNoKznfGbt8bkU1Ley85TgVV7ZTXce         ║
║                                                  ║
║  Please note  that on  pools that support  it    ║
║  (currently only ypool.net), there is an 2.5║
║  mining fee to support further development of    ║
║  this software.                                  ║
╚══════════════════════════════════════════════════╝
Launching miner...
Using 1024 megabytes of memory per thread
Using 1 threads
Available devices:
Platform 00: AMD Accelerated Parallel Processing
  Device 00: Barts
  Device 01: AMD Phenom(tm) II X4 925 Processor
Adjusting num threads to match device list: 1
Initializing GPU...
Initing device 0.
Starting OpenCLMomentum V9
Device 00: Barts
Max work group size: 256
ERROR: -61, CL_INVALID_BUFFER_SIZE, if size is 0.Implementations may return CL_I
NVALID_BUFFER_SIZE if size is greater than the CL_DEVICE_MAX_MEM_ALLOC_SIZE valu
e specified in the table of allowed values for param_name for clGetDeviceInfo fo
r all devices in context.
Assertion failed!

Program: C:\Users\Mile\Desktop\jhProtominer\jhProtominer.exe
File: OpenCLObjects.cpp, Line 373

Expression: _MY_ERR_X == CL_SUCCESS

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

C:\Users\Mile\Desktop\jhProtominer>

Offline krpetrov

  • Jr. Member
  • **
  • Posts: 43
    • View Profile
Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #60 on: February 22, 2014, 06:05:19 pm »
Need help running miner on Ubuntu 13.10.

5850 1GB wont run. I get the following error -
ERROR: -61, CL_INVALID_BUFFER_SIZE, if size is 0.Implementations may return CL_INVALID_BUFFER_SIZE if size is greater than the CL_DEVICE_MAX_MEM_ALLOC_SIZE value specified in the table of allowed values for param_name for clGetDeviceInfo for all devices in context.
ptsminer: OpenCLObjects.cpp:373: OpenCLBuffer* OpenCLContext::createBuffer(size_t, cl_mem_flags, void*): Assertion `_MY_ERR_X == 0' failed.
Aborted (core dumped)

Any advice? What should I do ?

try running with "-a gpuv9" and different values for -m (-m128 is sure to work, -m256 probably works, -m512 if it works will be the best)

Tried all gpuv options but none works with 5850. With other 1GB card - 560ti -  is works with gpuv9.

Offline feelgood2

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #59 on: February 22, 2014, 03:17:50 pm »
Something weird happen with your miner. When I first tried it, I received over 600 coll/min.
Then I tried to play with memory setting by using -m. When I try -m1024, it crashes. For others I get very low coll/min. Now, when I remove -m I get 250 colls/min.
Downloaded ver6 again but without change. Can't get more than 250 colls/min. Currently using Nan's version and getting 450 colls/min.

Card is 6870 1GB

Edit: tried this -a gpuv9 and is working for half an hour over 850. Great work!
« Last Edit: February 23, 2014, 09:28:07 am by feelgood2 »

Offline girino

  • Full Member
  • ***
  • Posts: 73
    • View Profile
Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #58 on: February 22, 2014, 03:11:09 pm »
Need help running miner on Ubuntu 13.10.

5850 1GB wont run. I get the following error -
ERROR: -61, CL_INVALID_BUFFER_SIZE, if size is 0.Implementations may return CL_INVALID_BUFFER_SIZE if size is greater than the CL_DEVICE_MAX_MEM_ALLOC_SIZE value specified in the table of allowed values for param_name for clGetDeviceInfo for all devices in context.
ptsminer: OpenCLObjects.cpp:373: OpenCLBuffer* OpenCLContext::createBuffer(size_t, cl_mem_flags, void*): Assertion `_MY_ERR_X == 0' failed.
Aborted (core dumped)

Any advice? What should I do ?

try running with "-a gpuv9" and different values for -m (-m128 is sure to work, -m256 probably works, -m512 if it works will be the best)

Offline krpetrov

  • Jr. Member
  • **
  • Posts: 43
    • View Profile
Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #57 on: February 22, 2014, 07:39:36 am »
Need help running miner on Ubuntu 13.10.

5850 1GB wont run. I get the following error -
ERROR: -61, CL_INVALID_BUFFER_SIZE, if size is 0.Implementations may return CL_INVALID_BUFFER_SIZE if size is greater than the CL_DEVICE_MAX_MEM_ALLOC_SIZE value specified in the table of allowed values for param_name for clGetDeviceInfo for all devices in context.
ptsminer: OpenCLObjects.cpp:373: OpenCLBuffer* OpenCLContext::createBuffer(size_t, cl_mem_flags, void*): Assertion `_MY_ERR_X == 0' failed.
Aborted (core dumped)

Any advice? What should I do ?

Offline jwiz168

  • Sr. Member
  • ****
  • Posts: 409
    • View Profile
Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #56 on: January 29, 2014, 10:42:53 pm »
share invalid : data time overflow  <--- this is the error . using 7970 win 7  64 bit

Offline rots

  • Newbie
  • *
  • Posts: 12
    • View Profile
quite astonished that
6850 800cpm !!!
270x 650cpm
280x 1100cpm

6850 seems drugged!

Same error here...  :(
win7_x64, 2x R9280
Hope you can fix this!  :-*

Fixed the new implementation so it works on AMD. All that had " error: expression must have pointer-to-struct-or-union type" type errors, please download the new version (build6), or simply update the sha512vectorized.cl file in your already downloaded build5.

Thanks to all for the bug reports and for the patience.
girino.

Offline NaN

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #54 on: January 26, 2014, 08:56:15 pm »
here is a new, fast miner for AMD gpus: https://bitsharestalk.org/index.php?topic=2598.0

Offline krpetrov

  • Jr. Member
  • **
  • Posts: 43
    • View Profile
Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #53 on: January 26, 2014, 08:53:02 pm »
Someone with Nvidia - how much collisions per minutes do you get?

Offline Bigboppa

  • Jr. Member
  • **
  • Posts: 30
    • View Profile
Re: OpenCL GPU miner by girino for ypool.net - edit: bug on AMD corrected
« Reply #52 on: January 26, 2014, 07:26:03 pm »
new v6 works like a charm! 2300 cpm with 2x 9280x (-a gpuv7 -m1024) !   :)

Offline slacking

  • Jr. Member
  • **
  • Posts: 47
    • View Profile

Fixed the new implementation so it works on AMD. All that had " error: expression must have pointer-to-struct-or-union type" type errors, please download the new version (build6), or simply update the sha512vectorized.cl file in your already downloaded build5.

Thanks to all for the bug reports and for the patience.
girino.

Updated to V6 of the miner. Windows 8.1 64 bit, overclocked Radeon 7950, -a gpuv7 (used to crash on this before) -m512 (1024 still crashes)...now getting in the 1030 cpm range.

http://i.imgur.com/0jc0v5y.jpg

Update: After running for half a hour or so, cpm's rose and stabilized at around 1048....not too darn bad for a Radeon 7950.

Update: After running for a few hours, cpm's are at a stable 1056.
« Last Edit: January 26, 2014, 11:23:19 pm by slacking »

Offline girino

  • Full Member
  • ***
  • Posts: 73
    • View Profile
Same error here...  :(
win7_x64, 2x R9280
Hope you can fix this!  :-*

Fixed the new implementation so it works on AMD. All that had " error: expression must have pointer-to-struct-or-union type" type errors, please download the new version (build6), or simply update the sha512vectorized.cl file in your already downloaded build5.

Thanks to all for the bug reports and for the patience.
girino.