Author Topic: Avoid forking  (Read 2130 times)

0 Members and 1 Guest are viewing this topic.

Offline abit

  • Committee member
  • Hero Member
  • *
  • Posts: 4664
    • View Profile
    • Abit's Hive Blog
  • BitShares: abit
  • GitHub: abitmore
More console logs may be useful.

Either your minor fork is getting too long (longer than max_undo_db_size) so it will be unable to switch back, or perhaps there is a bug in the fork switching code.
BitShares committee member: abit
BitShares witness: in.abit

Offline pc

  • Hero Member
  • *****
  • Posts: 1530
    • View Profile
    • Bitcoin - Perspektive oder Risiko?
  • BitShares: cyrano
So we tried what you proposes, and in order to make it, we had to start a first node with the property to true, otherwise, it doesn't start.
then, we added two nodes with enable-stale-production with false, and we restarted the first node, changing the param from true to false as well.

Good, keep it like that.

Then, we tested again, disconnect the network, reconnect the network, and we had the same effect as before.

I think you must also set the "required-participation" parameter so that a single node notices that it's on a minority chain. I. e. if you have three nodes, required-participation should be > 33% on each.
Bitcoin - Perspektive oder Risiko? ISBN 978-3-8442-6568-2 http://bitcoin.quisquis.de

Offline LoyaltyCoin

  • Newbie
  • *
  • Posts: 7
    • View Profile
Make sure "enable-stale-production = false" is set in your config.ini (on all nodes).

Thanks for your responsiveness.

So we tried what you proposes, and in order to make it, we had to start a first node with the property to true, otherwise, it doesn't start.
then, we added two nodes with enable-stale-production with false, and we restarted the first node, changing the param from true to false as well.
Then, we tested again, disconnect the network, reconnect the network, and we had the same effect as before.

any other idea?

Offline pc

  • Hero Member
  • *****
  • Posts: 1530
    • View Profile
    • Bitcoin - Perspektive oder Risiko?
  • BitShares: cyrano
Make sure "enable-stale-production = false" is set in your config.ini (on all nodes).
Bitcoin - Perspektive oder Risiko? ISBN 978-3-8442-6568-2 http://bitcoin.quisquis.de

Offline LoyaltyCoin

  • Newbie
  • *
  • Posts: 7
    • View Profile
Hi All,

As I said in my ann thread, we are using graphene.
we are currently running in private with 3 nodes. Two are hosted by third party and one is hosted at home.
The node at home sometimes disconnects from the network and start its own chain, its own fork. In order to reproduce the problem, we just have to disconnect the connection of our home computer, we can see that it forks, and eventually, when we switch the connection on, the home node remains in its own fork and do not reconnect to the other nodes.

In order to eliminate this effect, we need to stop the node, and restart it.

Does anyone has an idea of the reason why it happens, and how to avoid this problem?

Thanks.