Author Topic: AMD OpenCL Momentum miner  (Read 145977 times)

0 Members and 1 Guest are viewing this topic.

Offline srkpvn

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #405 on: February 17, 2014, 02:26:57 pm »
In batch file i have this path only "clpts_x86-64.exe -u 1.pts_1 -p 123 -t 0,0 -a 1" username worker name password all i gave in ypool.net its correct?

Offline wsnnwa

  • Jr. Member
  • **
  • Posts: 47
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #406 on: February 17, 2014, 02:31:01 pm »
I need some help setting up my miner. I have my 290 on the Ubuntu machine. Can someone help me set it up? I don't know the commands to get it running in as I am very new to Ubuntu. Still learning the process and terminal. Can someone help me?

Change directory to the folder containing the miner files.

chmod u+x ./clpts

For Be^5r -> ./clpts <address> -t 0,0

For YPool -> ./clpts -u <username>.<worker> -p <workerpassword> -t 0,0

« Last Edit: February 17, 2014, 02:44:35 pm by wsnnwa »

Offline mbender71

  • Jr. Member
  • **
  • Posts: 36
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #407 on: February 17, 2014, 02:36:28 pm »
I need some help setting up my miner. I have my 290 on the Ubuntu machine. Can someone help me set it up? I don't know the commands to get it running in as I am very new to Ubuntu. Still learning the process and terminal. Can someone help me?

Change directory to the folder containing the miner files.

chmod u+x ./clpts

For Be^5r -> ./clpts <address> -t 0,0

For YPool -> ./clpts -u <username>.<worker> -p <workerpassword>

I apologize if this was all the information you needed. Starting up the miner is the easy part. I was assuming that you
just installed Ubuntu and you haven't installed the AMD catalyst drivers and assured that xorg.conf was setup correctly
(which is kind of the pain in the neck part). If you have 'aticonfig --list-adapters' working and reporting all your GPU's
then you're pretty much good to go!

Offline Hukkel

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #408 on: February 17, 2014, 02:43:34 pm »
In batch file i have this path only "clpts_x86-64.exe -u 1.pts_1 -p 123 -t 0,0 -a 1" username worker name password all i gave in ypool.net its correct?

You have registered on Ypool, then you go to the "workers" tab and create a worker which you give a name and a password.

You insert the name and password into the scrypt. That is all.

Offline wsnnwa

  • Jr. Member
  • **
  • Posts: 47
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #409 on: February 17, 2014, 02:46:07 pm »
I need some help setting up my miner. I have my 290 on the Ubuntu machine. Can someone help me set it up? I don't know the commands to get it running in as I am very new to Ubuntu. Still learning the process and terminal. Can someone help me?

Change directory to the folder containing the miner files.

chmod u+x ./clpts

For Be^5r -> ./clpts <address> -t 0,0

For YPool -> ./clpts -u <username>.<worker> -p <workerpassword>

I apologize if this was all the information you needed. Starting up the miner is the easy part. I was assuming that you
just installed Ubuntu and you haven't installed the AMD catalyst drivers and assured that xorg.conf was setup correctly
(which is kind of the pain in the neck part). If you have 'aticonfig --list-adapters' working and reporting all your GPU's
then you're pretty much good to go!

I read it from a different perspective lol, I assumed he had his drivers set up...If he does then he should be able to just use those commands.

Offline zvs

  • Full Member
  • ***
  • Posts: 193
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #410 on: February 17, 2014, 02:50:56 pm »
my .bat is  clpts_x86-64.exe -u xxxxxx.pts_1 -p xxxxx -t 0,1

everything was working fine the past few day until tonight. i was getting ~1750 col/m on these settings.

I am on a 7970, running clpts_x86-64 -u user.1 -p 1 -t 0 -a 3,3

it gets 2800 collisions/m

i guess it can probably go higher, but i haven't really tinkered with the algorithm settings any, or card settings

it's running @ 1100 core 1300 memory , 1.063v, 61oC in ~76oF ambient

ed: and i need to read the readme file, because i'm not even sure if i'm using the -t and -a modifiers properly, scratch.  i thought -t specified the device #
« Last Edit: February 17, 2014, 03:00:27 pm by zvs »
Pls to join Primedice 3 and frolic about merrily whilst gambling awe-inspiring quantities of bitcoins. The power of Christ compels you.

I have a dogecoin p2pool at Nogleg.

Offline zvs

  • Full Member
  • ***
  • Posts: 193
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #411 on: February 17, 2014, 02:57:23 pm »
I think I saw this somewhere on this thread;

I have a 5770 on Ubuntu that I've been trying to test before putting my 290's on it. I cannot get the miner to work on the 5770. This is normal right? I was trying and failing but then remembered I thought I read in here that HD 5 series cards won't work on Ubuntu but will work in windows. I am curious as I did have it working with this miner in Windows.

So just to clarify can the 5770 mine using this miner in Ubuntu?

i had to move some cards around, since ptsgpu won't let me specify the devices to run it on, but will actually work with things like 5830.

so I run this on my 7970, 270's, etc.. and run ptsgpu on the older cards
Pls to join Primedice 3 and frolic about merrily whilst gambling awe-inspiring quantities of bitcoins. The power of Christ compels you.

I have a dogecoin p2pool at Nogleg.

Offline Darkbane

  • Full Member
  • ***
  • Posts: 119
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #412 on: February 17, 2014, 03:06:52 pm »
my .bat is  clpts_x86-64.exe -u xxxxxx.pts_1 -p xxxxx -t 0,1

everything was working fine the past few day until tonight. i was getting ~1750 col/m on these settings.

I am on a 7970, running clpts_x86-64 -u user.1 -p 1 -t 0 -a 3,3

it gets 2800 collisions/m

i guess it can probably go higher, but i haven't really tinkered with the algorithm settings any, or card settings

it's running @ 1100 core 1300 memory , 1.063v, 61oC in ~76oF ambient

ed: and i need to read the readme file, because i'm not even sure if i'm using the -t and -a modifiers properly, scratch.  i thought -t specified the device #

Yes you have -t and -a backwards... -t 3,3 -a 1

this will run two threads on the number 3 GPU... if you have another card to run this on, it might look like 3,3,4 to run two threads on GPU 3 and 1 thread on GPU 4... all depends what you have... I see you must be using gpu 0,1,2 for another miner? just have to get the right GPU ID for the right card...

I've found the -a 1 to be the best setting, but try all of them to see what works best for your card (0,1,2,3), -a 0 is more for the 290 crowd I guess... and yes please read the readme file it has the basic examples folks should be using. :)
« Last Edit: February 17, 2014, 03:09:37 pm by Darkbane »

Offline zvs

  • Full Member
  • ***
  • Posts: 193
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #413 on: February 17, 2014, 03:12:08 pm »
my .bat is  clpts_x86-64.exe -u xxxxxx.pts_1 -p xxxxx -t 0,1

everything was working fine the past few day until tonight. i was getting ~1750 col/m on these settings.

I am on a 7970, running clpts_x86-64 -u user.1 -p 1 -t 0 -a 3,3

it gets 2800 collisions/m

i guess it can probably go higher, but i haven't really tinkered with the algorithm settings any, or card settings

it's running @ 1100 core 1300 memory , 1.063v, 61oC in ~76oF ambient

ed: and i need to read the readme file, because i'm not even sure if i'm using the -t and -a modifiers properly, scratch.  i thought -t specified the device #

Yes you have -t and -a backwards... -t 3,3 -a 1

this will run two threads on the number 3 GPU... if you have another card to run this on, it might look like 3,3,4 to run two threads on GPU 3 and 1 thread on GPU 4... all depends what you have... I see you must be using gpu 0,1,2 for another miner? just have to get the right GPU ID for the right card...

I've found the -a 1 to be the best setting, but try all of them to see what works best for your card (0,1,2,3), -a 0 is more for the 290 crowd I guess... and yes please read the readme file it has the basic examples folks should be using. :)

haha, yeah, this is much better.  now it's -t 0,0 and -a 1... getting 3500cpm (only a 30 second reading so could be off 10% or so but still much faster than before)
Pls to join Primedice 3 and frolic about merrily whilst gambling awe-inspiring quantities of bitcoins. The power of Christ compels you.

I have a dogecoin p2pool at Nogleg.

Offline NewMine

  • Hero Member
  • *****
  • Posts: 551
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #414 on: February 17, 2014, 03:36:31 pm »
Please use the latest version, i.e. 0.1.4 for beeeeer.org and 0.2.2 for ypool.net
EDIT Is another miner running on your computer?

Checked environment variables and GPU_MAX_ALLOC_PERCENT was set at 0. Changed it to 100 percent. Everything is working now. 0.2.2 is giving my 7970 ~2925 col/m. Much faster now!

Thanks for your help!

Maybe remember if somebody has same error to check that setting. Thanks again.
« Last Edit: February 18, 2014, 03:54:06 am by newmine »

Offline battleaxe

  • Jr. Member
  • **
  • Posts: 27
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #415 on: February 17, 2014, 04:01:27 pm »
I'm having a bear of a time getting my drivers installed for AMD. I have a 290. Been researching on the web for two days now. I know I'm a complete Ubuntu noob, so I"m sure that is the only problem. I like this operating system a lot. Just can't get the drivers and patches to work correctly. And thus can't get the miner to work either. Can someone help me?

Offline mbender71

  • Jr. Member
  • **
  • Posts: 36
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #416 on: February 17, 2014, 04:07:16 pm »
I'm having a bear of a time getting my drivers installed for AMD. I have a 290. Been researching on the web for two days now. I know I'm a complete Ubuntu noob, so I"m sure that is the only problem. I like this operating system a lot. Just can't get the drivers and patches to work correctly. And thus can't get the miner to work either. Can someone help me?

Sorry to hear about your troubles, but like I said before in my reply to you, this is NOT an easy operating system to just
pick up (from from Windows). You'll have to do lots of research to do this right and my advice that you look on YouTube for
a video to setup a Linux Miner + LiteCoin was the best... really!! Not a lot of hand holding on this forum I'm afraid. If you want
linux that bad you're gonna have to work for it like the rest of us.... or just stick to windows :-) Good luck!

Offline mbender71

  • Jr. Member
  • **
  • Posts: 36
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #417 on: February 17, 2014, 04:14:21 pm »
I'm having a bear of a time getting my drivers installed for AMD. I have a 290. Been researching on the web for two days now. I know I'm a complete Ubuntu noob, so I"m sure that is the only problem. I like this operating system a lot. Just can't get the drivers and patches to work correctly. And thus can't get the miner to work either. Can someone help me?

One last thing... if you read my posts in this thread you can learn a lot about what versions/combinations
work properly as I went through some headaches myself and I'm a seasoned linux guy. As always, do searches
and READ before asking such general questions.... the answers might be right in front of you and you won't have
to wait for us :-) :-)

Offline battleaxe

  • Jr. Member
  • **
  • Posts: 27
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #418 on: February 17, 2014, 05:32:27 pm »
Okay. Fair enough. I'll keep studying. I want to learn this.

Offline Alec246

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #419 on: February 17, 2014, 07:17:36 pm »
Should I add the lines
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1

Before the rest of the commands in the .bat? Does this makes any different in this miner?

Thx!