Author Topic: AMD OpenCL Momentum miner  (Read 153256 times)

0 Members and 1 Guest are viewing this topic.

Offline Hukkel

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #465 on: February 20, 2014, 08:18:30 am »
Make 3 .bat foles, one for each card and run them individually.

Offline znakistu

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #466 on: February 20, 2014, 08:57:38 am »
Hello Guys,

First of all i want to thank you NAN for this beautiful miner.

I just wanna share my results for now:

My config (temporally):

Asrock Z77 extreme 6
8gb ram
I5 3570k
2x Sapphire R9 280x vapor-x oc 3gb ddr5 384bit
1 psu chieftech super 750w

My bat file: clpts_x86-64.exe -u x -p x -t 0,0,1,1 -a 2

Miner version: clpts-v0.2.2_win_x86-64

Undervolted as follow:

Core voltage (mv): 1094 mv
power limit: 0
core clock: 1055 mhz
memory clock: 1500 mhz
fan speed: 56%
Temp: Gpu0 - 66 oC
           GPU1 - 55 oC

« Last Edit: February 20, 2014, 09:06:01 am by znakistu »

Offline xxsoft

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #467 on: February 20, 2014, 09:03:16 am »
how to set the fan speed to 100%? with multiple GPU Fan speed? @ubuntu 12.04

Hint : cgminer..... aticonfig does NOT work under linux with more than one GPU

It works, just use the following.


export DISPLAY=:0
aticonfig --pplib-cmd "set fanspeed 0 100"

export DISPLAY=:0.1
aticonfig --pplib-cmd "set fanspeed 0 100"

"export DISPLAY=:0.X" --> Change X to whatever GPU you want to change the fan speed on.

i just can control 0 GPU ‘s fan speed
but
 export DISPLAY=:0.1
aticonfig --pplib-cmd "set fanspeed 0 100"
can not control?
what ’s wrong?

Offline zvs

  • Full Member
  • ***
  • Posts: 193
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #468 on: February 20, 2014, 12:15:52 pm »
Pls to join Primedice 3 and frolic about merrily whilst gambling awe-inspiring quantities of bitcoins. The power of Christ compels you.

I have a dogecoin p2pool at Nogleg.

Offline marcolecorse

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #469 on: February 20, 2014, 12:31:26 pm »
Hello
Pls Help


Offline zvs

  • Full Member
  • ***
  • Posts: 193
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #470 on: February 20, 2014, 12:43:33 pm »
Hello
Pls Help

according to your latest screenshot, you didn't even do what he suggested

so what more can be said?

well, OK, I'm curious as to why you've increased the voltage and powerlimit in afterburner.   with those settings, you should be undervolting

ed:   :-\

ok, run at 1100-1250 instead, you shouldnt need to raise voltage for that either, but who knows.  depends on the card I guess.

then run

clpts_x86-64 -u xxx -p xxx -t 0,0,1,1,2,2 -a 1

if you still get super slow speeds, fix your drivers

i get 3600 c/m with a 7970 in windows 7

ed2:  oh, for starters, both the screenshots in here are using the wrong version of catalyst

ed3:  and in screenshot 1, uh, is your PSU good enough to run that?  lol.
« Last Edit: February 20, 2014, 12:51:01 pm by zvs »
Pls to join Primedice 3 and frolic about merrily whilst gambling awe-inspiring quantities of bitcoins. The power of Christ compels you.

I have a dogecoin p2pool at Nogleg.

Offline marcolecorse

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #471 on: February 20, 2014, 01:09:36 pm »
Hello
Pls Help

according to your latest screenshot, you didn't even do what he suggested

so what more can be said?

well, OK, I'm curious as to why you've increased the voltage and powerlimit in afterburner.   with those settings, you should be undervolting

ed:   :-\

ok, run at 1100-1250 instead, you shouldnt need to raise voltage for that either, but who knows.  depends on the card I guess.

then run

clpts_x86-64 -u xxx -p xxx -t 0,0,1,1,2,2 -a 1

if you still get super slow speeds, fix your drivers

i get 3600 c/m with a 7970 in windows 7

ed2:  oh, for starters, both the screenshots in here are using the wrong version of catalyst

ed3:  and in screenshot 1, uh, is your PSU good enough to run that?  lol.

Hello

Thx for reply

Test R9 290 Solo

Windows 8.1 Drivers 13.12
Code: [Select]
-a 0 -t 0
« Last Edit: February 20, 2014, 01:11:42 pm by marcolecorse »

Offline battleaxe

  • Jr. Member
  • **
  • Posts: 27
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #472 on: February 20, 2014, 01:19:25 pm »
I get the following error ...

*****************************************************************************
** clpts - OpenCL PTS Pool Miner v0.7 RC2 <experimental>
** by NaN - based on ptsminer.
** If you like this software, please consider sending tips to: [email protected]
l.com
** PTS:  PtLx9kDLTXtR1ae3u7naXLPeGjjHZ1PGoR
** BTC:  1AumJ5uzz1nuER7pBA6Bh4gNusaxhN85rc
** Your donations will encourage further optimization and development
**
** press CTRL+C to exit
*****************************************************************************
Vendor of used platform (#1 / 2): Advanced Micro Devices, Inc.
        Name of device #1 / 1 (deviceID 0): Tahiti


Vendor of platform #2 / 2: Intel(R) Corporation
error in gpuhash.h, line 131: Method clGetDeviceIDs(...) failed (errorcode -1)

I'm getting this exact same error in Linux Lite. I assume its the same problem. I'm running Catalyst 13.12 drivers. Can someone help with scrypt to disable the Intel OpenCL in terminal?

Offline zvs

  • Full Member
  • ***
  • Posts: 193
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #473 on: February 20, 2014, 01:25:11 pm »
Hello
Pls Help

according to your latest screenshot, you didn't even do what he suggested

so what more can be said?

well, OK, I'm curious as to why you've increased the voltage and powerlimit in afterburner.   with those settings, you should be undervolting

ed:   :-\

ok, run at 1100-1250 instead, you shouldnt need to raise voltage for that either, but who knows.  depends on the card I guess.

then run

clpts_x86-64 -u xxx -p xxx -t 0,0,1,1,2,2 -a 1

if you still get super slow speeds, fix your drivers

i get 3600 c/m with a 7970 in windows 7

ed2:  oh, for starters, both the screenshots in here are using the wrong version of catalyst

ed3:  and in screenshot 1, uh, is your PSU good enough to run that?  lol.

Hello

Thx for reply

Test R9 290 Solo

Windows 8.1 Drivers 13.12
Code: [Select]
-a 0 -t 0
first, download catalyst v14.1 and amd app sdk 2.9

second, get driver uninstaller from http://www.wagnardmobile.com/DDU/  boot into safe mode select remove AMD drivers, select install windows default drivers, start process, select "restart computer"

third,  install catalyst v14.1

four, install amd app sdk 2.9

five, reboot (might not be necessary)

six, clpts_x86-64 -u xxx -p xxx -t 0,0 -a 1

seven, wait at least two minutes
Pls to join Primedice 3 and frolic about merrily whilst gambling awe-inspiring quantities of bitcoins. The power of Christ compels you.

I have a dogecoin p2pool at Nogleg.

Offline battleaxe

  • Jr. Member
  • **
  • Posts: 27
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #474 on: February 20, 2014, 01:29:40 pm »
Which drivers are working better on this 13.12 or 14.1  ?

Also how do I disable the Intel OpenCL SDK in linux? Its fighting with the AMD SDK apparently. Can't seem to find much on Google about this (nothing actually).

Edit: I'm going to try to get an answer to the SDK problem on an Ubuntu forum... maybe they will help me.
« Last Edit: February 20, 2014, 02:04:52 pm by battleaxe »

Offline marcolecorse

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #475 on: February 20, 2014, 01:55:48 pm »
Hello
Pls Help

according to your latest screenshot, you didn't even do what he suggested

so what more can be said?

well, OK, I'm curious as to why you've increased the voltage and powerlimit in afterburner.   with those settings, you should be undervolting

ed:   :-\

ok, run at 1100-1250 instead, you shouldnt need to raise voltage for that either, but who knows.  depends on the card I guess.

then run

clpts_x86-64 -u xxx -p xxx -t 0,0,1,1,2,2 -a 1

if you still get super slow speeds, fix your drivers

i get 3600 c/m with a 7970 in windows 7

ed2:  oh, for starters, both the screenshots in here are using the wrong version of catalyst

ed3:  and in screenshot 1, uh, is your PSU good enough to run that?  lol.

Hello

Thx for reply

Test R9 290 Solo

Windows 8.1 Drivers 13.12
Code: [Select]
-a 0 -t 0
first, download catalyst v14.1 and amd app sdk 2.9

second, get driver uninstaller from http://www.wagnardmobile.com/DDU/  boot into safe mode select remove AMD drivers, select install windows default drivers, start process, select "restart computer" Ok

third,  install catalyst v14.1   ok

four, install amd app sdk 2.9  ok

five, reboot (might not be necessary)

six, clpts_x86-64 -u xxx -p xxx -t 0,0 -a 1

seven, wait at least two minutes

look

Offline battleaxe

  • Jr. Member
  • **
  • Posts: 27
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #476 on: February 20, 2014, 02:36:43 pm »
Bug reported to developer.

I have 4 r9 290x running on ubuntu 12.10. The driver is 13.12 linux. I tried to run clptes but have an error message.

error in xptMiner/clInit.cpp, line 96: Method clGetDeviceIDs(...) failed (errorcode -1)

Any idea to fix it?

Were you able to fix this? I have the same error code. My devices are found fine though. Just won't start the miner.

Offline NaN

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #477 on: February 20, 2014, 02:52:56 pm »
That's not a miner bug. Most likely there is no running Xserver or OpenCL is not installed correctly. Do you use the newest version because older versions could have such behaviour if a Intel OpenCL platform was installed?
« Last Edit: February 20, 2014, 02:56:23 pm by NaN »

Offline battleaxe

  • Jr. Member
  • **
  • Posts: 27
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #478 on: February 20, 2014, 03:16:28 pm »
I wasn't implying it was a miner bug. I was able to get the miner to fire up on a 5770, even though it couldn't do anything. But when I put the 290 in the machine, then I get this code. I reinstalled the drivers, but same thing. I get this error. So I've got something wrong with the software installation otherwise. Been Googling for two days now. Nothing seems to work. This is the full error. Running AMD 13.12 drivers. And AMD APP SDK 2.9

** clpts - OpenCL PTS Pool Miner v0.2.2 (ypool.net only)
** by NaN - based on xptMiner by jh00 (clintar's code v1.1)
** If you like this software, please consider sending tips to: [email protected]
** PTS:  PajuVUWrcPn5ksCFfrBiWQXvpwtE29dcN2
** BTC:  1AumJ5uzz1nuER7pBA6Bh4gNusaxhN85rc
** Your donations will encourage further optimization and development
**
** press CTRL+C to exit
*****************************************************************************

Vendor of used platform (#1 / 1): Advanced Micro Devices, Inc.
error in xptMiner/clInit.cpp, line 96: Method clGetDeviceIDs(...) failed (errorcode -1)
« Last Edit: February 20, 2014, 03:21:54 pm by battleaxe »

Offline NaN

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #479 on: February 20, 2014, 03:24:28 pm »
Rewrite your xorg.conf by running sudo aticonfig --adapter=all --initial -f and reboot.