Author Topic: AMD OpenCL Momentum miner  (Read 143863 times)

0 Members and 1 Guest are viewing this topic.

Offline Alec246

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #720 on: March 30, 2014, 04:57:51 pm »
Still not working with Catalyst 14.3 in Xubuntu :/ Using the latest 1.0 version made for CAT 14

I have no idea why it's saying there's no supported card, if cgminer is running fine!

Offline Mfqrs3

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #721 on: March 30, 2014, 05:12:42 pm »
Hi NaN,
Thanks for the latest miner!

It's working fine in Win7 64bit with latest 14.3 beta drivers, but it doesn't work with win 8.1 64bit with 13.12 drivers, R9 270, R9 280x or R9 290 cards.

Error: Compilation from LLVMIR binary to IL text failed!

Use beta drivers.. or use old gpu_hash files from previous versions.

I'm bond with stock drivers with win 8.1, because only with them I got all six cards runing without problems.

Thanks for the tip, using old gpu_hash files did the trick for now!

Offline NaN

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #722 on: March 30, 2014, 05:49:55 pm »
Hi NaN,
Thanks for the latest miner!

It's working fine in Win7 64bit with latest 14.3 beta drivers, but it doesn't work with win 8.1 64bit with 13.12 drivers, R9 270, R9 280x or R9 290 cards.

Error: Compilation from LLVMIR binary to IL text failed!
As you may have noticed there are different files for Catalyst 13.12 and Catalyst 14.x drivers. You have to use the *Catalyst13 files for Catalyst 13.12

Offline Mfqrs3

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #723 on: March 30, 2014, 05:57:56 pm »
Hi NaN,
Thanks for the latest miner!

It's working fine in Win7 64bit with latest 14.3 beta drivers, but it doesn't work with win 8.1 64bit with 13.12 drivers, R9 270, R9 280x or R9 290 cards.

Error: Compilation from LLVMIR binary to IL text failed!
As you may have noticed there are different files for Catalyst 13.12 and Catalyst 14.x drivers. You have to use the *Catalyst13 files for Catalyst 13.12

You mean Gpu_hash files or driver files ? If driver files which and how shoul I replace them ? Just copy over the old ones or ?
Tnx

Offline Ykw

  • Full Member
  • ***
  • Posts: 88
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #724 on: March 30, 2014, 06:12:55 pm »
Hi NaN,
Thanks for the latest miner!

It's working fine in Win7 64bit with latest 14.3 beta drivers, but it doesn't work with win 8.1 64bit with 13.12 drivers, R9 270, R9 280x or R9 290 cards.

Error: Compilation from LLVMIR binary to IL text failed!
As you may have noticed there are different files for Catalyst 13.12 and Catalyst 14.x drivers. You have to use the *Catalyst13 files for Catalyst 13.12

You mean Gpu_hash files or driver files ? If driver files which and how shoul I replace them ? Just copy over the old ones or ?
Tnx

NaN wanted you to understand that in his download links... there are 2 set of files (miner+gpu_hash files), ones are for 13.12 drivers.. the other for the beta 14.x version. So you should download the correct version to run over the correct driver you are using.

The gpu_hash switch trick was before he posted that fix.

Offline Mfqrs3

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #725 on: March 30, 2014, 06:21:50 pm »
Ah I get it now :D
Tnx !

Offline NaN

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #726 on: March 30, 2014, 07:37:00 pm »
I updated the miner to v1.1, which solves some issues and adds support for the upcpu.com-pool.

Offline upcpu

  • Jr. Member
  • **
  • Posts: 26
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #727 on: March 31, 2014, 03:08:07 am »
Cool!

I updated the miner to v1.1, which solves some issues and adds support for the upcpu.com-pool.

Offline upcpu

  • Jr. Member
  • **
  • Posts: 26
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #728 on: March 31, 2014, 03:11:51 am »
    PoolID 7: upcpu.com (xptspool.upcpu.com:8080-8087, xpt5)

XPT version 6 had been supported in upcpu.com. It's better than v5.

I updated the miner to v1.1, which solves some issues and adds support for the upcpu.com-pool.

Offline NaN

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #729 on: March 31, 2014, 03:24:51 am »
Ok, I will test xpt6 on upcpu.com.

Offline justmwa

  • Jr. Member
  • **
  • Posts: 23
    • View Profile
    • PTS Stats!
Re: fast AMD OpenCL PTS miner released
« Reply #730 on: March 31, 2014, 08:47:29 am »
I updated the miner to v1.1, which solves some issues and adds support for the upcpu.com-pool.
Thanks! You forgot to update the banner though  8)
Unpaid PTS Stats
PTS:PhE77ocVCEaQVdxHHsMHixyBqrhiPhpdEw XPM:AZr7WijkyktevRvdyCCjrvti39hp5mw6Tj BTC:1GFHGxticHrtpXuavh3jMjGmfFVCT2zExM

Offline ozzy

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #731 on: March 31, 2014, 08:48:35 am »
I used C++11 for the new miner. Is your glibc up to date? Perhaps I should revert to boost and statically link it. Which distro do you use?
EDIT: Oh, the correct syntax is
./clpts -o 0,6 Pezz4JUPfpAFTSSwWgp1TMpCcS1YvEqVsn -u ozzy.PTS_1 -p x -t 0,0,1,1,2,2 -a 2
yea i also tried the ./clpts -o 0,6 Pezz4JUPfpAFTSSwWgp1TMpCcS1YvEqVsn -u ozzy.PTS_1 -p x -t 0,0,1,1,2,2 -a 2

but it didnt work .And i dont know if i have the latest c++11 i dont know much about linux (i am using ubuntu 12.04 )
edit i manage to install but :
installed
                      Conflicts: libstdc++6-4.5-dbg but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-dbg but 4.6.4-1ubuntu1~12.04 is to be installed
 libstdc++6-4.7-doc : Conflicts: libstdc++6-4.4-doc but 4.4.7-1ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.5-doc but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-doc but 4.6.4-1ubuntu1~12.04 is to be installed
 libstdc++6-4.8-dbg : Conflicts: libstdc++6-4.4-dbg but 4.4.7-1ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.5-dbg but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-dbg but 4.6.4-1ubuntu1~12.04 is to be installed
                      Conflicts: libstdc++6-4.7-dbg but 4.7.3-2ubuntu1~12.04 is to be installed
E: Unable to correct problems, you have held broken packages.
I got the same error with Ubuntu 12.04, I solved it by

sudo apt-get install libstdc++6
it also doesnt work
i am geting :
libstdc++6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 57 not upgraded.

btw i am using amd-catalyst-14.1-betav1.3-linux-x86.x86_64 drivers
« Last Edit: March 31, 2014, 08:55:27 am by ozzy »

Offline GrimVandal

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #732 on: March 31, 2014, 09:37:07 am »
And I was hoping for a version which runs with 1 GB cards. (7850 1 GB)

 :(

Offline Alec246

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #733 on: March 31, 2014, 01:38:08 pm »
I wanted to do PTS mining in my XUbuntu 13.10 , but no idea why the miner isn't recognizing my AMD card :/

Offline NaN

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #734 on: March 31, 2014, 01:40:23 pm »
Is your xorg.conf ok and is a X-server running? Otherwise you have to run the miner with sudo.