Author Topic: AMD OpenCL Momentum miner  (Read 143866 times)

0 Members and 1 Guest are viewing this topic.

Offline Alec246

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #735 on: March 31, 2014, 04:38:40 pm »
Tried with Sudo.

Pretty sure everything is OK otherwise I wouldn't be able to mine with cgminer.

Offline Ykw

  • Full Member
  • ***
  • Posts: 88
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #736 on: March 31, 2014, 05:01:24 pm »
I used C++11 for the new miner. Is your glibc up to date? Perhaps I should revert to boost and statically link it. Which distro do you use?
EDIT: Oh, the correct syntax is
./clpts -o 0,6 Pezz4JUPfpAFTSSwWgp1TMpCcS1YvEqVsn -u ozzy.PTS_1 -p x -t 0,0,1,1,2,2 -a 2
yea i also tried the ./clpts -o 0,6 Pezz4JUPfpAFTSSwWgp1TMpCcS1YvEqVsn -u ozzy.PTS_1 -p x -t 0,0,1,1,2,2 -a 2

but it didnt work .And i dont know if i have the latest c++11 i dont know much about linux (i am using ubuntu 12.04 )
edit i manage to install but :
installed
                      Conflicts: libstdc++6-4.5-dbg but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-dbg but 4.6.4-1ubuntu1~12.04 is to be installed
 libstdc++6-4.7-doc : Conflicts: libstdc++6-4.4-doc but 4.4.7-1ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.5-doc but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-doc but 4.6.4-1ubuntu1~12.04 is to be installed
 libstdc++6-4.8-dbg : Conflicts: libstdc++6-4.4-dbg but 4.4.7-1ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.5-dbg but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-dbg but 4.6.4-1ubuntu1~12.04 is to be installed
                      Conflicts: libstdc++6-4.7-dbg but 4.7.3-2ubuntu1~12.04 is to be installed
E: Unable to correct problems, you have held broken packages.
I got the same error with Ubuntu 12.04, I solved it by

sudo apt-get install libstdc++6
it also doesnt work
i am geting :
libstdc++6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 57 not upgraded.

btw i am using amd-catalyst-14.1-betav1.3-linux-x86.x86_64 drivers


You have libstdc++6-4.4 installed and probably have multiple sources.. with different names of the same package... try to remove all the libstdc++ and dependent packages and then install them again.. but using only one source. This is not a miner problem.. it's an OS config know how...

If you are uncomfortable with ubunto.. try other OSs you are ok with... you have fedora, centos, windows.. etc etc...

Otherwise.. post more details. (the more you can get)

Offline Ykw

  • Full Member
  • ***
  • Posts: 88
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #737 on: March 31, 2014, 05:06:44 pm »
Tried with Sudo.

Pretty sure everything is OK otherwise I wouldn't be able to mine with cgminer.

Can you post the output? Are you using/booting into single user mode (init 3) ? Is "startx" command working?

Offline ozzy

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #738 on: March 31, 2014, 05:24:15 pm »
Is your xorg.conf ok and is a X-server running? Otherwise you have to run the miner with sudo.
can you tell me what am i doing wrong?I am trying for 3 days but cant run the newest miner :/

Offline Alec246

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #739 on: March 31, 2014, 05:36:17 pm »
I don't want to mess too much with my Linux because it's working flawless for CgMiner! If I Start doing stuff to it, I will probably crash it, and since I have no Linux experience, the only way will be a complete Format :/

Here's the tutorial I followed

https://www.weminecryptos.com/forum/topic/2187-guide-housing-xubuntu-setup-amd-drivers-kdev-sd-cgminer-monitoring-and-vbios-flashing/

The output is simply No GPU Device with the id.

Offline Ykw

  • Full Member
  • ***
  • Posts: 88
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #740 on: March 31, 2014, 05:39:03 pm »
Hi folks....

You have to understand that if you want help you have to give back something.. just saying that it does not work.. doesn't help anyone nor it will be enough for anyone from the community to help.

Try to be logic... when you have a problem.. share the errors, configs, when problem started to happen, when it did not.. etc etc...

There are no magic within devs...  they are all hard working geeks =)

Offline Ykw

  • Full Member
  • ***
  • Posts: 88
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #741 on: March 31, 2014, 05:53:16 pm »
I don't want to mess too much with my Linux because it's working flawless for CgMiner! If I Start doing stuff to it, I will probably crash it, and since I have no Linux experience, the only way will be a complete Format :/

Here's the tutorial I followed

https://www.weminecryptos.com/forum/topic/2187-guide-housing-xubuntu-setup-amd-drivers-kdev-sd-cgminer-monitoring-and-vbios-flashing/

The output is simply No GPU Device with the id.

What you have in this "aticonfig --lsa"...


EDIT: Share the actual output of the miner when you try to run it
« Last Edit: March 31, 2014, 06:02:04 pm by Ykw »

Offline NaN

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #742 on: March 31, 2014, 06:19:00 pm »
I don't want to mess too much with my Linux because it's working flawless for CgMiner! If I Start doing stuff to it, I will probably crash it, and since I have no Linux experience, the only way will be a complete Format :/

Here's the tutorial I followed

https://www.weminecryptos.com/forum/topic/2187-guide-housing-xubuntu-setup-amd-drivers-kdev-sd-cgminer-monitoring-and-vbios-flashing/

The output is simply No GPU Device with the id.
That sounds like you're using wrong command line arguments. Could you post the output of the miner and your command line arguments?

Offline NaN

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #743 on: March 31, 2014, 06:23:11 pm »
I used C++11 for the new miner. Is your glibc up to date? Perhaps I should revert to boost and statically link it. Which distro do you use?
EDIT: Oh, the correct syntax is
./clpts -o 0,6 Pezz4JUPfpAFTSSwWgp1TMpCcS1YvEqVsn -u ozzy.PTS_1 -p x -t 0,0,1,1,2,2 -a 2
yea i also tried the ./clpts -o 0,6 Pezz4JUPfpAFTSSwWgp1TMpCcS1YvEqVsn -u ozzy.PTS_1 -p x -t 0,0,1,1,2,2 -a 2

but it didnt work .And i dont know if i have the latest c++11 i dont know much about linux (i am using ubuntu 12.04 )
edit i manage to install but :
installed
                      Conflicts: libstdc++6-4.5-dbg but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-dbg but 4.6.4-1ubuntu1~12.04 is to be installed
 libstdc++6-4.7-doc : Conflicts: libstdc++6-4.4-doc but 4.4.7-1ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.5-doc but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-doc but 4.6.4-1ubuntu1~12.04 is to be installed
 libstdc++6-4.8-dbg : Conflicts: libstdc++6-4.4-dbg but 4.4.7-1ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.5-dbg but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-dbg but 4.6.4-1ubuntu1~12.04 is to be installed
                      Conflicts: libstdc++6-4.7-dbg but 4.7.3-2ubuntu1~12.04 is to be installed
E: Unable to correct problems, you have held broken packages.
I got the same error with Ubuntu 12.04, I solved it by

sudo apt-get install libstdc++6
it also doesnt work
i am geting :
libstdc++6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 57 not upgraded.

btw i am using amd-catalyst-14.1-betav1.3-linux-x86.x86_64 drivers
Did you try to use v1.1? If it does not work I can give you a statically linked version of the miner so there are no dependencies on OS-libraries. The disadvantage is that the binaries become several MB large.

Offline kpematop

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #744 on: March 31, 2014, 06:43:19 pm »
Is there any performance improvement with version 1.x compared against 0.2.2?

Offline ozzy

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #745 on: March 31, 2014, 06:43:50 pm »
I used C++11 for the new miner. Is your glibc up to date? Perhaps I should revert to boost and statically link it. Which distro do you use?
EDIT: Oh, the correct syntax is
./clpts -o 0,6 Pezz4JUPfpAFTSSwWgp1TMpCcS1YvEqVsn -u ozzy.PTS_1 -p x -t 0,0,1,1,2,2 -a 2
yea i also tried the ./clpts -o 0,6 Pezz4JUPfpAFTSSwWgp1TMpCcS1YvEqVsn -u ozzy.PTS_1 -p x -t 0,0,1,1,2,2 -a 2

but it didnt work .And i dont know if i have the latest c++11 i dont know much about linux (i am using ubuntu 12.04 )
edit i manage to install but :
installed
                      Conflicts: libstdc++6-4.5-dbg but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-dbg but 4.6.4-1ubuntu1~12.04 is to be installed
 libstdc++6-4.7-doc : Conflicts: libstdc++6-4.4-doc but 4.4.7-1ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.5-doc but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-doc but 4.6.4-1ubuntu1~12.04 is to be installed
 libstdc++6-4.8-dbg : Conflicts: libstdc++6-4.4-dbg but 4.4.7-1ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.5-dbg but 4.5.3-12ubuntu2 is to be installed
                      Conflicts: libstdc++6-4.6-dbg but 4.6.4-1ubuntu1~12.04 is to be installed
                      Conflicts: libstdc++6-4.7-dbg but 4.7.3-2ubuntu1~12.04 is to be installed
E: Unable to correct problems, you have held broken packages.
I got the same error with Ubuntu 12.04, I solved it by

sudo apt-get install libstdc++6
it also doesnt work
i am geting :
libstdc++6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 57 not upgraded.

btw i am using amd-catalyst-14.1-betav1.3-linux-x86.x86_64 drivers
Did you try to use v1.1? If it does not work I can give you a statically linked version of the miner so there are no dependencies on OS-libraries. The disadvantage is that the binaries become several MB large.

yes i couldntmake v1.1 when i click the run in terminal window the miner window just opens and closes, v0.2.2 works ok   

Offline NaN

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #746 on: March 31, 2014, 06:47:15 pm »
Could you post the output of the miner and your config?

Offline ozzy

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #747 on: March 31, 2014, 07:20:48 pm »
Could you post the output of the miner and your config?
i do as what it says here:
http://www.overclock.net/t/1462655/guide-nvidia-amd-pts-gpu-mining/3000_100#post_21775115
 
#!/bin/bash

./clpts -o 0,6 Pezz4JUPfpAFTSSwWgp1TMpCcS1YvEqVsn -u ozzy.PTS_1 -p x -t 0,0,1,1,2,2 -a 2


Offline NaN

  • Full Member
  • ***
  • Posts: 162
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #748 on: March 31, 2014, 07:26:51 pm »
Could you execute ./clpts -o 0,6 Pezz4JUPfpAFTSSwWgp1TMpCcS1YvEqVsn -u ozzy.PTS_1 -p x -t 0,0,1,1,2,2 -a 2 directly in your bash (first switch to the folder of the miner)? I need the output of the miner otherwise I won't be able to solve your problem.

Offline ozzy

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #749 on: March 31, 2014, 08:28:17 pm »
i am   a beginner  linux user and dont know how to execute the bash :/
« Last Edit: March 31, 2014, 08:51:09 pm by ozzy »