Author Topic: [ANN] ypool.net - Fast PTS pool  (Read 214511 times)

0 Members and 1 Guest are viewing this topic.

Offline arcke

  • Full Member
  • ***
  • Posts: 115
    • View Profile
    • Diaspora
Re: [ANN] ypool.net - Fast PTS pool
« Reply #521 on: January 04, 2014, 11:50:06 pm »
https://bitsharestalk.org/index.php?topic=2001.0

Is someone able to respond to this users question regarding mining on ypool?
I gave some advise, links etc.
Nice, maybe we will create a sticky for howtos on pool mining different pool servers.
OpenPGP: 0x22d7e9cc35375665
PTS - PawnbhoiXhmkrKJEPAsCiwkpP81nRXJGTD
Diaspora profile - https://pod.orkz.net/u/arcke

Offline CryptoN8

  • Full Member
  • ***
  • Posts: 192
    • View Profile
Re: [ANN] ypool.net - Fast PTS pool
« Reply #520 on: January 04, 2014, 11:47:42 pm »
https://bitsharestalk.org/index.php?topic=2001.0

Is someone able to respond to this users question regarding mining on ypool?
I gave some advise, links etc.

Offline arcke

  • Full Member
  • ***
  • Posts: 115
    • View Profile
    • Diaspora
Re: [ANN] ypool.net - Fast PTS pool
« Reply #519 on: January 04, 2014, 10:39:07 pm »
https://bitsharestalk.org/index.php?topic=2001.0

Is someone able to respond to this users question regarding mining on ypool?
OpenPGP: 0x22d7e9cc35375665
PTS - PawnbhoiXhmkrKJEPAsCiwkpP81nRXJGTD
Diaspora profile - https://pod.orkz.net/u/arcke

Offline CryptoN8

  • Full Member
  • ***
  • Posts: 192
    • View Profile
Re: [ANN] ypool.net - Fast PTS pool
« Reply #518 on: January 04, 2014, 05:02:44 am »
which yam version should i use?
i have an amd fx 8350
I am using the M7i-bdver1 and seeing ~250 CPM with 512M. My system only has 8GB ram, I'd like to put more but the CPU cooler is blocking 2 DIMM slots.  >:(

If I should be using a different version, please speak up. Thanks.

Offline nothosaurus

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: [ANN] ypool.net - Fast PTS pool
« Reply #517 on: January 04, 2014, 04:04:46 am »
I have tried all versions of jhproto miner,but none of them work including the yam version, my system is fedora 20 on IBM POWER 780. Anyone can help me?

Offline lemon

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [ANN] ypool.net - Fast PTS pool
« Reply #516 on: January 02, 2014, 02:23:21 pm »
which yam version should i use?
i have an amd fx 8350

Offline yvg1900

  • Full Member
  • ***
  • Posts: 198
    • View Profile
  • BitShares: yvg1900
Re: [ANN] ypool.net - Fast PTS pool
« Reply #515 on: January 02, 2014, 01:44:34 pm »
I am trying to build compatible version of glibc now, but oldest kernel tree I managed to get system running is 2.6.16. Looks like 2.6.9 is no-go nowadays in any case...

I will try building glibc with no version checking, but I doubt it is a good idea - very high chances of sudden crashes on supported variations...

yvg1900

P.S. This is already taking too much time, there is a high chance that I will give up on that. Sorry. Hopefully you understand.
Follow @yvg1900 on Twitter for yam miner updates and support

Offline bryantism

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: [ANN] ypool.net - Fast PTS pool
« Reply #514 on: January 02, 2014, 06:18:42 am »
install glibc will require


checking installed Linux kernel header files... TOO OLD!
configure: error: GNU libc requires kernel header files from
Linux 2.6.19 or later to be installed before configuring.
The kernel header files are found usually in /usr/include/asm and
/usr/include/linux; make sure these directories use files from
Linux 2.6.19 or later.  This check uses <linux/version.h>, so
make sure that file was built correctly when installing the kernel header
files.  To use kernel headers not from /usr/include/linux, use the
configure option --with-headers.


Offline bryantism

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: [ANN] ypool.net - Fast PTS pool
« Reply #513 on: January 02, 2014, 06:10:14 am »
it seems glibc 2.17need ..... but when i install 2.17, more wired problem.....

Offline ryvius

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: [ANN] ypool.net - Fast PTS pool
« Reply #512 on: January 02, 2014, 05:32:40 am »

 yam-yvg1900-M7i-linux64ld-core2

[yy@yy ~]$ ./yam
./yam: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./yam)
./yam: /lib64/libc.so.6: version `GLIBC_2.8' not found (required by ./yam)
./yam: /lib64/libc.so.6: version `GLIBC_2.9' not found (required by ./yam)
./yam: /lib64/libc.so.6: version `GLIBC_2.7' not found (required by ./yam)
./yam: /lib64/libc.so.6: version `GLIBC_2.17' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./yam)
[yy@yy ~]$ uname -a
Linux yy 2.6.18-308.el5 #1 SMP Fri Jan 27 17:17:51 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

[yy@yy ~]$ strings /usr/lib/libstdc++.so.6 | grep GLIBC
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBC_2.3
GLIBC_2.0
GLIBC_2.3.2
GLIBC_2.4
GLIBC_2.1
GLIBC_2.1.3
GLIBC_2.2
GLIBCXX_FORCE_NEW

Offline ryvius

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: [ANN] ypool.net - Fast PTS pool
« Reply #511 on: January 02, 2014, 05:25:59 am »

 yam-yvg1900-M7i-linux64ld-core2

[yy@yy ~]$ ./yam
./yam: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./yam)
./yam: /lib64/libc.so.6: version `GLIBC_2.8' not found (required by ./yam)
./yam: /lib64/libc.so.6: version `GLIBC_2.9' not found (required by ./yam)
./yam: /lib64/libc.so.6: version `GLIBC_2.7' not found (required by ./yam)
./yam: /lib64/libc.so.6: version `GLIBC_2.17' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./yam)
[yy@yy ~]$ uname -a
Linux yy 2.6.18-308.el5 #1 SMP Fri Jan 27 17:17:51 EST 2012 x86_64 x86_64 x86_64 GNU/Linux

Offline bryantism

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: [ANN] ypool.net - Fast PTS pool
« Reply #510 on: January 02, 2014, 05:24:41 am »
Bryantism,

After some evaluation of possibilities running yam with 2.6.9 kernels, only reasonable opportunity I found is that I build dynamically linked elf that will support glibc 2.7 and you have to build alternate glibc right on your system and run yam with that glibc using LD_LIBRARY_PATH .

Glibc shipped with that generation of RedHat distros is completely outdated and buggy when it comes to modern memory management.

If you feel you can take care of building secondary glibc on your system, that will probably involve updating GCC and binutils, then I can post dynamically linked version somewhere. If not I doubt it makes sense to support that version.

Follow @yvg1900 on Twitter to get updates on performance mining software

i installed glibc, but it's still :

./yam: /***/lib/libc.so.6: version `GLIBC_2.14' not found (required by ./yam)
./yam: /***/lib/libc.so.6: version `GLIBC_2.8' not found (required by ./yam)
./yam: /***/lib/libc.so.6: version `GLIBC_2.9' not found (required by ./yam)
./yam: /***/libc.so.6: version `GLIBC_2.17' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./yam)

are all these should be installed ?

i have ldd this program.
yam: /lib64/tls/libc.so.6: version `GLIBC_2.14' not found (required by ./yam)
./yam: /lib64/tls/libc.so.6: version `GLIBC_2.8' not found (required by ./yam)
./yam: /lib64/tls/libc.so.6: version `GLIBC_2.9' not found (required by ./yam)
./yam: /lib64/tls/libc.so.6: version `GLIBC_2.7' not found (required by ./yam)
./yam: /lib64/tls/libc.so.6: version `GLIBC_2.17' not found (required by ./yam)
.....
installed 2.7
all glibc 2.8 , 2.9 2.17 needed??

Offline bryantism

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: [ANN] ypool.net - Fast PTS pool
« Reply #509 on: January 02, 2014, 04:40:02 am »
Bryantism,

After some evaluation of possibilities running yam with 2.6.9 kernels, only reasonable opportunity I found is that I build dynamically linked elf that will support glibc 2.7 and you have to build alternate glibc right on your system and run yam with that glibc using LD_LIBRARY_PATH .

Glibc shipped with that generation of RedHat distros is completely outdated and buggy when it comes to modern memory management.

If you feel you can take care of building secondary glibc on your system, that will probably involve updating GCC and binutils, then I can post dynamically linked version somewhere. If not I doubt it makes sense to support that version.

Follow @yvg1900 on Twitter to get updates on performance mining software

i installed glibc, but it's still :

./yam: /***/lib/libc.so.6: version `GLIBC_2.14' not found (required by ./yam)
./yam: /***/lib/libc.so.6: version `GLIBC_2.8' not found (required by ./yam)
./yam: /***/lib/libc.so.6: version `GLIBC_2.9' not found (required by ./yam)
./yam: /***/libc.so.6: version `GLIBC_2.17' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./yam)
./yam: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./yam)

are all these should be installed ?

Offline yvg1900

  • Full Member
  • ***
  • Posts: 198
    • View Profile
  • BitShares: yvg1900
Re: [ANN] ypool.net - Fast PTS pool
« Reply #508 on: January 01, 2014, 09:53:31 pm »
Okay, let us try. I just uploaded set of dynamically-linked builds, link can be found in HowTo section at ypool.net, builds for linux64ld (state for Linux 64, Linked Dynamically). All supported instruction sets uploaded, download one of your interest and give it a try. But be ready for complications building on rhel4 - from this point you are on your own.

Let me know your results, if it will be positive l will make this build part of regular releases.

Follow @yvg1900 on Twitter to get updates on performance mining software

Follow @yvg1900 on Twitter for yam miner updates and support

Offline bryantism

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: [ANN] ypool.net - Fast PTS pool
« Reply #507 on: January 01, 2014, 08:07:57 pm »
ok  i think i can do it