Author Topic: BitShares 1.0, клиент 0.9.3c  (Read 60794 times)

0 Members and 1 Guest are viewing this topic.

Offline bitsharesegregor

  • Newbie
  • *
  • Posts: 4
    • View Profile
 Добрый день.
Подскажите пожалуйста,как правильно обновиться,чтобы не закачивать всю базу данных снова(на винде).

Offline testz

Вышла новая версия BitSharesX 0.4.19, всем клиентам и делегатам необходимо обновится до блока 640000:
https://github.com/dacsunlimited/bitsharesx/releases

Offline testz

testz
Подскажи как вернуть обратно английский язык, пожалуйста.

В этой версии выбора языка еще нет, поэтому перед запуском поменяйте региональные настройки на английские (это там где изменения формата времени и т.д.) запустите BitSharesX и верните настройки назад.
Надеюсь, в следующей версии уже будет выбор в меню.

Сделали, в новой версии можно будет переключить web интерфейс на другой язык: https://github.com/BitShares/web_wallet/commit/1bacb8ff23d456f8f4493a6a976ee31a31d55321

Offline testz

testz
Подскажи как вернуть обратно английский язык, пожалуйста.

В этой версии выбора языка еще нет, поэтому перед запуском поменяйте региональные настройки на английские (это там где изменения формата времени и т.д.) запустите BitSharesX и верните настройки назад.
Надеюсь, в следующей версии уже будет выбор в меню.

Offline Strip

  • Full Member
  • ***
  • Posts: 63
    • View Profile
testz
Подскажи как вернуть обратно английский язык, пожалуйста.
BTS: strip

Offline testz

Вышла новая версия BitSharesX 0.4.18, всем клиентам и делегатам необходимо обновится до блока 613200 (приблизительно понедельник 29.09.2014 17:00 UTC):
https://github.com/dacsunlimited/bitsharesx/releases

Offline testz

Вышла новая версия BitSharesX 0.4.17, всем клиентам и делегатам необходимо обновится до блока 578900:
https://github.com/dacsunlimited/bitsharesx/releases

Offline abrakadabra

  • Full Member
  • ***
  • Posts: 72
    • View Profile
в убунте нужно доустановить
apt-get install qttools5-dev qttools5-dev-tools
иначе не соберется

Offline testz

Вышла новая версия BitSharesX 0.4.16, всем клиентам и делегатам необходимо обновится до блока 554800. Рекомендуется перед обновлением отменить все открытые ордера на шорт, или они будут автоматически отменены на блоке 554800:
https://github.com/dacsunlimited/bitsharesx/releases

Offline testz

Вышла новая версия BitSharesX 0.4.15, всем клиентам и делегатам необходимо обновится до блока 494000:
https://github.com/dacsunlimited/bitsharesx/releases

Блок 494000 будет в понедельник 15 сентября.
С 32-х битовой версией (BitSharesX-v0.4.15-x86.exe) есть проблемы (требует debug версий C++ runtime) поэтому подождите пока исправят или используйте 64-х битовую версию.
« Last Edit: September 14, 2014, 06:58:15 pm by testz »

Offline testz

Вышла новая версия BitSharesX 0.4.13, всем клиентам и делегатам необходимо обновится до блока 451500:
https://github.com/dacsunlimited/bitsharesx/releases

Блок 451500 будет примерно 10.09.2014 19:00 GMT (3PM EST)
« Last Edit: September 10, 2014, 06:58:31 am by testz »

Offline abrakadabra

  • Full Member
  • ***
  • Posts: 72
    • View Profile
спасибо. собрал по этому мануалу, отлично работает.

Offline testz

ubuntu 14.04
bitsharesx-0.4.12

BitSharesX: /build/buildd/bitsharesx-0.4.12/libraries/fc/include/fc/optional.hpp:197: T* fc::optional<T>::operator->() [with T = bts::blockchain::market_order]: Проверочное утверждение «_valid» не выполнено.
Аварийный останов (сделан дамп памяти)

Тут хорошее руководство по компиляции под Ubuntu:
https://bitsharestalk.org/index.php?topic=6008.msg80548#msg80548

Offline testz

ubuntu 14.04
bitsharesx-0.4.12

BitSharesX: /build/buildd/bitsharesx-0.4.12/libraries/fc/include/fc/optional.hpp:197: T* fc::optional<T>::operator->() [with T = bts::blockchain::market_order]: Проверочное утверждение «_valid» не выполнено.
Аварийный останов (сделан дамп памяти)

Убедитесь, что перед компиляцией вы выполнили команды для обновления всех sub-модулей, скорее всего проблема из-за того что у Вас старый fc:
Code: [Select]
git submodule init
git submodule update

Offline abrakadabra

  • Full Member
  • ***
  • Posts: 72
    • View Profile
ubuntu 14.04
bitsharesx-0.4.12

BitSharesX: /build/buildd/bitsharesx-0.4.12/libraries/fc/include/fc/optional.hpp:197: T* fc::optional<T>::operator->() [with T = bts::blockchain::market_order]: Проверочное утверждение «_valid» не выполнено.
Аварийный останов (сделан дамп памяти)