Author [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Bitshares Not Connected  (Read 476 times)

Offline chsln

  • Jr. Member
  • **
  • Posts: 43
    • View Profile
Bitshares Not Connected
« on: November 11, 2014, 10:48:53 PM »

Hi,

I'm running bitshares on Ubuntu 14.04, compiled from source and I keep getting a "not connected" message in the bottom right corner.

this is my get_info output:

>> getinfo

{
  "blockchain_head_block_num": 984971,
  "blockchain_head_block_age": "4 seconds old",
  "blockchain_head_block_timestamp": "2014-11-11T22:27:40",
  "blockchain_average_delegate_participation": "100.00 %",
  "blockchain_confirmation_requirement": 1,
  "blockchain_share_supply": "2,498,891,432.39478 BTS",
  "blockchain_blocks_left_in_round": 82,
  "blockchain_next_round_time": "at least 14 minutes in the future",
  "blockchain_next_round_timestamp": "2014-11-11T22:41:20",
  "blockchain_random_seed": "1196cb550df3389ca3bea3459e3f6b73e53b60ef",
  "client_data_dir": "/home/lo/.BitShares",
  "client_version": "v0.4.24",
  "network_num_connections": 14,
  "network_num_connections_max": 200,
  "network_chain_downloader_running": false,
  "network_chain_downloader_blocks_remaining": null,
  "ntp_time": "2014-11-11T22:27:44",
  "ntp_time_error": 0,
  55613800000000002,
  "wallet_open": true,
  "wallet_unlocked": true,
  "wallet_unlocked_until": "29 minutes in the future",
  "wallet_unlocked_until_timestamp": "2014-11-11T22:56:46",
  "wallet_last_scanned_block_timestamp": "2014-11-11T22:27:40",
  "wallet_scan_progress": "100.00 %",
  "wallet_block_production_enabled": false,
  "wallet_next_block_production_time": null,
  "wallet_next_block_production_timestamp": null
}

I also get many errors in the message box saying: JSON Parse error: Property name must be a string literal


I tried to follow the troubleshooting but no success.

How could I fix this?

Thanks
« Last Edit: November 11, 2014, 10:50:34 PM by chsln »
Delegate: bitfeeds.chsln

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 11962
  • ChainSquad GmbH
    • View Profile
    • ChainSquad GmbH
  • BTS: xeroc
  • GitHub: xeroc
Re: Bitshares Not Connected
« Reply #1 on: November 12, 2014, 07:38:24 AM »
I'm running bitshares on Ubuntu 14.04, compiled from source and I keep getting a "not connected" message in the bottom right corner.
It's a display bug

Quote
>> getinfo
{
  "blockchain_head_block_num": 984971,
  "blockchain_head_block_age": "4 seconds old",

  "blockchain_head_block_timestamp": "2014-11-11T22:27:40",
  "blockchain_average_delegate_participation": "100.00 %",
  "blockchain_confirmation_requirement": 1,
  "blockchain_share_supply": "2,498,891,432.39478 BTS",
  "blockchain_blocks_left_in_round": 82,
  "blockchain_next_round_time": "at least 14 minutes in the future",
  "blockchain_next_round_timestamp": "2014-11-11T22:41:20",
  "blockchain_random_seed": "1196cb550df3389ca3bea3459e3f6b73e53b60ef",
  "client_data_dir": "/home/lo/.BitShares",
  "client_version": "v0.4.24",
  "network_num_connections": 14,

  "network_num_connections_max": 200,
  "network_chain_downloader_running": false,
  "network_chain_downloader_blocks_remaining": null,
  "ntp_time": "2014-11-11T22:27:44",
  "ntp_time_error": 0,
  55613800000000002,
  "wallet_open": true,
  "wallet_unlocked": true,
  "wallet_unlocked_until": "29 minutes in the future",
  "wallet_unlocked_until_timestamp": "2014-11-11T22:56:46",
  "wallet_last_scanned_block_timestamp": "2014-11-11T22:27:40",
  "wallet_scan_progress": "100.00 %",
  "wallet_block_production_enabled": false,
  "wallet_next_block_production_time": null,
  "wallet_next_block_production_timestamp": null
}
Looks perfectly fine to me

Quote
I also get many errors in the message box saying: JSON Parse error: Property name must be a string literal

I tried to follow the troubleshooting but no success.

How could I fix this?

Thanks
Are you compiling on your own? What OS? did you try the most recent version 0.4.24?
Give BitShares a try! Use the http://testnet.bitshares.eu provided by http://bitshares.eu powered by ChainSquad GmbH

Offline chsln

  • Jr. Member
  • **
  • Posts: 43
    • View Profile
Re: Bitshares Not Connected
« Reply #2 on: November 13, 2014, 12:15:14 AM »
Yes, I'm compiling on my own. Version 0.4.24. But I also tried the one from the ppa posted in the forum with the same outcome.
I'm compiling on Xubuntu 14.04 amd64.

In fact I can see the transactions I'm doing but I can't see market status (error is "Cannot get market status. Probably no orders have been placed.") or place any order (error is "invalid price (20009)").

I have tried from the windows client and I can do everything no problem... But I'd prefer to use my linux machine for this purpose.

Delegate: bitfeeds.chsln

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 11962
  • ChainSquad GmbH
    • View Profile
    • ChainSquad GmbH
  • BTS: xeroc
  • GitHub: xeroc
Re: Bitshares Not Connected
« Reply #3 on: November 13, 2014, 07:42:12 AM »
Yes, I'm compiling on my own. Version 0.4.24. But I also tried the one from the ppa posted in the forum with the same outcome.
I'm compiling on Xubuntu 14.04 amd64.

In fact I can see the transactions I'm doing but I can't see market status (error is "Cannot get market status. Probably no orders have been placed.") or place any order (error is "invalid price (20009)").

I have tried from the windows client and I can do everything no problem... But I'd prefer to use my linux machine for this purpose.
Those messages shouldn't appear ..
To me it seems you did compile the CORE correctly but something went wrong (re)compiling the GUI

Here's a tutorial to compile the GUI:
http://wiki.bitshares.org/index.php/Developer/Build#Configuration_and_Compilation_.28GUI.29

Please double check for any errors during compilation

you may also try "make forcebuildweb" instead of "make buildweb"

Good luck
Give BitShares a try! Use the http://testnet.bitshares.eu provided by http://bitshares.eu powered by ChainSquad GmbH

Offline chsln

  • Jr. Member
  • **
  • Posts: 43
    • View Profile
Re: Bitshares Not Connected
« Reply #4 on: November 13, 2014, 07:25:25 PM »
I've tried again following the instructions on the wiki but I still have the same errors  :(

Shall I look into some log files?
Delegate: bitfeeds.chsln

Offline maqifrnswa

  • Hero Member
  • *****
  • Posts: 661
    • View Profile
Re: Bitshares Not Connected
« Reply #5 on: November 13, 2014, 09:41:43 PM »
are you on ubuntu 14.10? There might be something there that we aren't seeing on 14.04.

nevermind, I see that you are on 14.04 too, I'm kind of stumped. I'll try to break my version, but so far it's been ok
« Last Edit: November 13, 2014, 09:43:15 PM by maqifrnswa »
maintains an Ubuntu PPA: https://launchpad.net/~showard314/+archive/ubuntu/bitshares [15% delegate] wallet_account_set_approval maqifrnswa true [50% delegate] wallet_account_set_approval delegate1.maqifrnswa true

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 11962
  • ChainSquad GmbH
    • View Profile
    • ChainSquad GmbH
  • BTS: xeroc
  • GitHub: xeroc
Re: Bitshares Not Connected
« Reply #6 on: November 14, 2014, 07:48:35 AM »
I've tried again following the instructions on the wiki but I still have the same errors  :(

Shall I look into some log files?
you have also run "lineman" when updating?

for me this seems to be an inconsistency between the GUI and the CORE ... CORE seems to be all fine ..
Give BitShares a try! Use the http://testnet.bitshares.eu provided by http://bitshares.eu powered by ChainSquad GmbH

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 11962
  • ChainSquad GmbH
    • View Profile
    • ChainSquad GmbH
  • BTS: xeroc
  • GitHub: xeroc
Give BitShares a try! Use the http://testnet.bitshares.eu provided by http://bitshares.eu powered by ChainSquad GmbH

Offline chsln

  • Jr. Member
  • **
  • Posts: 43
    • View Profile
Re: Bitshares Not Connected
« Reply #8 on: November 14, 2014, 12:48:02 PM »
yest i have run lineman as well. I did it from scratches too just to see if i was missing something.
Delegate: bitfeeds.chsln

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 11962
  • ChainSquad GmbH
    • View Profile
    • ChainSquad GmbH
  • BTS: xeroc
  • GitHub: xeroc
Re: Bitshares Not Connected
« Reply #9 on: November 14, 2014, 01:10:30 PM »
To me it seems the GUI (more precisely, the web_wallet) was not compiled properly

It was confirmed by 'nathanhourt' at issue #67 to be related to web_wallet component.
https://github.com/BitShares/qt_wallet/issues/67

The bug was redirected to web_wallet repository as issue #420
https://github.com/BitShares/web_wallet/issues/420

Coder 'valzav' closed it as difficult to replicate. I have just replicated the bug in three simple steps:
- installed fresh Ubuntu 14.10 into VirtualBox
- added the ppa and installed bitshares
- run Bitshares
After unlocking the wallet issue 'JSON parsing errors' and issue 'Not connected' showed themselves right away.
Give BitShares a try! Use the http://testnet.bitshares.eu provided by http://bitshares.eu powered by ChainSquad GmbH

 

Google+