Author [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: --> All Delegates: Please upgrade to 0.4.27.1 ASAP <--  (Read 1373 times)

0 Members and 1 Guest are viewing this topic.

Offline dannotestein

--> All Delegates: Please upgrade to 0.4.27.1 ASAP <--
« on: December 17, 2014, 08:21:26 AM »

Update, use client below for best results:
https://github.com/BitShares/bitshares/releases/tag/v0.4.27.1

Some  (but not all) 4.26 delegates appear to be going off on a minority fork, so please upgrade to 0.4.27 as soon as you're able (especially if you're not on the majority fork).

Also, if you're on the wrong fork, you will probably need to delete your local copy of blockchain and resync.
Also, as per msgs further down in this thread, if you fail to get on correct fork, you can force it using this method from testz:

If as delegate you have a problem to sync to right chain, you should move to 0.4.27.1 and add following lines to checkpoints.json at data directory:
Quote

      ],[
        1279500,
        "488313d2c1c85bdec117bac0379f7b17f7cfbed3"
      ],[
        1283300,
        "cef871ef96c687b4841b02a7643c2a90d6c46bd1"
      ],[
        1283590,
        "d5265058f7be7d5cf1b496bbaa9b9deaf8cfbe00"
      ]


I mark as bold the lines which present in original file.
After this you should re-index the database.
« Last Edit: December 17, 2014, 07:11:47 PM by dannotestein »
http://blocktrades.us Fast/Safe/High-Liquidity Crypto Coin Converter

Offline liondani

Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #1 on: December 17, 2014, 08:37:04 AM »
on the way !!!
  https://bitshares.OPENLEDGER.info/?r=GREECE  | You are in Control | BUY | SELL | SHORT | SWAP | LOAN | TRADE |  

Offline Harvey

  • Sr. Member
  • ****
  • Posts: 241
    • View Profile
Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #2 on: December 17, 2014, 08:47:44 AM »
upgraded to 0.4.27
BTS       Witness:harvey-xts Seed:128.199.143.47:2015 API:wss://128.199.143.47:2016 
MUSE   Witness:harvey-xts Seed:128.199.143.47:2017 API:ws://128.199.143.47:2018

Offline liondani

Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #3 on: December 17, 2014, 09:14:50 AM »
my seed node 185.25.22.21:1776 is on the right fork....

(wallet closed) >>> info
{
  "blockchain_head_block_num": 1283659,
  "blockchain_head_block_age": "6 seconds old",
  "blockchain_head_block_timestamp": "2014-12-17T09:13:30",
  "blockchain_average_delegate_participation": "65.58 %",
  "blockchain_confirmation_requirement": 76,
  "blockchain_share_supply": "2,498,424,447.19030 BTS",
  "blockchain_blocks_left_in_round": 51,
  "blockchain_next_round_time": "at least 8 minutes in the future",
  "blockchain_next_round_timestamp": "2014-12-17T09:22:00",
  "blockchain_random_seed": "03d4d1e27e7d8027c9182138b552da4ccbe733a4",
  "client_data_dir": "/root/.BitShares",
  "client_version": "v0.4.26",
  "network_num_connections": 78,
  "network_num_connections_max": 200,
  https://bitshares.OPENLEDGER.info/?r=GREECE  | You are in Control | BUY | SELL | SHORT | SWAP | LOAN | TRADE |  

Offline monsterer

Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #4 on: December 17, 2014, 09:20:43 AM »
Some  (but not all) 4.26 delegates appear to be going off on a minority fork, so please upgrade to 0.4.27 as soon as you're able (especially if you're not on the majority fork).

Also, if you're on the wrong fork, you will probably need to delete your local copy of blockchain and resync.

Are you part of the official dev team?
My opinions do not represent those of metaexchange unless explicitly stated.
https://metaexchange.info | Bitcoin<->Altcoin exchange | Instant | Safe | Low spreads

Offline liondani

Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #5 on: December 17, 2014, 09:24:59 AM »
just to keep this thread on the first places ...

(wallet closed) >>> info
{
  "blockchain_head_block_num": 1283702,
  "blockchain_head_block_age": "28 seconds old",
  "blockchain_head_block_timestamp": "2014-12-17T09:23:50",
  "blockchain_average_delegate_participation": "64.74 %",
  "blockchain_confirmation_requirement": 71,
  "blockchain_share_supply": "2,498,424,750.89030 BTS",
  "blockchain_blocks_left_in_round": 8,
  "blockchain_next_round_time": "at least 72 seconds in the future",
  "blockchain_next_round_timestamp": "2014-12-17T09:25:30",
  "blockchain_random_seed": "0d395d1024ac74ebe6a3725cacc0dfb358b02dfc",
  "client_data_dir": "/root/.BitShares",
  "client_version": "v0.4.26",
  "network_num_connections": 77,
  "network_num_connections_max": 200,
  https://bitshares.OPENLEDGER.info/?r=GREECE  | You are in Control | BUY | SELL | SHORT | SWAP | LOAN | TRADE |  

Offline liondani

Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #6 on: December 17, 2014, 09:25:45 AM »
Some  (but not all) 4.26 delegates appear to be going off on a minority fork, so please upgrade to 0.4.27 as soon as you're able (especially if you're not on the majority fork).

Also, if you're on the wrong fork, you will probably need to delete your local copy of blockchain and resync.

Are you part of the official dev team?

yes he is.

http://bitshares.org/team/
  https://bitshares.OPENLEDGER.info/?r=GREECE  | You are in Control | BUY | SELL | SHORT | SWAP | LOAN | TRADE |  

Offline testz

Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #7 on: December 17, 2014, 09:46:51 AM »
If as delegate you has a problems to sync to right chain, you should move to 0.4.27 and add following lines to checkpoints.json at data directory:
Quote
  ],[
    1279500,
    "488313d2c1c85bdec117bac0379f7b17f7cfbed3"
  ],[
    1283300,
    "cef871ef96c687b4841b02a7643c2a90d6c46bd1"
  ],[
    1283590,
    "d5265058f7be7d5cf1b496bbaa9b9deaf8cfbe00"
  ]

I mark as bold the lines which present in original file.
After this you should re-index the database.
« Last Edit: December 17, 2014, 09:47:45 AM by dannotestein »

Offline dannotestein

Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #8 on: December 17, 2014, 09:49:15 AM »
If as delegate you has a problems to sync to right chain, you should move to 0.4.27 and add following lines to checkpoints.json at data directory:
Quote
  ],[
    1279500,
    "488313d2c1c85bdec117bac0379f7b17f7cfbed3"
  ],[
    1283300,
    "cef871ef96c687b4841b02a7643c2a90d6c46bd1"
  ],[
    1283590,
    "d5265058f7be7d5cf1b496bbaa9b9deaf8cfbe00"
  ]

I mark as bold the lines which present in original file.
After this you should re-index the database.
good idea, testz, that will make sure the client moves to the proper fork.
http://blocktrades.us Fast/Safe/High-Liquidity Crypto Coin Converter

Offline monsterer

Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #9 on: December 17, 2014, 09:56:23 AM »
If as delegate you has a problems to sync to right chain, you should move to 0.4.27 and add following lines to checkpoints.json at data directory:

I have no file called checkpoints.json
My opinions do not represent those of metaexchange unless explicitly stated.
https://metaexchange.info | Bitcoin<->Altcoin exchange | Instant | Safe | Low spreads

Offline monsterer

Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #10 on: December 17, 2014, 10:00:24 AM »
If as delegate you has a problems to sync to right chain, you should move to 0.4.27 and add following lines to checkpoints.json at data directory:

I have no file called checkpoints.json

Oh, it gets created when you run the client... which means you are forced to re-index once and then again if it doesn't work.
My opinions do not represent those of metaexchange unless explicitly stated.
https://metaexchange.info | Bitcoin<->Altcoin exchange | Instant | Safe | Low spreads

Offline testz

Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #11 on: December 17, 2014, 10:07:53 AM »
If as delegate you has a problems to sync to right chain, you should move to 0.4.27 and add following lines to checkpoints.json at data directory:

I have no file called checkpoints.json

Oh, it gets created when you run the client... which means you are forced to re-index once and then again if it doesn't work.

Yes, first time my 0.4.27 goes to wrong chain then I modify checkpoint.json and re-index.

Offline monsterer

Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #12 on: December 17, 2014, 10:26:50 AM »
If as delegate you has a problems to sync to right chain, you should move to 0.4.27 and add following lines to checkpoints.json at data directory:

I have no file called checkpoints.json

Oh, it gets created when you run the client... which means you are forced to re-index once and then again if it doesn't work.

Yes, first time my 0.4.27 goes to wrong chain then I modify checkpoint.json and re-index.

Code: [Select]
./bitshares_client --rebuild-index
My opinions do not represent those of metaexchange unless explicitly stated.
https://metaexchange.info | Bitcoin<->Altcoin exchange | Instant | Safe | Low spreads

Offline emski

  • Hero Member
  • *****
  • Posts: 1283
    • View Profile
    • http://lnkd.in/nPbhxG
Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #13 on: December 17, 2014, 11:45:28 AM »
Here is the output of my delegate after update to 0.4.27 and --resync-blockchain (and I've deleted everything in data-dir except wallet):

Code: [Select]
I am disconnecting peer 84.238.140.192:42577 for reason: You offered us a block that we reject as invalid
(wallet closed) >>> info
{
  "blockchain_head_block_num": 1283490,
  "blockchain_head_block_age": "2 minutes old",
  "blockchain_head_block_timestamp": "2014-12-17T11:40:40",
  "blockchain_average_delegate_participation": "17.18 %",
  "blockchain_confirmation_requirement": 303,
  "blockchain_share_supply": "2,498,424,296.59030 BTS",
  "blockchain_blocks_left_in_round": 18,
  "blockchain_next_round_time": "at least 3 minutes in the future",
  "blockchain_next_round_timestamp": "2014-12-17T11:45:50",
  "blockchain_random_seed": "9fd5828f7cc87cbf48c62745c4a6181510072306",
  "client_data_dir": "/home/emski/bitsharesAltDelegate/bitshares/programs/client/dd",
  "client_version": "v0.4.27",
  "network_num_connections": 9,
  "network_num_connections_max": 200,
  "network_chain_downloader_running": false,
  "network_chain_downloader_blocks_remaining": null,
  "ntp_time": "2014-12-17T11:42:50",
  "ntp_time_error": 0.0055840000000000004,
  "wallet_open": false,
  "wallet_unlocked": null,
  "wallet_unlocked_until": null,
  "wallet_unlocked_until_timestamp": null,
  "wallet_last_scanned_block_timestamp": null,
  "wallet_scan_progress": null,
  "wallet_block_production_enabled": null,
  "wallet_next_block_production_time": null,
  "wallet_next_block_production_timestamp": null
}


[13:43:35] Emil Velichkov: this is with the checkpoints
[13:43:50] Emil Velichkov: note that 84.238.140.192:42577 is the seed node which is on the right chain
[13:44:18] Emil Velichkov: so checkpoints and --resync-blockchain does NOT work

Offline emski

  • Hero Member
  • *****
  • Posts: 1283
    • View Profile
    • http://lnkd.in/nPbhxG
Re: --> All Delegates: Please upgrade to 0.4.27 ASAP <--
« Reply #14 on: December 17, 2014, 11:56:31 AM »
1283481 2014-12-17T11:33:40 backbone.riverhead              0       166     544     0.002572         d310b14962c87e4a97600e6f6b6d0d72e6039cad
you are signing the wrong chain
[13:49:25] Emil Velichkov: crazibyt, chinesecommunity, bm.payroll.riverhead, rose.ebit, titan.crazybit
[13:49:59] Emil Velichkov: including x.ebit
[13:50:00] Emil Velichkov: fox
[13:50:15] Emil Velichkov: *.helloworld
[13:50:23] Emil Velichkov: del0.cass
[13:50:29] Emil Velichkov: marketing.methodx
[13:50:59] Emil Velichkov: riverhead-del-server-1
[13:51:30] Emil Velichkov: anchor.crazybit
[13:52:00] Emil Velichkov: dc-delegate
[13:52:20] Emil Velichkov: there are still seed nodes on the forked chain and some delegates actively producing blocks there
[13:53:04] Emil Velichkov: if someone can reach out the the above-mentioned delegates that would be cool

 

Google+