Author [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Как установить клиент на Debian?  (Read 712 times)

0 Members and 1 Guest are viewing this topic.

Offline MayDay

  • Jr. Member
  • **
  • Posts: 27
    • View Profile
  • Witness: MayDay
  • Payrate: 3%
Как установить клиент на Debian?
« on: February 08, 2015, 08:31:50 AM »

Как установить клиент на Debian не собирая из исходников?

Offline fundomatic

  • Full Member
  • ***
  • Posts: 149
    • View Profile
Re: Как установить клиент на Debian?
« Reply #1 on: February 08, 2015, 08:56:38 AM »
Как установить клиент на Debian не собирая из исходников?

https://github.com/BitShares/bitshares/releases

Download bitsharesGUI-0.6.0-linux-x86_64.tar.gz

tar xzvf bitsharesGUI-0.6.0-linux-x86_64.tar.gz\

cd bitsharesGUI-0.6.0-linux-x86_64

start the client

./bitshares_client



GUI (BitShares) отсутсвует в этой версии.

Offline MayDay

  • Jr. Member
  • **
  • Posts: 27
    • View Profile
  • Witness: MayDay
  • Payrate: 3%
Re: Как установить клиент на Debian?
« Reply #2 on: February 08, 2015, 09:21:59 AM »
Code: [Select]
[email protected]:~/bitsharesGUI-0.6.0-linux-x86_64$ ./bitshares_client
./bitshares_client: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./bitshares_client)
Я что то ни так сделал?

Offline fundomatic

  • Full Member
  • ***
  • Posts: 149
    • View Profile
Re: Как установить клиент на Debian?
« Reply #3 on: February 08, 2015, 10:14:00 AM »
Нужно установить "libc6",
детали:
Code: [Select]
[email protected]:$ apt-cache search libc6
debian-policy - Debian Policy Manual and related documents
libc6 - Embedded GNU C Library: Shared libraries
libc6-amd64 - Embedded GNU C Library: 64bit Shared libraries for AMD64
libc6-dbg - Embedded GNU C Library: detached debugging symbols
libc6-dev - Embedded GNU C Library: Development Libraries and Header Files
libc6-dev-amd64 - Embedded GNU C Library: 64bit Development Libraries for AMD64
libc6-i686 - Embedded GNU C Library: Shared libraries [i686 optimized]
libc6-pic - Embedded GNU C Library: PIC archive library
libc6-prof - Embedded GNU C Library: Profiling Libraries
libc6-xen - Embedded GNU C Library: Shared libraries [Xen version]
libcompfaceg1 - Compress/decompress images for mailheaders, libc6 runtime
libcompfaceg1-dev - Compress/decompress images for mailheaders, libc6 devel
libtext-iconv-perl - converts between character sets in Perl
manpages-ja-dev - Japanese version of the manual pages (for developers)
manpages-pt-dev - Portuguese Versions of the Manual Pages (dev sections)

должно быть достаточно:

Code: [Select]
$ sudo apt-get install libc6

Offline MayDay

  • Jr. Member
  • **
  • Posts: 27
    • View Profile
  • Witness: MayDay
  • Payrate: 3%
Re: Как установить клиент на Debian?
« Reply #4 on: February 08, 2015, 10:31:31 AM »
Опять что то ни так :(
Code: [Select]
[email protected]://home/aleksandr/bitsharesGUI-0.6.0-linux-x86_64# apt-cache search libc6
debian-policy - Debian Policy Manual and related documents
libc6-dbg - Embedded GNU C Library: detached debugging symbols
libc6-dev-i386 - Embedded GNU C Library: 32-bit development libraries for AMD64
libc6-i386 - Embedded GNU C Library: 32-bit shared libraries for AMD64
libc6-pic - Embedded GNU C Library: PIC archive library
libc6-prof - Embedded GNU C Library: Profiling Libraries
libcompfaceg1 - Compress/decompress images for mailheaders, libc6 runtime
libcompfaceg1-dev - Compress/decompress images for mailheaders, libc6 devel
manpages-ja-dev - Japanese version of the manual pages (for developers)
manpages-pt-dev - Portuguese Versions of the Manual Pages (dev sections)
libc6 - библиотека Embedded GNU C (динамические библиотеки)
libc6-dev - архивы для сборки и заголовочные файлы к библиотеке Embedded GNU C
libtext-iconv-perl - библиотека для преобразования кодировок символов в Perl
[email protected]://home/aleksandr/bitsharesGUI-0.6.0-linux-x86_64#
Code: [Select]
[email protected]://home/aleksandr/bitsharesGUI-0.6.0-linux-x86_64# apt-get install libc6
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлена самая новая версия libc6.
Следующие пакеты устанавливались автоматически и больше не требуются:
  accountsservice apg argyll at-spi2-core baobab browser-plugin-gnash cdrdao cups-pk-helper dconf-tools
  empathy-common espeak-data file-roller finger fonts-cantarell fonts-sil-gentium fonts-sil-gentium-basic gcalctool
  gdebi gdm3 gedit gedit-common gedit-plugins gir1.2-atspi-2.0 gir1.2-gdata-0.0 gir1.2-gnomekeyring-1.0
  gir1.2-goa-1.0 gir1.2-gtop-2.0 gir1.2-gucharmap-2.90 gir1.2-javascriptcoregtk-3.0 gir1.2-rb-3.0
  gir1.2-tracker-0.14 gir1.2-webkit-3.0 gir1.2-wnck-3.0 gnash gnash-common gnome-backgrounds gnome-color-manager
  gnome-control-center-data gnome-disk-utility gnome-documents gnome-font-viewer gnome-icon-theme-extras gnome-mag
  gnome-nettool gnome-online-accounts gnome-packagekit gnome-packagekit-data gnome-screenshot
  gnome-shell-extensions gnome-system-log gnome-tweak-tool gnome-video-effects grilo-plugins-0.1 gucharmap
  guile-2.0-libs hamster-applet hyphen-en-us inkscape iputils-tracepath libao-common libao4 libatk-adaptor
  libatk-adaptor-data libatk-bridge2.0-0 libatspi1.0-0 libatspi2.0-0 libaudio2 libavahi-gobject0 libavahi-ui-gtk3-0
  libblas3gf libbrlapi0.5 libburn4 libcaribou-gtk-module libcaribou-gtk3-module libcolamd2.7.1 libcolorblind0
  libdee-1.0-4 libdiscid0 libdmapsharing-3.0-2 libdotconf1.0 libespeak1 libgail-common libgdu-gtk0 libgeocode-glib0
  libgexiv2-1 libgnome-mag2 libgpod-common libgpod4 libgrilo-0.1-0 libgtk-vnc-2.0-0 libgtkmm-2.4-1c2a
  libgupnp-av-1.0-2 libgupnp-dlna-1.0-2 libgvnc-1.0-0 libicc2 libimdi0 libisofs6 libjte1 liblinear-tools liblinear1
  liblouis-data liblouis2 libmagick++5 libminiupnpc5 libmtp-common libmtp-runtime libmtp9 libnatpmp1
  libnm-glib-vpn1 libnm-gtk-common libnm-gtk0 libplot2c2 libpstoedit0c2a libraw5 libreoffice libreoffice-calc
  libreoffice-draw libreoffice-evolution libreoffice-filter-mobiledev libreoffice-gnome libreoffice-gtk
  libreoffice-help-en-us libreoffice-impress libreoffice-report-builder-bin librest-extras-0.7-0 librhythmbox-core6
  libsocialweb-client2 libsocialweb-common libsocialweb-service libsocialweb0 libsofia-sip-ua-glib3
  libsofia-sip-ua0 libsonic0 libsvm-tools libtelepathy-farstream2 libunique-3.0-0 libvisio-0.0-0 libwnck-common
  libwnck22 lp-solve media-player-info minissdpd mobile-broadband-provider-info mousetweaks mythes-en-us
  network-manager-gnome nmap p7zip-full perlmagick pstoedit python-brlapi python-gconf python-gnome2 python-louis
  python-mako python-markupsafe python-notify python-pyatspi python-pyatspi2 python-pyorbit python-speechd
  python-wnck python-zeitgeist rdesktop rhythmbox rhythmbox-data rhythmbox-plugins rygel rygel-playbin
  rygel-preferences rygel-tracker seahorse shotwell shotwell-common simple-scan sound-theme-freedesktop
  speech-dispatcher telepathy-gabble telepathy-idle telepathy-logger telepathy-rakia telepathy-salut
  transmission-common transmission-gtk ttf-liberation ttf-sil-gentium-basic unoconv vinagre vino xbrlapi
  xdg-user-dirs-gtk zeitgeist-core
Для их удаления используйте «apt-get autoremove».
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
[email protected]://home/aleksandr/bitsharesGUI-0.6.0-linux-x86_64#

Code: [Select]
[email protected]://home/aleksandr/bitsharesGUI-0.6.0-linux-x86_64# ./bitshares_client
./bitshares_client: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./bitshares_client)
[email protected]://home/aleksandr/bitsharesGUI-0.6.0-linux-x86_64#

Offline fundomatic

  • Full Member
  • ***
  • Posts: 149
    • View Profile
Re: Как установить клиент на Debian?
« Reply #5 on: February 08, 2015, 10:49:45 AM »
В debian wheezy 'libc6' (2.13-38+deb7u6) устарел для 'bitshares_client' 

Code: [Select]

$ lsb_release -a

No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 7.7 (wheezy)
Release: 7.7
Codename: wheezy

$ apt-cache policy libc6
libc6:
  Installed: 2.13-38+deb7u6
  Candidate: 2.13-38+deb7u6
  ...

для сравнения:

Code: [Select]
$ lsb_release -a

No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 8.0 (jessie)
Release: 8.0
Codename: jessie

$ apt-cache policy libc6
libc6:
  Installed: 2.19-13
  Candidate: 2.19-13

Какой debian установлен?
Что след. соманды выдают?

Code: [Select]
lsb_release -a

Code: [Select]
apt-cache policy libc6

Offline fundomatic

  • Full Member
  • ***
  • Posts: 149
    • View Profile
Re: Как установить клиент на Debian?
« Reply #6 on: February 08, 2015, 11:07:53 AM »
Для debian wheezy можно попробовать:

добавить след. в файл /etc/apt/sources.list
Code: [Select]
# Testing repository - main, contrib and non-free branches
deb http://http.us.debian.org/debian testing main non-free contrib
deb-src http://http.us.debian.org/debian testing main non-free contrib

затем:

Code: [Select]
sudo apt-get update
sudo apt-get install libc6-dev=2.17-7

Edit:
больше здесь:
http://unix.stackexchange.com/questions/85505/need-to-install-glibc-2-14-on-wheezy
http://forums.debian.net/viewtopic.php?f=17&t=118262
« Last Edit: February 08, 2015, 11:35:52 AM by fundomatic »

Offline MayDay

  • Jr. Member
  • **
  • Posts: 27
    • View Profile
  • Witness: MayDay
  • Payrate: 3%
Re: Как установить клиент на Debian?
« Reply #7 on: February 08, 2015, 11:41:58 AM »
Вообщем установил с тестового репозитария .

Code: [Select]
[email protected]:~$ cd /home/aleksandr/bitsharesGUI-0.6.0-linux-x86_64
[email protected]:~/bitsharesGUI-0.6.0-linux-x86_64$ ./bitshares_client
Creating new data directory /home/aleksandr/.BitShares
Setting UNIX permissions on new data directory to 700
Loading blockchain from: /home/aleksandr/.BitShares/chain
Creating default config file at: /home/aleksandr/.BitShares/config.json
Logging to file: /home/aleksandr/.BitShares/logs/default/default.log
Logging RPC to file: /home/aleksandr/.BitShares/logs/rpc/rpc.log
Logging blockchain to file: /home/aleksandr/.BitShares/logs/blockchain/blockchain.log
Logging P2P to file: /home/aleksandr/.BitShares/logs/p2p/p2p.log
Using built-in blockchain checkpoints
Erasing all state
Initializing state from built-in genesis file
Please be patient, this will take several minutes...
Successfully replayed 0 blocks in 2 seconds.                         
Blockchain size changed from 0MiB to 0MiB.
Not starting RPC server, use --server to enable the RPC interface
--- there are now 1 active connections to the p2p network
--- there are now 2 active connections to the p2p network
--- there are now 3 active connections to the p2p network
--- there are now 4 active connections to the p2p network
--- syncing with p2p network, 1735643 blocks left to fetch
--- syncing with p2p network, our last block is 28 weeks old
(wallet closed) >>>

Где можно найти команды для управления кошельком?

Offline testz

Re: Как установить клиент на Debian?
« Reply #8 on: February 08, 2015, 11:43:14 AM »
Вообщем установил с тестового репозитария .

...

Где можно найти команды для управления кошельком?

Небольшое описание есть тут: https://github.com/BitShares/bitshares/wiki

Наберите в консоли help
А потом help <команда>

При надоре команд можете использовать Tab - консоль будет подсказывать варианты.
« Last Edit: February 08, 2015, 11:46:33 AM by testz »

Offline MayDay

  • Jr. Member
  • **
  • Posts: 27
    • View Profile
  • Witness: MayDay
  • Payrate: 3%
Re: Как установить клиент на Debian?
« Reply #9 on: February 09, 2015, 04:21:41 PM »
хотел установить c GUI, но  ещё проблема возникла . помогите разобраться.
Code: [Select]
[email protected]:~/bitsharesGUI-0.5.3-linux-x86_64$ ./BitShares
Gtk-Message: Failed to load module "canberra-gtk-module"
Listening for new instances on /tmp/BitShares
480141ms th_a       thread.cpp:95                 thread               ] name:bitshares tid:140435735934720
480155ms th_a       MainWindow.cpp:989            loadWebUpdates       ] No web update package found.
480271ms th_a       ClientWrapper.cpp:134         initialize           ] config: {
  "rpc": {
    "enable": false,
    "rpc_user": "randomuser",
    "rpc_password": "69ac7a72e10fde94b1c00a27eb4ee4b02a9ce91b026561424ed52c67049a1f73",
    "rpc_endpoint": "127.0.0.1:0",
    "httpd_endpoint": "127.0.0.1:0",
    "htdocs": "./htdocs"
  },
  "default_peers": [
    "5.101.106.138:1776",
    "5.101.106.138:1777",
    "5.101.106.138:1778",
    "46.226.109.66:1776",
    "54.77.51.177:1776",
    "54.79.27.224:1776",
    "61.129.33.213:1776",
    "84.238.140.192:42577",
    "85.214.53.224:1776",
    "95.85.33.16:8764",
    "104.131.35.149:1776",
    "106.185.26.162:1776",
    "178.62.50.61:1776",
    "178.62.50.61:1777",
    "178.62.50.61:1778",
    "178.62.50.61:1779",
    "178.62.157.161:1776",
    "180.153.142.120:1777",
    "185.25.22.21:1776",
    "188.226.195.137:60696"
  ],
  "chain_servers": [],
  "chain_server": {
    "enabled": false,
    "listen_port": 0
  },
  "mail_server_enabled": false,
  "wallet_enabled": true,
  "ignore_console": false,
  "logging": {
    "includes": [],
    "appenders": [{
        "name": "stderr",
        "type": "console",
        "args": {
          "stream": "std_error",
          "level_colors": [{
              "level": "debug",
              "color": "green"
            },{
              "level": "warn",
              "color": "brown"
            },{
              "level": "error",
              "color": "red"
            }
          ]
        },
        "enabled": true
      },{
        "name": "stdout",
        "type": "console",
        "args": {
          "stream": "std_out",
          "level_colors": [{
              "level": "debug",
              "color": "green"
            },{
              "level": "warn",
              "color": "brown"
            },{
              "level": "error",
              "color": "red"
            }
          ]
        },
        "enabled": true
      }
    ],
    "loggers": [{
        "name": "default",
        "parent": null,
        "level": "debug",
        "enabled": true,
        "additivity": false,
        "appenders": [
          "stderr"
        ]
      }
    ]
  },
  "wallet_callback_url": "",
  "client_debug_name": "",
  "growl_notify_endpoint": null,
  "growl_password": null,
  "growl_bitshares_client_identifier": null,
  "relay_fee": 0,
  10000000000000001,
  "light_relay_fee": 0,
  10000000000000001,
  "relay_account_name": "",
  "faucet_account_name": "",
  "track_statistics": true
}
480271ms th_a       ClientWrapper.cpp:137         initialize           ] Starting client with data-dir: /home/aleksandr/.BitShares
Loading config from file: /home/aleksandr/.BitShares/config.json
480278ms bitshares  ClientWrapper.cpp:206         operator()           ] Failure when attempting to initialize client
483792ms bitshares  general_api.cpp:204           stop                 ] stop...
483793ms bitshares  chain_database.cpp:1196       ~chain_database      ] unexpected exception closing database
 10 assert_exception: Assert Exception
is_open(): Database is not open!
    {}
    bitshares  level_map.hpp:343 create_batch

    {}
    bitshares  cached_level_map.hpp:52 flush

    {}
    bitshares  cached_level_map.hpp:28 close

    {}
    bitshares  chain_database.cpp:1475 close
483793ms th_a       thread.cpp:115                ~thread              ] calling quit() on bitshares
483793ms th_a       thread.cpp:160                quit                 ] destroying boost thread 140435735934720
483793ms th_a       BitSharesApp.cpp:432          run                  ] stop logging (shutting down)
[email protected]:~/bitsharesGUI-0.5.3-linux-x86_64$

Offline fundomatic

  • Full Member
  • ***
  • Posts: 149
    • View Profile
Re: Как установить клиент на Debian?
« Reply #10 on: February 09, 2015, 04:59:50 PM »

Code: [Select]
sudo apt-get install libcanberra-gtk3-module

Из вашего сообщения
Code: [Select]
    "rpc_user": "randomuser",
    "rpc_password": "69ac7a72e10fde94b1c00a27eb4ee4b02a9ce91b026561424ed52c67049a1f73",

Желательно не показывать (нужно поменять).

 

Google+