Author [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: Error compiling on raspberry pi 2 with salsa20.s.  (Read 349 times)

Offline zhangweis

  • Sr. Member
  • ****
  • Posts: 258
    • View Profile
Error compiling on raspberry pi 2 with salsa20.s.
« on: March 14, 2015, 12:04:30 AM »

I tried gcc and clang with the similiar errors like below. I guess it's because salsa20.s doesn't support arm. What is this salsa20 for and can I make it work with arm? Can we turn it into C to make it compile or is there a way to bypass this?

[ 23%] Building C object libraries/fc/CMakeFiles/fc.dir/vendor/salsa20/salsa20.s.o
clang: warning: argument unused during compilation: '-std=c99'
clang: warning: argument unused during compilation: '-D NDEBUG'
clang: warning: argument unused during compilation: '-I bitshares/libraries/fc/include'
clang: warning: argument unused during compilation: '-I bitshares/libraries/fc'
clang: warning: argument unused during compilation: '-I bitshares/libraries/fc/vendor/cyoencode-1.0.2/src'
clang: warning: argument unused during compilation: '-I bitshares/libraries/fc/vendor/boost_1.51/include'
clang: warning: argument unused during compilation: '-I bitshares/libraries/fc/vendor/salsa20'
clang: warning: argument unused during compilation: '-I bitshares/libraries/fc/vendor/easylzma/src'
clang: warning: argument unused during compilation: '-I bitshares/libraries/fc/vendor/udt4/src'
bitshares/libraries/fc/vendor/salsa20/salsa20.s:279:5: error: unexpected token in operand
mov %esp,%eax
    ^
bitshares/libraries/fc/vendor/salsa20/salsa20.s:280:9: error: unexpected token in operand
and $31,%eax
        ^
bitshares/libraries/fc/vendor/salsa20/salsa20.s:281:10: error: unexpected token in operand
add $640,%eax
         ^
bitshares/libraries/fc/vendor/salsa20/salsa20.s:282:5: error: unexpected token in operand
sub %eax,%esp
    ^
bitshares/libraries/fc/vendor/salsa20/salsa20.s:287:6: error: unexpected token in operand
movl %eax,0(%esp)
     ^
PTS:PnmqJxiiEggCYm7bQgxEyAsD8mrDbif8QY
BTC:15hCQrFMpSxcTSDVYgchajEqGF15XqW1M9
Weibo:http://weibo.com/zhangweis

Offline zhangweis

  • Sr. Member
  • ****
  • Posts: 258
    • View Profile
Re: Error compiling on raspberry pi 2 with salsa20.s.
« Reply #1 on: March 14, 2015, 02:15:14 AM »
Seems solved by commenting all the salsa related lines in libraries/fc/CMakeLists.txt

I also want to mention that I have to use export LC_ALL="en_GB.UTF-8" instead of en_US as I don't have locale en_US preinstalled on my raspbian. 
PTS:PnmqJxiiEggCYm7bQgxEyAsD8mrDbif8QY
BTC:15hCQrFMpSxcTSDVYgchajEqGF15XqW1M9
Weibo:http://weibo.com/zhangweis

Offline maqifrnswa

  • Hero Member
  • *****
  • Posts: 661
    • View Profile
Re: Error compiling on raspberry pi 2 with salsa20.s.
« Reply #2 on: June 23, 2015, 08:49:40 PM »
I'm also getting this error early on:
In file included from /home/pi/graphene/graphene/libraries/fc/vendor/secp256k1-zkp/src/secp256k1.c:11:0:
/home/pi/graphene/graphene/libraries/fc/vendor/secp256k1-zkp/src/util.h:102:37: error: ‘__int128’ is not supported for this target
 SECP256K1_GNUC_EXT typedef unsigned __int128 uint128_t;

which, according to:
http://raspberrypi.stackexchange.com/questions/3919/using-128bit-integers-in-gcc
__int128 isn't defined on raspberry pi
maintains an Ubuntu PPA: https://launchpad.net/~showard314/+archive/ubuntu/bitshares [15% delegate] wallet_account_set_approval maqifrnswa true [50% delegate] wallet_account_set_approval delegate1.maqifrnswa true

Offline maqifrnswa

  • Hero Member
  • *****
  • Posts: 661
    • View Profile
Re: Error compiling on raspberry pi 2 with salsa20.s.
« Reply #3 on: June 24, 2015, 08:02:06 PM »
Seems solved by commenting all the salsa related lines in libraries/fc/CMakeLists.txt

I also want to mention that I have to use export LC_ALL="en_GB.UTF-8" instead of en_US as I don't have locale en_US preinstalled on my raspbian.

I think you can just comment out:
Code: [Select]
#SET(SALSA_SRC vendor/salsa20/salsa20.s)and it will work. It's already checking if it is not apple, it should also check if it is not x86 or x86_64
maintains an Ubuntu PPA: https://launchpad.net/~showard314/+archive/ubuntu/bitshares [15% delegate] wallet_account_set_approval maqifrnswa true [50% delegate] wallet_account_set_approval delegate1.maqifrnswa true

Offline vikram

Re: Error compiling on raspberry pi 2 with salsa20.s.
« Reply #4 on: June 24, 2015, 11:02:51 PM »
Recently removed salsa20 from build; should be gone in upcoming versions: https://github.com/bitshares/bitshares/issues/1089#issuecomment-114653757

 

Google+