Author [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: compiling on linux -> locale issue  (Read 249 times)

Offline santaclause102

  • Hero Member
  • *****
  • Posts: 2466
    • View Profile
compiling on linux -> locale issue
« on: June 03, 2015, 10:02:48 PM »

Hi,

so I attempted to compile according to this https://github.com/BitShares/bitshares/blob/master/BUILD_UBUNTU.md on a debian 64 bit system.

There is a newly added instruction
Code: [Select]
export LC_ALL="en_US.UTF-8"Doing this produced the follwoing error for me: "warning setlocale lc_all cannot change locale (en_us.utf-8)" (I left out a few signs because that is from memory). 
I ignored it... and compiled (make).
Later in the make process I got an error that might be related to the above or not. I dont have an internet connection on the respective machine and didnt want to type it all so here is a photo I made of the error message: http://imgur.com/SGQ7FaX
Don't be confused by the blue background. The blue and the grey background are the same. The blue is marked stuff...

Whats wrong? What should I do? Can I give more information?

Thanks for your help!
« Last Edit: June 08, 2015, 07:15:49 PM by delulo »

Offline santaclause102

  • Hero Member
  • *****
  • Posts: 2466
    • View Profile
Re: compiling on linux -> locale issue
« Reply #1 on: June 08, 2015, 07:14:05 PM »
Anyone that has some input here?

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 11907
    • View Profile
    • BitShares.Europe
  • BTS: xeroc
  • GitHub: xeroc
Re: compiling on linux -> locale issue
« Reply #2 on: June 08, 2015, 07:22:27 PM »
you need to setup your locales correctly:
https://help.ubuntu.com/community/Locale

make sure to have "en_US.UTF-8" enabled and built then try again with the export command in the OP
Give BitShares a try! Use the http://testnet.bitshares.eu provided by http://bitshares.eu

Offline santaclause102

  • Hero Member
  • *****
  • Posts: 2466
    • View Profile
Re: compiling on linux -> locale issue
« Reply #3 on: June 10, 2015, 08:03:18 PM »
you need to setup your locales correctly:
https://help.ubuntu.com/community/Locale

make sure to have "en_US.UTF-8" enabled and built then try again with the export command in the OP
great, thanks xeroc! I will try when I am back home on the weekend...

Offline santaclause102

  • Hero Member
  • *****
  • Posts: 2466
    • View Profile
Re: compiling on linux -> locale issue
« Reply #4 on: June 20, 2015, 01:03:59 PM »
I have made the system default to be "en_US.UTF-8". I used this http://perlgeek.de/en/article/set-up-a-clean-utf8-environment ->Section: Locales: generation

When I do the "export LC_ALL="en_US.UTF-8" command that is suggested here  https://github.com/BitShares/bitshares/blob/master/BUILD_UBUNTU.md then I get the error: [translated from German so might not be exactly the same]: bash: Warning: setlocale: LC_ALL: Can not change locale (en_US.UTF-8): File oder folder not found.

The last time I ignored this error and then the make process didn't complete (see OP).

What can I do?

EDIT:
SOLUTION:
1) Logout - login after changing the system default.
2) If that doesnt work then:
Adding the following to /etc/environment:
LC_ALL=en_US.UTF-8
LANG=en_US.UTF-8
« Last Edit: June 20, 2015, 01:26:18 PM by delulo »

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 11907
    • View Profile
    • BitShares.Europe
  • BTS: xeroc
  • GitHub: xeroc
Re: compiling on linux -> locale issue
« Reply #5 on: June 20, 2015, 04:10:26 PM »
So its compiling now?
Give BitShares a try! Use the http://testnet.bitshares.eu provided by http://bitshares.eu

Offline santaclause102

  • Hero Member
  • *****
  • Posts: 2466
    • View Profile
Re: compiling on linux -> locale issue
« Reply #6 on: June 20, 2015, 11:10:23 PM »
Compiled :) Thanks Xeroc for your hints!
« Last Edit: June 20, 2015, 11:16:44 PM by delulo »

 

Google+