Author [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: MMC Ubuntu compile error  (Read 688 times)

0 Members and 1 Guest are viewing this topic.

Offline barwizi

  • Hero Member
  • *****
  • Posts: 764
  • Noirbits, NoirShares, NoirEx.....lol, noir anyone?
    • View Profile
    • Noirbitstalk.org
MMC Ubuntu compile error
« on: January 30, 2014, 01:20:47 PM »

I made a few modifications to add coin control to the client but it now refuses to compile i get this error:-

Code: [Select]
cd /home/barwizi/memorycoin-psforkinit/memorycoin-psforkinit; /bin/sh share/genbuild.sh /home/barwizi/memorycoin-psforkinit/memorycoin-psforkinit/build/build.h
fatal: Not a git repository (or any of the parent directories): .git
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/sendcoinsdialog.ui -o build/ui_sendcoinsdialog.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/addressbookpage.ui -o build/ui_addressbookpage.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/signverifymessagedialog.ui -o build/ui_signverifymessagedialog.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/aboutdialog.ui -o build/ui_aboutdialog.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/editaddressdialog.ui -o build/ui_editaddressdialog.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/transactiondescdialog.ui -o build/ui_transactiondescdialog.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/overviewpage.ui -o build/ui_overviewpage.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/sendcoinsentry.ui -o build/ui_sendcoinsentry.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/askpassphrasedialog.ui -o build/ui_askpassphrasedialog.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/rpcconsole.ui -o build/ui_rpcconsole.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/optionsdialog.ui -o build/ui_optionsdialog.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/votecoinsdialog.ui -o build/ui_votecoinsdialog.h
/usr/lib/x86_64-linux-gnu/qt4/bin/uic src/qt/forms/votecoinsentry.ui -o build/ui_votecoinsentry.h
g++ -c -m64 -pipe -fstack-protector-all -D_FORTIFY_SOURCE=2 -O2 -D_REENTRANT -fdiagnostics-show-option -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -Wstack-protector -DQT_GUI -DBOOST_THREAD_USE_LIB -DBOOST_SPIRIT_THREADSAFE -DSCRYPT_CHACHA -DSCRYPT_KECCAK512 -DUSE_UPNP=1 -DSTATICLIB -DUSE_IPV6=1 -DHAVE_BUILD_INFO -DLINUX -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4 -Isrc -Isrc/json -Isrc/qt -Isrc/leveldb/include -Isrc/leveldb/helpers -Ibuild -Ibuild -o build/bitcoin.o src/qt/bitcoin.cpp
In file included from src/wallet.h:13:0,
                 from src/init.h:8,
                 from src/qt/bitcoin.cpp:13:
src/main.h:616:11: error: default argument missing for parameter 2 of ‘int64 CTransaction::GetMinFee(unsigned int, unsigned int, bool, GetMinFee_mode) const’
make: *** [build/bitcoin.o] Error 1
[email protected]:~/memorycoin-psforkinit/memorycoin-psforkinit$

anyone got an idea?

https:github.com/Nameshar/memorycoin
--Bar--  PiNEJGUv4AZVZkLuF6hV4xwbYTRp5etWWJ

The magical land of crypto, no freebies people.

Offline vertoe

  • Jr. Member
  • **
  • Posts: 30
  • i'm here
    • View Profile
Re: MMC Ubuntu compile error
« Reply #1 on: January 31, 2014, 04:20:40 PM »
Change Line 614 in src/main.cpp to:

Code: [Select]
int64 CTransaction::GetMinFee(unsigned int nBlockSize, unsigned int nBytes, bool fAllowFree,
And try again. The arguments are mixed up by the looks of it.

https://github.com/Nameshar/memorycoin/blob/master/src/main.cpp#L614

Offline barwizi

  • Hero Member
  • *****
  • Posts: 764
  • Noirbits, NoirShares, NoirEx.....lol, noir anyone?
    • View Profile
    • Noirbitstalk.org
Re: MMC Ubuntu compile error
« Reply #2 on: January 31, 2014, 05:40:25 PM »
thanks, i got past that, but now only to run into this

Code: [Select]
src/qt/walletmodel.cpp: In member function ‘WalletModel::SendCoinsReturn WalletModel::sendCoins(const QList<SendCoinsRecipient>&, const CCoinControl*)’:
src/qt/walletmodel.cpp:196:101: error: no matching function for call to ‘CWallet::CreateTransaction(std::vector<std::pair<CScript, long long int> >&, CWalletTx&, CReserveKey&, int64&, const CCoinControl*&)’
src/qt/walletmodel.cpp:196:101: note: candidates are:
In file included from src/qt/walletmodel.cpp:8:0:
src/wallet.h:186:10: note: bool CWallet::CreateTransaction(std::vector<std::pair<CScript, long long int> >&, CWalletTx&, CReserveKey&, int64&, std::string&, const CCoinControl*)
src/wallet.h:186:10: note:   no known conversion for argument 5 from ‘const CCoinControl*’ to ‘std::string& {aka std::basic_string<char>&}’
src/wallet.h:188:10: note: bool CWallet::CreateTransaction(CScript, int64, CWalletTx&, CReserveKey&, int64&, std::string&, const CCoinControl*)
src/wallet.h:188:10: note:   candidate expects 7 arguments, 5 provided
src/qt/walletmodel.cpp:204:67: error: ‘strFailReason’ was not declared in this scope
make: *** [build/walletmodel.o] Error 1
[email protected]:~/memorycoin-psforkinit/memorycoin-psforkinit$

any idea?
--Bar--  PiNEJGUv4AZVZkLuF6hV4xwbYTRp5etWWJ

The magical land of crypto, no freebies people.

Offline vertoe

  • Jr. Member
  • **
  • Posts: 30
  • i'm here
    • View Profile
Re: MMC Ubuntu compile error
« Reply #3 on: February 01, 2014, 11:45:16 AM »
Not sure on that one but try to initialize the emptry string:

Code: [Select]
        string strFailReason = "";
https://github.com/Nameshar/memorycoin/blob/master/src/qt/walletmodel.cpp#L196

Just curious, what are you trying to do?

/EDIT: I see you already fixed that one :)
« Last Edit: February 01, 2014, 11:47:40 AM by vertoe »

Offline MaxPWR

  • Sr. Member
  • ****
  • Posts: 221
  • Sink 2UR Source
    • View Profile
    • Max's Power Plant
Re: MMC Ubuntu compile error
« Reply #4 on: March 08, 2014, 12:24:25 AM »
Looks like you got past the qt errors and now onto wallet errors?

Do you have bitcoin-qt installed on that machine?

I've found on re-installs some coins need bitcoin installed first...

You can't stop the signal, Mal. Everything goes somewhere, and I go everywhere.

PWR UP: MAXVTEoYhDfWJjvkNm2ZmUhHpYbsPYuybg

 

Google+