Author [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] [EN] [ZH] [ES] [PT] [IT] [DE] [FR] [NL] [TR] [SR] [AR] [RU] Topic: All users, please upgrade your client version to 0.4.5  (Read 2712 times)

0 Members and 1 Guest are viewing this topic.

Offline DACSunlimited

  • Full Member
  • ***
  • Posts: 136
    • View Profile
All users, please upgrade your client version to 0.4.5
« on: August 21, 2014, 09:43:18 PM »

Delegates and other interested users make sure to subscribe to the delegate notification thread: https://bitsharestalk.org/index.php?topic=7067.0

This is a version for all users, provided with GUI.

All Delegates and seed nodes should upgrade their nodes to this version.

Delegates do NOT publish price feeds until confident all delegates, exchanges, and users are upgraded. Publish price feed operation will officially hardfork the chain and freeze old clients.

Download and build from:
https://github.com/dacsunlimited/bitsharesx/releases/tag/0.4.5

Suggestions:
1. Active Delegate, be careful and make sure you are producing blocks during upgrading.
2. The database will re-index if upgrading from 0.4.2 or older.

Change Log:
- [HARDFORK] Required upgrade for all users before starting new market engine
- [CHECKPOINT] Block 282000 - 611197d4a3f90f5c9009559b896f0f5d4a4f4b5f
- [EXCHANGES] Added wallet_get_transaction API command
- Market engine bug fixes
- Improved initial syncing speed
- Fix wallet backup on extremely large wallets
- Fix crashes on exit
- Fix missing CrashReport.DLL issue on windows.
« Last Edit: August 21, 2014, 10:57:57 PM by DACSunlimited »

Offline vikram

Re: All users, please upgrade your client version to 0.4.5
« Reply #1 on: August 21, 2014, 09:54:21 PM »
I recommend all delegates do not publish any price feeds until at least Monday, to give exchanges and other users sufficient time to upgrade.

Offline JA

  • Hero Member
  • *****
  • Posts: 650
    • View Profile
  • Payrate: 666%
Re: All users, please upgrade your client version to 0.4.5
« Reply #2 on: August 21, 2014, 09:55:01 PM »
installed the windows version
it's way faster than before  +5%
« Last Edit: August 21, 2014, 09:58:59 PM by jabbajabba »

Offline Bitshark

  • Full Member
  • ***
  • Posts: 75
    • View Profile
Re: All users, please upgrade your client version to 0.4.5
« Reply #3 on: August 21, 2014, 10:16:39 PM »
"the program cant start because crashrpt1402.dll is missing from your computer"

Offline Gentso1

Re: All users, please upgrade your client version to 0.4.5
« Reply #4 on: August 21, 2014, 10:44:05 PM »
"the program cant start because crashrpt1402.dll is missing from your computer"

I had the same issue in the client the file you need is here
https://bitsharestalk.org/index.php?topic=7161.msg95548#msg95548

Offline cygnify

  • Full Member
  • ***
  • Posts: 118
    • View Profile
Re: All users, please upgrade your client version to 0.4.5
« Reply #5 on: August 21, 2014, 10:49:06 PM »
Is there a guide with step by step instructions how to get this running on ubuntu with gui?

I've tried a couple times using information from a few different sources and never managed to get it running with the gui. Plus it would be nice to have a guide all in one place with working gui, because if I'm having problems I can't be the only one?

Offline DACSunlimited

  • Full Member
  • ***
  • Posts: 136
    • View Profile
Re: All users, please upgrade your client version to 0.4.5
« Reply #6 on: August 21, 2014, 10:58:38 PM »
"the program cant start because crashrpt1402.dll is missing from your computer"

Just re-download the program if you still have problem. Installer has just been fixed and re-uploaded.
« Last Edit: August 21, 2014, 10:59:49 PM by vikram »

Offline puppies

Re: All users, please upgrade your client version to 0.4.5
« Reply #7 on: August 21, 2014, 11:07:21 PM »
Is there a guide with step by step instructions how to get this running on ubuntu with gui?

I've tried a couple times using information from a few different sources and never managed to get it running with the gui. Plus it would be nice to have a guide all in one place with working gui, because if I'm having problems I can't be the only one?
https://bitsharestalk.org/index.php?topic=6008.msg81582#msg81582 has a step by step.  Let me know where youre getting stuck.
https://metaexchange.info | Bitcoin<->Altcoin exchange | Instant | Safe | Low spreads

Offline cygnify

  • Full Member
  • ***
  • Posts: 118
    • View Profile
Re: All users, please upgrade your client version to 0.4.5
« Reply #8 on: August 22, 2014, 12:11:11 AM »
Looks like I didn't install Qt properly last few times. Trying arhag's instructions now, let you know if I get stuck, should be OK.

Offline puppies

Re: All users, please upgrade your client version to 0.4.5
« Reply #9 on: August 22, 2014, 12:18:47 AM »
Looks like I didn't install Qt properly last few times. Trying arhag's instructions now, let you know if I get stuck, should be OK.

Installing and setting qt up manually is a pain in the butt. 
Code: [Select]
sudo apt-get install qt5-default libqt5webkit5-dev  works for me on 14.04

And its way easier.
https://metaexchange.info | Bitcoin<->Altcoin exchange | Instant | Safe | Low spreads

Offline RejectKid

  • Full Member
  • ***
  • Posts: 87
    • View Profile
    • Facebook Profile
Re: All users, please upgrade your client version to 0.4.5
« Reply #10 on: August 22, 2014, 12:22:48 AM »
Something seems wrong, It sits here until it eventually crashes

https://www.dropbox.com/s/9htym8knvz8xhcy/Screenshot%202014-08-21%2020.21.06.png
PTS: Pu4ahefp2nMXeQw2cxome8g6V9B4faLx81 BTC: 1NcZg4xF9zSCNUpVanfwfMJY7kqAXtdrbu MMC: MWsdbnkdZRPNEQru1YeeATZTGmqhuSYFoN
Reddit: www.reddit.com/r/protoshare www.reddit.com/r/memorycoin

Offline maqifrnswa

  • Hero Member
  • *****
  • Posts: 661
    • View Profile
Re: All users, please upgrade your client version to 0.4.5
« Reply #11 on: August 22, 2014, 12:23:37 AM »
PPA and my delegate are up and running
maintains an Ubuntu PPA: https://launchpad.net/~showard314/+archive/ubuntu/bitshares [15% delegate] wallet_account_set_approval maqifrnswa true [50% delegate] wallet_account_set_approval delegate1.maqifrnswa true

Offline bytemaster

Re: All users, please upgrade your client version to 0.4.5
« Reply #12 on: August 22, 2014, 12:46:13 AM »

Something seems wrong, It sits here until it eventually crashes

https://www.dropbox.com/s/9htym8knvz8xhcy/Screenshot%202014-08-21%2020.21.06.png

That is an issue that has been fixed in 4.5.  If you are still having this issue after restart then post the result. Of the console command about. 


Sent from my iPhone using Tapatalk
For the latest updates checkout my blog: http://bytemaster.bitshares.org
Anything said on these forums does not constitute an intent to create a legal obligation or contract between myself and anyone else.   These are merely my opinions and I reserve the right to change them at any time.

Offline cygnify

  • Full Member
  • ***
  • Posts: 118
    • View Profile
Re: All users, please upgrade your client version to 0.4.5
« Reply #13 on: August 22, 2014, 12:52:20 AM »
Looks like I didn't install Qt properly last few times. Trying arhag's instructions now, let you know if I get stuck, should be OK.

Installing and setting qt up manually is a pain in the butt. 
Code: [Select]
sudo apt-get install qt5-default libqt5webkit5-dev  works for me on 14.04

And its way easier.

Well followed those instructions perfectly. Get to last step to run BitSharesX and it can't find the file because it wasn't there. I had no errors up until that point, and I did install Qt manually, wish I had known about the other option. I think a proper guide is very much in order for this...

Edit: Oh wait the BitSharesX program was in cd ~/bitsharesx-build/programs/qt_wallet/bin
any reason why it is in bin? Should I move it or Ok to run from there?
« Last Edit: August 22, 2014, 12:56:56 AM by cygnify »

Offline puppies

Re: All users, please upgrade your client version to 0.4.5
« Reply #14 on: August 22, 2014, 01:01:23 AM »
Looks like I didn't install Qt properly last few times. Trying arhag's instructions now, let you know if I get stuck, should be OK.

Installing and setting qt up manually is a pain in the butt. 
Code: [Select]
sudo apt-get install qt5-default libqt5webkit5-dev  works for me on 14.04

And its way easier.

Well followed those instructions perfectly. Get to last step to run BitSharesX and it can't find the file because it wasn't there. I had no errors up until that point, and I did install Qt manually, wish I had known about the other option. I think a proper guide is very much in order for this...

Edit: Oh wait the BitSharesX program was in cd ~/bitsharesx-build/programs/qt_wallet/bin
any reason why it is in bin? Should I move it or Ok to run from there?

run it from there.  I updated my instructions in the thread I linked.
https://metaexchange.info | Bitcoin<->Altcoin exchange | Instant | Safe | Low spreads

 

Google+