Author Topic: MUSE Seed Nodes  (Read 1535 times)

0 Members and 1 Guest are viewing this topic.

Offline Riverhead

MUSE Seed Nodes
« on: October 27, 2015, 11:59:44 am »

I have started a seed node on a dedicated server: 185.82.203.92:8090



edit: Port updated to comply with existing docs.
« Last Edit: October 27, 2015, 06:06:09 pm by Riverhead »

Offline liondani

  • Hero Member
  • *****
  • Posts: 3717
  • Inch by inch, play by play
    • View Profile
    • My detailed info
  • BitShares: liondani
  • GitHub: liondani
Re: MUSE Seed Nodes
« Reply #1 on: October 29, 2015, 11:29:52 am »

I have started a seed node on a dedicated server: 185.82.203.92:8090



edit: Port updated to comply with existing docs.

I try to start my witness node on muse using your seednode with this command:
./witness_node --rpc-endpoint "127.0.0.1:8090" -s "185.82.203.92:8090" --resync-blockchain
 but I am stuck here:

Code: [Select]
[email protected] ~/muse/programs/witness_node $ ./witness_node --rpc-endpoint "127.0.0.1:8090" -s "185.82.203.92:8090" --resync-blockchain
1645185ms th_a       witness.cpp:86                plugin_initialize    ] witness plugin:  plugin_initialize() begin
1645185ms th_a       witness.cpp:96                plugin_initialize    ] key_id_to_wif_pair: ["MUSE6M############################CV","5K####################################3"]
1645185ms th_a       witness.cpp:114               plugin_initialize    ] witness plugin:  plugin_initialize() end
1645185ms th_a       db_management.cpp:101         wipe                 ] Wiping database
1645188ms th_a       object_database.cpp:84        wipe                 ] Wiping object database...
1645196ms th_a       object_database.cpp:86        wipe                 ] Done wiping object databse.
1645196ms th_a       object_database.cpp:91        open                 ] Opening object database from /home/liondani/muse/programs/witness_node/witness_node_data_dir/blockchain ...
1645196ms th_a       object_database.cpp:97        open                 ] Done opening object database.
1645197ms th_a       application.cpp:248           operator()           ] Initializing database...
1646245ms th_a       db_debug.cpp:82               debug_dump           ] total_balances[asset_id_type()].value: 0 core_asset_data.current_supply.value: 15000000000000
1646254ms th_a       thread.cpp:95                 thread               ] name:ntp tid:140312819603200
1646254ms th_a       thread.cpp:95                 thread               ] name:p2p tid:140312802817792
1646466ms th_a       application.cpp:128           reset_p2p_node       ] Adding seed node 185.82.203.92:8090
1646467ms th_a       application.cpp:140           reset_p2p_node       ] Configured p2p node to listen on 0.0.0.0:57940
1646468ms th_a       application.cpp:190           reset_websocket_serv ] Configured websocket rpc to listen on 127.0.0.1:8090
1646468ms th_a       witness.cpp:119               plugin_startup       ] witness plugin:  plugin_startup() begin
1646468ms th_a       witness.cpp:136               plugin_startup       ] No witnesses configured! Please add witness IDs and private keys to configuration.
1646468ms th_a       witness.cpp:137               plugin_startup       ] witness plugin:  plugin_startup() end
1646468ms th_a       main.cpp:176                  main                 ] Started witness node on a chain with 0 blocks.
1646468ms th_a       main.cpp:177                  main                 ] Chain ID is 45ad2d3f9ef92a49b55c2227eb06123f613bb35dd08bd876f2aea21925a67a67
1646502ms ntp        ntp.cpp:177                   read_loop            ] ntp_delta_time updated to -2099 us

Am I doing something wrong or is your seed-node not running?

Offline xeroc

  • Board Moderator
  • Hero Member
  • *****
  • Posts: 12866
  • ChainSquad GmbH
    • View Profile
    • ChainSquad GmbH
  • BitShares: xeroc
  • GitHub: xeroc
Re: MUSE Seed Nodes
« Reply #2 on: October 29, 2015, 11:39:05 am »
-s "185.82.203.92:8090" inidicates a seed node .. but I don't think that the seed node's P2P port is on port 8090 ..
try 9090 instead
Give BitShares a try! Use the http://testnet.bitshares.eu provided by http://bitshares.eu powered by ChainSquad GmbH

Offline Riverhead

Re: MUSE Seed Nodes
« Reply #3 on: October 29, 2015, 12:12:58 pm »

It is running on 8090. Are you still having issues with it? I have my Muse client pointed to it without issue.

Offline JA

  • Hero Member
  • *****
  • Posts: 650
    • View Profile
Re: MUSE Seed Nodes
« Reply #4 on: October 29, 2015, 02:24:40 pm »
yesterday i also couldnt connect to reiverheads node.
i just used the one on the release page.

Offline liondani

  • Hero Member
  • *****
  • Posts: 3717
  • Inch by inch, play by play
    • View Profile
    • My detailed info
  • BitShares: liondani
  • GitHub: liondani
Re: MUSE Seed Nodes
« Reply #5 on: October 29, 2015, 02:52:23 pm »

It is running on 8090. Are you still having issues with it? I have my Muse client pointed to it without issue.

still the same issues...
have you used a command like this to run your seed node?:
./witness_node --rpc-endpoint 127.0.0.1:8090 --p2p-endpoint 0.0.0.0:8090

Maybe you pointed to your seed-node but in reality you are connected with the official one(?)
it's important you use address 0.0.0.0  for your p2p endpoint I think... do you?

edit: and you have no problem because you have locally connected to you seed node... I bet you don't used 0.0.0.0:8090 address for p2p endpoint
« Last Edit: October 29, 2015, 03:04:52 pm by liondani »

Offline liondani

  • Hero Member
  • *****
  • Posts: 3717
  • Inch by inch, play by play
    • View Profile
    • My detailed info
  • BitShares: liondani
  • GitHub: liondani
Re: MUSE Seed Nodes
« Reply #6 on: October 29, 2015, 02:56:51 pm »
yesterday i also couldnt connect to reiverheads node.
i just used the one on the release page.

yep it works with:
54.165.143.33:5197
for me too.

riverhead must run properly his seed node... 

Offline Riverhead

Re: MUSE Seed Nodes
« Reply #7 on: October 29, 2015, 03:09:53 pm »

I just tried the --p2p-endpoint flag and my Muse client stopped working. Went back to the old command line and it started working again. Hmm.

Code: [Select]
[email protected]:~/github/muse/programs/witness_node$ ./witness_node -s 54.165.143.33:5197 --replay-blockchain  --rpc-endpoint 185.82.203.92:8090
« Last Edit: October 29, 2015, 03:15:48 pm by Riverhead »

Offline liondani

  • Hero Member
  • *****
  • Posts: 3717
  • Inch by inch, play by play
    • View Profile
    • My detailed info
  • BitShares: liondani
  • GitHub: liondani
Re: MUSE Seed Nodes
« Reply #8 on: October 29, 2015, 04:10:44 pm »

I just tried the --p2p-endpoint flag and my Muse client stopped working. Went back to the old command line and it started working again. Hmm.

Code: [Select]
[email protected]:~/github/muse/programs/witness_node$ ./witness_node -s 54.165.143.33:5197 --replay-blockchain  --rpc-endpoint 185.82.203.92:8090

try this:
[email protected]:~/github/muse/programs/witness_node$ ./witness_node -s 54.165.143.33:5197 --rpc-endpoint 127.0.0.1:8090 --p2p-endpoint 0.0.0.0:9090

(use different ports for rpc & p2p )
« Last Edit: October 29, 2015, 04:16:21 pm by liondani »

Offline liondani

  • Hero Member
  • *****
  • Posts: 3717
  • Inch by inch, play by play
    • View Profile
    • My detailed info
  • BitShares: liondani
  • GitHub: liondani
Re: MUSE Seed Nodes
« Reply #9 on: October 29, 2015, 04:17:11 pm »

I have started a seed node on a dedicated server: 185.82.203.92:8090



edit: Port updated to comply with existing docs.

...and change it to port 9090

Offline puppies

  • Hero Member
  • *****
  • Posts: 1659
    • View Profile
  • BitShares: puppies
Re: MUSE Seed Nodes
« Reply #10 on: October 29, 2015, 08:47:23 pm »
I have gotten my seed node up and running on 45.55.13.98:1776

Took me awhile to get it working with my script that restarts it in case of low witness participation or a crash.  Was totally a stupid error on my part.  It is now up and running.
https://metaexchange.info | Bitcoin<->Altcoin exchange | Instant | Safe | Low spreads

Offline Riverhead

Re: MUSE Seed Nodes
« Reply #11 on: October 30, 2015, 02:08:47 am »
I have gotten my seed node up and running on 45.55.13.98:1776

Took me awhile to get it working with my script that restarts it in case of low witness participation or a crash.  Was totally a stupid error on my part.  It is now up and running.

Ah, I see the issue. I was running an API server and not a seed node. Fixed.

Offline lafona

  • Sr. Member
  • ****
  • Posts: 229
    • View Profile
  • BitShares: lafona
Re: MUSE Seed Nodes
« Reply #12 on: November 07, 2015, 03:42:39 am »
I have added a seed node at 52.20.134.30:39706
BTS Witnesses: delegate-1.lafona     Witness Thread: https://bitsharestalk.org/index.php/topic,21569.msg280911/topicseen.html#msg280911
MUSE Witness: lafona

Offline roadscape

Re: MUSE Seed Nodes
« Reply #13 on: January 26, 2016, 01:48:26 am »
I have gotten my seed node up and running on 45.55.13.98:1776

Took me awhile to get it working with my script that restarts it in case of low witness participation or a crash.  Was totally a stupid error on my part.  It is now up and running.

I think there might be an issue with the main seed node (54.165.143.33:5197), I couldn't get the witness_node to resync.. yours did the trick.. thanks!
http://cryptofresh.com  |  witness: roadscape