Author Topic: what's the version for node and npm?  (Read 1033 times)

0 Members and 1 Guest are viewing this topic.

Offline alt

  • Hero Member
  • *****
  • Posts: 2821
    • View Profile
  • BitShares: baozi
what's the version for node and npm?
« on: November 12, 2015, 04:34:15 am »
I upgrade my ubuntu 1404 today, and the graphene-ui can't run now.
what version for node and npm are recommand?

Offline svk

Re: what's the version for node and npm?
« Reply #1 on: November 12, 2015, 08:27:56 am »
I upgrade my ubuntu 1404 today, and the graphene-ui can't run now.
what version for node and npm are recommand?

I've run it will all kinds of different versions, 0.10.x, 0.12.x, 0.4.0. 0.12.x is your best bet though.

Use nvm and remember to rm -rf node_modules and reinstall with npm install whenever you change node version.

https://github.com/creationix/nvm

Worker: dev.bitsharesblocks

Offline alt

  • Hero Member
  • *****
  • Posts: 2821
    • View Profile
  • BitShares: baozi
Re: what's the version for node and npm?
« Reply #2 on: November 12, 2015, 03:03:12 pm »
thanks, don't know why, I have to change some source code, based tag 2.0.151111

Code: [Select]
npm install babel-polyfill
npm install react-responsive-mixin

Code: [Select]
diff --git a/web/app/assets/loader-dev.js b/web/app/assets/loader-dev.js
index b567eba..4b281ab 100644
--- a/web/app/assets/loader-dev.js
+++ b/web/app/assets/loader-dev.js
@@ -1,6 +1,6 @@
 require("./stylesheets/app.scss");
 require("file?name=index.html!./index-dev.html");
 require("file?name=favicon.ico!./favicon.ico");
-require("babel/polyfill");
+require("babel-core/polyfill");
 require("whatwg-fetch");
 require("indexeddbshim");
diff --git a/web/app/assets/stylesheets/app.scss b/web/app/assets/stylesheets/app.scss
index 26f77e9..b976e10 100644
--- a/web/app/assets/stylesheets/app.scss
+++ b/web/app/assets/stylesheets/app.scss
@@ -1,5 +1,5 @@
 @import "./foundation_settings";
[email protected] "~react-foundation-apps/node_modules/foundation-apps/scss/foundation.scss";
[email protected] "~foundation-apps/scss/foundation.scss";
 @import "./foundation_overrides";
 @import "~react-tooltip/dist/react-tooltip.scss";
 @import "./forms";
diff --git a/web/app/workers/AesWorker.js b/web/app/workers/AesWorker.js
index a2f041d..b27877a 100644
--- a/web/app/workers/AesWorker.js
+++ b/web/app/workers/AesWorker.js
@@ -1,4 +1,4 @@
-require("babel/polyfill");
+require("babel-core/polyfill");
 var key = require('common/key_utils')
 var Aes = require('ecc/aes')

Offline maqifrnswa

  • Hero Member
  • *****
  • Posts: 661
    • View Profile
Re: what's the version for node and npm?
« Reply #3 on: November 15, 2015, 08:36:58 pm »
thanks, don't know why, I have to change some source code, based tag 2.0.151111

thanks alt, I had something similar. I didn't need more modules, just this part of your patch on node version 5.0.0
Code: [Select]
diff --git a/web/app/assets/stylesheets/app.scss b/web/app/assets/stylesheets/app.scss
index 26f77e9..b976e10 100644
--- a/web/app/assets/stylesheets/app.scss
+++ b/web/app/assets/stylesheets/app.scss
@@ -1,5 +1,5 @@
 @import "./foundation_settings";
[email protected] "~react-foundation-apps/node_modules/foundation-apps/scss/foundation.scss";
[email protected] "~foundation-apps/scss/foundation.scss";
 @import "./foundation_overrides";
 @import "~react-tooltip/dist/react-tooltip.scss";
 @import "./forms";
maintains an Ubuntu PPA: https://launchpad.net/~showard314/+archive/ubuntu/bitshares [15% delegate] wallet_account_set_approval maqifrnswa true [50% delegate] wallet_account_set_approval delegate1.maqifrnswa true