Author Topic: Problem with client upgrade  (Read 886 times)

0 Members and 1 Guest are viewing this topic.

Offline Chuckone

  • Sr. Member
  • ****
  • Posts: 314
    • View Profile
Problem with client upgrade
« on: August 22, 2014, 12:42:49 am »
I'll try to explain my problem here, not sure if it's exactly the right place to do it, but that would be a start.

I saw there was a new client version for LTS, I guess because of the "hard fork"... anyway, not sure I did it the right way, most probably someone will be able to help me.

I uninstalled the older client (I had redeemed my LTS for my PTS/AGS already, but I guess since I didn't erase manually the wallet, it might still be somewhere) and installed the new version. I thought about it after, I know now I should have made a backup of my wallet file first.

Now when I try to start the client, I have the message "Incorrect or no genesis block found. Wrong datadir for network?" message appearing, and I can't seem to find my wallet either. I might appear to be incredibly newb or illiterate of how all this work, but I can live with that.

Is there a solution, or have I just easily got rid of my LTS without having the pleasure of playing them?

Thanks for the help!


Offline pc

  • Hero Member
  • *****
  • Posts: 1389
    • View Profile
    • Bitcoin - Perspektive oder Risiko?
  • BitShares: cyrano
Re: Problem with client upgrade
« Reply #1 on: August 22, 2014, 08:39:03 am »
You must delete the old blockchain and re-download the new one.

0. Shut down the lottoshares client
1. Go to $HOME/.lottoshares (or its equivalent on windows, whatever that may be)
2. Back up everything, especially wallet.dat
3. Delete everything EXCEPT wallet.dat
4. Start lottoshares client
Bitcoin - Perspektive oder Risiko? ISBN 978-3-8442-6568-2 http://bitcoin.quisquis.de