Author Topic: AMD OpenCL Momentum miner  (Read 144028 times)

0 Members and 1 Guest are viewing this topic.

Offline xxx2003gs

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #435 on: February 18, 2014, 08:34:42 pm »
Has anyone successfully set the GPU voltage using cgminer under linux for a R9 290(X)?
I have my gpu clock, memory, and fan settings where I want them to be but I wouldn't
mind under-volting the GPU to save a little energy and heat. I *believe* cgminer wants
an exact voltage and not a delta but I could be wrong. I don't know what the normal
voltage is for a R9 290 and every attempt to enter an absolute value like 1.25 fails (out
of boundary). Many thanks in advance!

I have been in that same situation for the last two days. I found some good clocks that provide a rather good performance boost in-terms of c/m. I have my 290X's running at 1150/1150. The core increase raised my c/m by ~400, the problem is that I am having some heating issues (80C - 85C - 90C spikes)...I'll try to figure out a way to undervolt on linux, I'll post my solution here if I find anything. If you find something please share.

At the moment I have multiple .sh files that I execute after a system reboot. One sets the fan speed to 100%, and then overclocks my GPUs, one to initialize the miner, and the last one to monitor temps.

Edit: I found this http://sourceforge.net/projects/amdovdrvctrl/?source=navbar, I'll give it a try once I get home. It was last update Dec 13 2013.
how to set the fan speed to 100%? with multiple GPU Fan speed? @ubuntu 12.04

Offline mbender71

  • Jr. Member
  • **
  • Posts: 36
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #436 on: February 18, 2014, 08:45:51 pm »
how to set the fan speed to 100%? with multiple GPU Fan speed? @ubuntu 12.04

Hint : cgminer..... aticonfig does NOT work under linux with more than one GPU

Offline wsnnwa

  • Jr. Member
  • **
  • Posts: 47
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #437 on: February 18, 2014, 09:16:01 pm »
how to set the fan speed to 100%? with multiple GPU Fan speed? @ubuntu 12.04

Hint : cgminer..... aticonfig does NOT work under linux with more than one GPU

It works, just use the following.

export DISPLAY=:0
aticonfig --pplib-cmd "set fanspeed 0 100"

export DISPLAY=:0.1
aticonfig --pplib-cmd "set fanspeed 0 100"

"export DISPLAY=:0.X" --> Change X to whatever GPU you want to change the fan speed on.

Offline mbender71

  • Jr. Member
  • **
  • Posts: 36
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #438 on: February 18, 2014, 09:19:47 pm »
It works, just use the following.

export DISPLAY=:0
aticonfig --pplib-cmd "set fanspeed 0 100"

export DISPLAY=:0.1
aticonfig --pplib-cmd "set fanspeed 0 100"

"export DISPLAY=:0.X" --> Change X to whatever GPU you want to change the fan speed on.

Woah! I was always using the --adapter=x parameter with aticonfig and couldn't ever get it to
display/set values of anything but the default display. Knowing this will really help! Many thanks
for the education!

Offline montecristo83

  • Full Member
  • ***
  • Posts: 51
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #439 on: February 18, 2014, 09:38:04 pm »
Think I found the sweet-spot for my cards. The R9 280X ASUS DC2T's are amazing! These results are from 24-48 hours of mining.

W7 64
4GB RAM

3x 280X ASUS DC2T @ 1160/1600 and 1x 280X Gigabyte Windforce 3X @ 1100/1500 with the flags -t 0,0,1,1,2,2,3,3 -a 2. Total = 14374 CPM. (Avg is ~3593 CPM.)

Temps are ranging from 62C to 72C at 60% fan-speed with ambient at 25C-30C depending on the time of day. If running 4 instances, one for each card, each card would hit 3300-3400 CPM (why?).

My single 280X Sapphire Dual-X @ 1100/1500 hits 3362 CPM. It has low ASIC rating and fans that apparently are prone to fail; I'm just gonna leave this as is.
« Last Edit: February 18, 2014, 09:40:37 pm by montecristo83 »

Offline morecpmplz

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #440 on: February 19, 2014, 12:19:48 am »
how to set the fan speed to 100%? with multiple GPU Fan speed? @ubuntu 12.04

Hint : cgminer..... aticonfig does NOT work under linux with more than one GPU

It works, just use the following.

export DISPLAY=:0
aticonfig --pplib-cmd "set fanspeed 0 100"

export DISPLAY=:0.1
aticonfig --pplib-cmd "set fanspeed 0 100"

"export DISPLAY=:0.X" --> Change X to whatever GPU you want to change the fan speed on.

Would this work for overclocking cards like 270's with aticonfig?

Offline Bigboppa

  • Jr. Member
  • **
  • Posts: 30
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #441 on: February 19, 2014, 12:49:31 am »
Think I found the sweet-spot for my cards. The R9 280X ASUS DC2T's are amazing! These results are from 24-48 hours of mining.

W7 64
4GB RAM

3x 280X ASUS DC2T @ 1160/1600 and 1x 280X Gigabyte Windforce 3X @ 1100/1500 with the flags -t 0,0,1,1,2,2,3,3 -a 2. Total = 14374 CPM. (Avg is ~3593 CPM.)

You are right! -a 2 seems to be a little bit faster than -a 1, at least at the R9 280X ASUS DC2T. I have only 2 of them, gives me 7350 cpm with -t 0,0,1,1 -a 2
Cards are running at 1200/1800 with special memory-timing bios (Stilt, ASUS_C386PI3_DC2T_SS2_AGR)

Offline wsnnwa

  • Jr. Member
  • **
  • Posts: 47
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #442 on: February 19, 2014, 02:07:57 am »
how to set the fan speed to 100%? with multiple GPU Fan speed? @ubuntu 12.04

Hint : cgminer..... aticonfig does NOT work under linux with more than one GPU

It works, just use the following.

export DISPLAY=:0
aticonfig --pplib-cmd "set fanspeed 0 100"

export DISPLAY=:0.1
aticonfig --pplib-cmd "set fanspeed 0 100"

"export DISPLAY=:0.X" --> Change X to whatever GPU you want to change the fan speed on.

Would this work for overclocking cards like 270's with aticonfig?

I still don't have a proper method for undervolting on Linux. I use the following to overclock core and memory.

aticonfig --adapter=0 --od-setclocks=1140,1500

just change adapter number for different GPU's, also [Core, Memory]

Offline Darkbane

  • Full Member
  • ***
  • Posts: 119
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #443 on: February 19, 2014, 06:01:32 am »
R9 270X 4GB   <--- 4GB version...

anyone with these 4GB cards, running two threads per card???

out of curiosity I decided to start doing it, and it works out pretty good... its got the memory (with room to spare) to run both threads and I've gotten a roughly 300cpm increase on each card, so I thought I would ask around... I had only been using the 280X cards with two threads, and was wondering why I never saw anyone mention the 4GB 270X cards with two threads, I know most 270 series come with only 2GB and won't do this, but for those with them, what are your results?

guess I will find out in 8 hours how well the results hold...

UPDATE :: well after 8 hours it seems I am getting a 428 cpm increase per card and holding... I guess you really can squeeze a lot out of a 4GB 270X card... almost 2000 cpm per card... (wish the other cards weren't 2GB now)
« Last Edit: February 19, 2014, 04:48:05 pm by Darkbane »

Offline Outlawed

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #444 on: February 19, 2014, 12:29:23 pm »

I still don't have a proper method for undervolting on Linux. I use the following to overclock core and memory.

aticonfig --adapter=0 --od-setclocks=1140,1500

just change adapter number for different GPU's, also [Core, Memory]

Is this the correct way to OC? I just used this for my 290x and set the clocks as 1150,1150. I was asked to confirm it and did so using the command supplied. It then displayed overdrive was enabled.

My CPM hasn't changed at all though. Was about 3900 before hand and still is. Using flags -a 0 -t 0,0

Edit: Duh. Need to run the original command again after enabling overdrive.
« Last Edit: February 19, 2014, 06:07:51 pm by Outlawed »

Offline flo2005

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #445 on: February 19, 2014, 01:05:15 pm »
Hi guys,

Not able to reach "normal" score on my side. Only having 3000 cm on the following rig:
Win 8.1
Catalyst 13.12 whql (also tested beta 14 but lower score)
Sapphire r9 290 @1125/1270
-t 0,0 -a 1 (other values do lower score!)
I also have a gtx780 running on the same computer. But dont think it is important... At least I hope xD

Any suggestion please?
« Last Edit: February 19, 2014, 02:11:06 pm by flo2005 »

Offline morecpmplz

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #446 on: February 19, 2014, 06:02:19 pm »
how to set the fan speed to 100%? with multiple GPU Fan speed? @ubuntu 12.04

Hint : cgminer..... aticonfig does NOT work under linux with more than one GPU

It works, just use the following.

export DISPLAY=:0
aticonfig --pplib-cmd "set fanspeed 0 100"

export DISPLAY=:0.1
aticonfig --pplib-cmd "set fanspeed 0 100"

"export DISPLAY=:0.X" --> Change X to whatever GPU you want to change the fan speed on.

Would this work for overclocking cards like 270's with aticonfig?

I still don't have a proper method for undervolting on Linux. I use the following to overclock core and memory.

aticonfig --adapter=0 --od-setclocks=1140,1500

just change adapter number for different GPU's, also [Core, Memory]

I get the following when using aticonfig to try to overclock my 270's... It may because they are on the same system as my 290x's.

Code: [Select]
sudo aticonfig --adapter=1 --od-setclocks=1150,1500
invalid input. Please use the following format
"--od-setclocks=<NewCoreClock>,<NewMemoryClock>,<PowerState>,<Performance Level>"

Offline AceCobra1

  • Jr. Member
  • **
  • Posts: 22
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #447 on: February 19, 2014, 06:11:40 pm »
I am getting a lot of "share data time overflow".... any ideas ??

Offline Darkbane

  • Full Member
  • ***
  • Posts: 119
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #448 on: February 19, 2014, 06:13:29 pm »

I get the following when using aticonfig to try to overclock my 270's... It may because they are on the same system as my 290x's.

Code: [Select]
sudo aticonfig --adapter=1 --od-setclocks=1150,1500
invalid input. Please use the following format
"--od-setclocks=<NewCoreClock>,<NewMemoryClock>,<PowerState>,<Performance Level>"

are you sure the BIOS has 1150 as a valid range on a 270 (non-x) card? I think mine were capped at 1050 in the BIOS... have you tried just raising slightly above regular clock speeds and keep adding on top of that as it works?

Offline crazycoin

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: fast AMD OpenCL PTS miner released
« Reply #449 on: February 19, 2014, 06:24:50 pm »
Can you help me, ypool version has stopped working on Ubuntu 13.10. I am getting following message:

spawning 5 worker threads
Segmentation fault (core dumped)