Author Topic: New YAM version release  (Read 61638 times)

0 Members and 1 Guest are viewing this topic.

Offline Delinquency

  • Sr. Member
  • ****
  • Posts: 370
    • View Profile
Re: New YAM version release
« Reply #105 on: February 20, 2014, 09:41:48 pm »
Guys, please help me with installation on linux.
I have VPS in cloud with proc, having aes-ni support, but even with aesni=off i got this:
(-> Illegal instruction (core dumped))

On my windows everything is ok, farming with aesni=on.

Maybe i must install some dependencies ?



I only get that error if I run a YAM executable that is not compatible with my processor.

Please check on your processor type again.
Just try a different version of YAM.

i downloaded correct version ivy-bridge, my proc has ivy-bridge architecture, but yam don't work :( how can i check what is illegal instruction i have? Please help

Offline shadow32

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: New YAM version release
« Reply #106 on: February 20, 2014, 10:55:10 pm »
I keep getting error 1300 on YAM for huge pages. I have went under user rights management and added my account but still getting the error. I went back and added every group and user but am still getting the error. Can anyone help?

Offline isiarj20

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: New YAM version release
« Reply #107 on: February 21, 2014, 10:12:30 pm »
I tryed with a Xeon 5605 and Works fine, with an E3-3103(or similar) and goes well, but I have a problem with a Xeon E5504, the yam miner only Works with the aes-ni option disabled but this procesor has the aes-ni instructions set...., I tryed with the generic and the Sandy bridge versions, but has the same problem, any help? Thanks.

Offline mjs

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: New YAM version release
« Reply #108 on: February 21, 2014, 11:16:46 pm »
Nope it doesn't, this Xeon is Nehalem-based. Gulftown and Clarkdale were first to intruduce AES instruction set.

Offline balthazr

  • Jr. Member
  • **
  • Posts: 43
    • View Profile
Re: New YAM version release
« Reply #109 on: February 22, 2014, 04:23:13 am »
HI all, i'm running on ubuntu server, it run well.
But i hear someone on ypool memtion that if we can enable the huge and also attach thread to physical socket, it would be more performance?
Anyone know how to setup the numactl and huge please help.
My server config as below.

Quote
numactl -s
policy: default
preferred node: current
physcpubind: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
cpubind: 0
nodebind: 0
membind: 0

numactl -H
available: 1 nodes (0)
node 0 cpus: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
node 0 size: 30681 MB
node 0 free: 28979 MB
node distances:
node   0
  0:  10

Thanks.

Offline asquirrel

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: New YAM version release
« Reply #110 on: February 22, 2014, 04:46:13 pm »
Hello folks,

I have been having a real bear of a time getting huge pages enabled and working with the miner.  Running I-5 3570 Ivy Bridge.  overclocked to 4.4 ghz.  8 gigs of ram.  Windows 7 64 bit ultimate. 

Error message is as follows (see below in more detail)

Can not allocate hugepages memory, error=1450
Warning: MemoryCoin2 memory block for thread 2 allocated in non-hugepages memory
 - thread performance may degrade

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\System32>cd\

C:\>cd  yam

C:\yam>go

C:\yam>yam.exe -c yam-mmc.cfg
YAM - Yet Another Miner by yvg1900
yam M7m-win64-ivy-bridge/yvg1900
***************************************************
* Supported coins: PTS                            *
* Author: yvg1900 (Twitter @yvg1900)              *
* XPT protocol: jh (http://ypool.net)             *
*                                                 *
* Addresses for Thanks and Donations:             *
*   PTS: PZxsEQoiMeB6tHcW2ZySBEiCPio1WkxbEL       *
*   XPM: AW2388DEWNEfMH4rP9kcj9yKcMq1QywYT4       *
*   DTC: D6PmUogMigWvXurgFTqm5VLxQeVpXdYQj3       *
*   MMC: MVk7PuJCa9o6qTYeiQRJDd3uHxKXMrQuU6       *
*   LTC: Lby4YjhcAxhmbsdHFb4nYydrwGoiJezZt1       *
*   BTC: 1FxekeK5La7AuF3oxiLzPKnjXyLMrux6VT       *
*   NMC: N9KXqmzEqP7gB2dGHpEZiRMgFjUHNM38FR       *
***************************************************
Loading config file [yam-mmc.cfg]
Miner version: yam M7m-win64-ivy-bridge/yvg1900
Checking target [getwork://[email protected]:8
0:8880:8881:8882:8883/mmc]...
Target OK
Checking target [getwork://[email protected]:80
80:8081:8082:8083/mmc]...
Target OK
Checking target [getwork://MDLTQ29J7BHuxfkBV6JsfMTY5exun7SKcn.mmc_1:[email protected]
.com:8080/mmc]...
Target OK
Checking params [mmc:av=0&aesni=on&m=3072]...
Params OK
Checking MMC Stage 1 optimizations compatibility...
Checking MMC Stage 2 optimizations compatibility...
OK: MMC optimizations are compatible
MemoryCoin: Memory usage 3072M, determine Algorithm Variation by finetuning
Using 3 mining threads as 3 workers
  Will mine 12 rounds for miner developers to support development of the next version
  Follow @yvg1900 on Twitter to get information on new version availability on time
Error: Can not allocate hugepages memory, error=1450
Warning: MemoryCoin2 memory block for thread 2 allocated in non-hugepages memory
 - thread performance may degrade
New MemoryCoin Block nTime 1392944919
MMC Agg. SPM: ?, HPM: ?; Rnds C/I: 0/0, Don. C/I: 0/0; Cfg/Wkr SPM: ?/?, Cfg/Wkr
 HPM: ?/? 0 rnds AV=1, ART=?; FT AV/RT: 1/0, Best AV/RT: 1/0
  work.mmcpool.com: On-line, Shares Submitted 0, Accepted 0
  mmcpool.1gh.com: Idle, Shares Submitted 0, Accepted 0
  mmc.gpools.com: Idle, Shares Submitted 0, Accepted 0
New MemoryCoin Block nTime 1392944924


Running yam-yvg1900-M7m-win64-ivy-bridge.  Running memory coin wallet 0.8.583.0 unk-beta.  I like it better than the standalone since I can jump to that webpage where it gives my mmc stats. 

yam-mmc.cfg settings are:

threads = 3
mining-params = mmc:av=0&aesni=on&m=3072
mine = getwork://[email protected]:80:8880:8881:8882:8883/mmc
mine = getwork://[email protected]:8080:8081:8082:8083/mmc
mine = getwork://MDLTQ29J7BHuxfkBV6JsfMTY5exun7SKcn.mmc_1:[email protected]:8080/mmc
#proxy = socks4a://127.0.0.1:9150
compact-stats = 1
print-timestamps = 0

Running three threads instead of four threads because with four I can't work at all on my system.  I just upgraded my system ram from 4 to 8 gigs. I've tried changing memory settings to 512 but program says it's too small and minimum needs to be 1024 per thread.  I tried going above 3072 and got the same error message (1024 per thread).

I googled this:

https://www.google.com/#q=how+to+enable+large+page+support+in+windows+7+

went into this link:

http://technet.microsoft.com/en-us/library/ms190730%28v=sql.120%29.aspx


To enable the lock pages in memory option

    On the Start menu, click Run. In the Open box, type gpedit.msc.

    The Group Policy dialog box opens.

    On the Group Policy console, expand Computer Configuration, and then expand Windows Settings.

    Expand Security Settings, and then expand Local Policies.

    Select the User Rights Assignment folder.

    The policies will be displayed in the details pane.

    In the pane, double-click Lock pages in memory.

    In the Local Security Policy Setting dialog box, click Add.

    In the Select Users or Groups dialog box, add an account with privileges to run sqlservr.exe.


Foofoobean (my pc) was already set as a user.  I also added "everyone" as a user.  I tried adding "users" but that didn't work.  Then I rebooted and tried again.  Same error message as above.

My HPM right now is around 6.5.  I'm hoping with hugepages enabled  I will get higher HPM.

Any help would be greatly appreciated. 

Offline yvg1900

  • Full Member
  • ***
  • Posts: 197
    • View Profile
  • BitShares: yvg1900
Re: New YAM version release
« Reply #111 on: February 23, 2014, 07:35:11 am »
On Windows, 8Gb of RAM is true minimum of RAM needed for hugepages to work.

AT this physical RAM size, possibility to allocate 1Gb of properly aligned RAM depends on how many and which applications start at boot and login. Even starting and exiting program at boot may cause mem fragmentatoin due to allocations made by other programs while exited one was running.

I recommend trying the consig on machine with 16Gb or more RAM, and once you know the right way to enable it, try on smaller machine.
Follow @yvg1900 on Twitter for yam miner updates and support

Offline asquirrel

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: New YAM version release
« Reply #112 on: February 23, 2014, 05:02:59 pm »
Thanks for your response yvg1900.

Buying another 8 gigs just to get huge pages to work is not possible for me at this time.  Is there anyone here who has gotten huge pages to work on 8 gigs?  Also, you had said that," I recommend trying the consig on machine with 16Gb or more RAM, and once you know the right way to enable it, try on smaller machine."

What do you mean by "the right way to enable it?"  Are there any other commands I should know about to get it to work?  Do you think a memory deframentation program would help?

Best wishes,

asquirrel

*update*

I pulled another 4 gigs from another system that I had in storage and added it to my system for a total of 12 gigs.  It seems that at least in my case, 12 gigs was enough to get the "huge pages" function to work.  MY HPM (at least according the the YAM program running with AV 2) is at 7.6
« Last Edit: February 23, 2014, 09:16:02 pm by asquirrel »

Offline sasio

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: New YAM version release
« Reply #113 on: February 24, 2014, 04:41:20 am »
I have a problem with the version 2 for Bulldozer, it crash right after printing a welcome message with the donations addresses etc.
Code: [Select]
Unhandled exception at 0x005d237e in yam.exe: 0xC000001D: Illegal Instruction.
This what I get from debugger (maybe its going to help)
Code: [Select]
> yam.exe!00000000005d237e()
  [Frames below may be incorrect and/or missing, no symbols loaded for yam.exe]
  yam.exe!00000000004e7389()
  yam.exe!00000000005e756e()
  yam.exe!00000000004013b5()
  yam.exe!00000000004014d8()
  kernel32.dll!0000000076c3652d()
  ntdll.dll!0000000076d6c541()

System: Windows 7 x64
CPU: AMD FX-8150 Stock

I have to note that version 1 work just fine with the performance of about 6.9HPM (3.6GHz, Turbo Off)

Offline feiqinying

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: New YAM version release
« Reply #114 on: February 24, 2014, 10:32:03 am »
start /low yam.exe -c yam-mmc.cfg

threads = 2
mining-params = mmc:av=0&aesni=on&donation-interval=100&m=2048
mine = getwork://[email protected]:8080:8081:8082:8083/mmc
compact-stats = 1
print-timestamps = 0

it does not work

Offline ManeBjorn

  • Full Member
  • ***
  • Posts: 174
    • View Profile
Re: New YAM version release
« Reply #115 on: February 24, 2014, 09:44:53 pm »
Has anyone used one of these yet?  If so what were your results?
Intel E3110 3.0 ghz
Tips Appreciated MMC | MQotia5NmKTsaXXPaN8hw2ze3Z1DNwi39s
https://www.multibet.io/index.php?ref=ManeBjorn

Offline Delinquency

  • Sr. Member
  • ****
  • Posts: 370
    • View Profile
Re: New YAM version release
« Reply #116 on: February 25, 2014, 12:35:46 am »
I have a problem with the version 2 for Bulldozer, it crash right after printing a welcome message with the donations addresses etc.
Code: [Select]
Unhandled exception at 0x005d237e in yam.exe: 0xC000001D: Illegal Instruction.
This what I get from debugger (maybe its going to help)
Code: [Select]
> yam.exe!00000000005d237e()
  [Frames below may be incorrect and/or missing, no symbols loaded for yam.exe]
  yam.exe!00000000004e7389()
  yam.exe!00000000005e756e()
  yam.exe!00000000004013b5()
  yam.exe!00000000004014d8()
  kernel32.dll!0000000076c3652d()
  ntdll.dll!0000000076d6c541()

System: Windows 7 x64
CPU: AMD FX-8150 Stock

I have to note that version 1 work just fine with the performance of about 6.9HPM (3.6GHz, Turbo Off)

I believe v2 works with 9xxx FX CPU's.
start /low yam.exe -c yam-mmc.cfg

threads = 2
mining-params = mmc:av=0&aesni=on&donation-interval=100&m=2048
mine = getwork://[email protected]:8080:8081:8082:8083/mmc
compact-stats = 1
print-timestamps = 0

it does not work

Try with aesni=off

Offline sasio

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: New YAM version release
« Reply #117 on: February 25, 2014, 03:32:37 am »
FX 9xxx is the Piledriver architecture so do x3xx and including APUs.
But Bulldozer the FX x1xx and other variantions support AVX instructions as well (but yes not 1.1 version as Piledriver)

Offline wallace

  • Sr. Member
  • ****
  • Posts: 204
    • View Profile
Re: New YAM version release
« Reply #118 on: February 25, 2014, 05:28:47 pm »
Thanks Yvg1900!

I'm a newbie, and just got a problem when I run with a Haswell-EP Xeon E-2600 CPU to mine the MMC, This is a Haswell CPU. But it seems the program always auto exit after below message:
-----------------------------------------------------------------
Checking MMC Stage 1 optimizations compatibility...
Checking MMC Stage 2 optimizations compatibility...
-----------------------------------------------------------------

I have tried each type folder, still the same issue.

but I can run the same program to mine the PTS on this CPU successfully. what's the problem? Is this CPU compatible with xpt protocol but getwork protocol?

very appreciate if you can answer my question.
give me money, I will do...

Offline yvg1900

  • Full Member
  • ***
  • Posts: 197
    • View Profile
  • BitShares: yvg1900
Re: New YAM version release
« Reply #119 on: February 25, 2014, 06:47:32 pm »
Thanks Yvg1900!

I'm a newbie, and just got a problem when I run with a Haswell-EP Xeon E-2600 CPU to mine the MMC, This is a Haswell CPU. But it seems the program always auto exit after below message:
-----------------------------------------------------------------
Checking MMC Stage 1 optimizations compatibility...
Checking MMC Stage 2 optimizations compatibility...
-----------------------------------------------------------------

I have tried each type folder, still the same issue.

but I can run the same program to mine the PTS on this CPU successfully. what's the problem? Is this CPU compatible with xpt protocol but getwork protocol?

very appreciate if you can answer my question.

Are you 100% sure you have Haswell-EP CPU? What is EXACT CPU model?
Follow @yvg1900 on Twitter for yam miner updates and support